1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time 60
4 %define popup_service_idle_timeout_time 10
6 # Configure engine file system.
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 # concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
21 %define with_sample_engine 1
23 Summary: A general purpose content screening and reputation solution
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd-daemon)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 BuildRequires: pkgconfig(libtzplatform-config)
45 BuildRequires: pkgconfig(cynara-client)
46 Requires: lib%{name}-common = %{version}-%{release}
50 General purpose content screening and reputation solution. Can scan
51 file contents and checking url to prevent malicious items.
53 %global service_name csr
54 %global bin_dir %{_bindir}
55 %global sbin_dir /sbin
56 %global ro_data_dir %{_datadir}
57 %global rw_data_dir /opt/share
58 %global ro_db_dir %{ro_data_dir}/%{service_name}/dbspace
59 %global rw_db_dir %{rw_data_dir}/%{service_name}/dbspace
60 %global ro_res_dir %{ro_data_dir}/%{service_name}/res
61 %global engine_rw_working_dir %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
62 %global engine_dir %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
63 %global test_dir %{rw_data_dir}/%{service_name}-test
64 %global test_res_dir %{ro_data_dir}/%{service_name}-test
66 %global service_user security_fw
67 %global service_group security_fw
68 %global test_user owner
69 %global popup_service_env_file_path /run/tizen-system-env
70 %global smack_domain_name System
71 %global popup_unitdir %{_unitdir_user}
73 %package -n lib%{name}-common
74 Summary: CSR framework (common library)
76 Group: Security/Libraries
77 BuildRequires: pkgconfig(cynara-creds-socket)
78 Requires: %{sbin_dir}/ldconfig
80 %description -n lib%{name}-common
81 Content Screening and Reputation framework package (common library)
83 %package -n lib%{name}-client
84 Summary: CSR framework (client library)
86 Group: Security/Libraries
87 BuildRequires: pkgconfig(capi-base-common)
88 Requires: %{name} = %{version}-%{release}
89 Requires: %{sbin_dir}/ldconfig
91 %description -n lib%{name}-client
92 Content Screening and Reputation framework package (client library)
95 Summary: CSR framework (development files)
97 Group: Security/Development
98 BuildRequires: pkgconfig(capi-base-common)
99 Requires: %{name} = %{version}-%{release}
100 Requires: lib%{name}-client
103 Content Screening and Reputation framework development files like headers and pkgconfigs
105 %package engine-devel
106 Summary: CSR framework (engine development files)
108 Group: Security/Development
110 %description engine-devel
111 Content Screening and Reputation framework engine development files like headers and
115 Summary: CSR framework (test program)
116 License: Apache-2.0 and BSL-1.0
117 Group: Security/Testing
118 BuildRequires: boost-devel
119 BuildRequires: pkgconfig(pkgmgr-info)
120 BuildRequires: pkgconfig(glib-2.0)
121 BuildRequires: pkgconfig(storage)
122 Requires: %{name} = %{version}
125 Content Screening and Reputation framework (test program)
132 # define build architecture
134 %define test_target emulator
136 %define test_target target
140 -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
141 -DCMAKE_VERBOSE_MAKEFILE=ON \
142 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
143 -DSERVICE_USER=%{service_user} \
144 -DSERVICE_GROUP=%{service_group} \
145 -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
146 -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
147 -DSERVICE_NAME=%{service_name} \
148 -DVERSION=%{version} \
149 -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
150 -DBIN_DIR:PATH=%{bin_dir} \
151 -DSYSTEMD_UNIT_DIR=%{_unitdir} \
152 -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
153 -DRO_DBSPACE:PATH=%{ro_db_dir} \
154 -DRW_DBSPACE:PATH=%{rw_db_dir} \
155 -DRO_RES_DIR:PATH=%{ro_res_dir} \
156 -DRO_DATA_DIR:PATH=%{ro_data_dir} \
157 -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
158 -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
159 -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
160 -DENGINE_DIR:PATH=%{engine_dir} \
161 -DTEST_TARGET=%{test_target} \
162 -DTEST_DIR:PATH=%{test_dir} \
163 -DTEST_RES_DIR:PATH=%{test_res_dir} \
164 %if 0%{?with_detailed_base_url}
165 -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
167 %if 0%{?with_sample_engine}
168 -DWITH_SAMPLE_ENGINE:BOOL=ON \
170 -DWITH_SAMPLE_ENGINE:BOOL=OFF \
172 -DTZ_SYS_STORAGE=%TZ_SYS_STORAGE \
173 -DTZ_SYS_RW_APP=%TZ_SYS_RW_APP \
174 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
176 make %{?jobs:-j%jobs}
180 %install_service sockets.target.wants %{service_name}-cs.socket
181 %install_service sockets.target.wants %{service_name}-wp.socket
182 %install_service sockets.target.wants %{service_name}-admin.socket
183 %install_service ../user/sockets.target.wants %{service_name}-popup.socket
185 mkdir -p %{buildroot}%{rw_db_dir}
186 mkdir -p %{buildroot}%{ro_db_dir}
187 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
189 mkdir -p %{buildroot}%{engine_dir}
190 mkdir -p %{buildroot}%{engine_rw_working_dir}
192 %find_lang %{service_name}
195 set_cap_script=%{ro_data_dir}/security-config/set_capability
196 if [ -f $set_cap_script ]; then
200 rm -f %{rw_db_dir}/.%{service_name}.db*
202 systemctl daemon-reload
204 systemctl start %{service_name}-cs.socket
205 systemctl start %{service_name}-wp.socket
206 systemctl start %{service_name}-admin.socket
207 systemctl start %{service_name}.service
209 systemctl --user start %{service_name}-popup.socket
210 systemctl --user start %{service_name}-popup.service
211 elif [ $1 = 2 ]; then
212 systemctl stop %{service_name}-cs.socket
213 systemctl stop %{service_name}-wp.socket
214 systemctl stop %{service_name}-admin.socket
215 systemctl restart %{service_name}.service
217 systemctl --user stop %{service_name}-popup.socket
218 systemctl --user restart %{service_name}-popup.service
223 systemctl stop %{service_name}-cs.socket
224 systemctl stop %{service_name}-wp.socket
225 systemctl stop %{service_name}-admin.socket
226 systemctl stop %{service_name}.service
228 systemctl --user stop %{service_name}-popup.socket
229 systemctl --user stop %{service_name}-popup.service
234 systemctl daemon-reload
237 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
238 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
239 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
240 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
242 %post -n %{name}-test
243 chsmack -a "_" %{test_dir}/test_dir/dir1
244 %if 0%{?with_sample_engine}
245 systemctl stop %{service_name}-cs.socket
246 systemctl stop %{service_name}-wp.socket
247 systemctl stop %{service_name}-admin.socket
248 systemctl restart %{service_name}.service
251 %files -f %{service_name}.lang
252 %defattr(-,root,root,-)
253 %manifest %{service_name}.manifest
255 %license LICENSE.BSL-1.0
256 %{bin_dir}/%{service_name}-server
257 %{bin_dir}/%{service_name}-popup
258 %{_unitdir}/%{service_name}.service
259 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
260 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
261 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
262 %{_unitdir}/%{service_name}-cs.socket
263 %{_unitdir}/%{service_name}-wp.socket
264 %{_unitdir}/%{service_name}-admin.socket
265 %{popup_unitdir}/%{service_name}-popup.socket
266 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
267 %{popup_unitdir}/%{service_name}-popup.service
268 %{ro_res_dir}/default-icon.png
270 %dir %{ro_data_dir}/%{service_name}
271 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
273 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
274 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
277 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
279 %files -n lib%{name}-common
280 %defattr(-,root,root,-)
281 %manifest %{service_name}-common.manifest
283 %{_libdir}/lib%{service_name}-common.so.*
285 %files -n lib%{name}-client
286 %defattr(-,root,root,-)
287 %manifest %{service_name}-client.manifest
289 %{_libdir}/lib%{service_name}-client.so.*
292 %defattr(-,root,root,-)
293 %{_includedir}/csr/csr-content-screening.h
294 %{_includedir}/csr/csr-content-screening-types.h
295 %{_includedir}/csr/csr-web-protection.h
296 %{_includedir}/csr/csr-web-protection-types.h
297 %{_includedir}/csr/csr-error.h
298 %{_includedir}/csr/csr-engine-manager.h
299 %{_libdir}/pkgconfig/%{service_name}.pc
300 %{_libdir}/lib%{service_name}-client.so
301 %{_libdir}/lib%{service_name}-common.so
304 %defattr(-,root,root,-)
305 %{_includedir}/csre/csre-content-screening-engine-info.h
306 %{_includedir}/csre/csre-content-screening.h
307 %{_includedir}/csre/csre-content-screening-types.h
308 %{_includedir}/csre/csre-error.h
309 %{_includedir}/csre/csre-web-protection-engine-info.h
310 %{_includedir}/csre/csre-web-protection.h
311 %{_includedir}/csre/csre-web-protection-types.h
312 %{_libdir}/pkgconfig/%{service_name}-engine.pc
315 %defattr(-,root,root,-)
316 %manifest %{service_name}-test.manifest
318 %license LICENSE.BSL-1.0
319 %{_libdir}/lib%{service_name}-test-common.so
320 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
321 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
322 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
323 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
326 %dir %attr(-, %{test_user}, %{service_group}) %{test_dir}
327 %attr(-, %{test_user}, %{service_group}) %{test_dir}/*
329 %dir %attr(-, %{test_user}, %{service_group}) %{test_res_dir}
330 %attr(-, %{test_user}, %{service_group}) %{test_res_dir}/*
332 # sample engine related files
333 %if 0%{?with_sample_engine}
334 %{engine_dir}/lib%{service_name}-cs-engine.so
335 %{engine_dir}/lib%{service_name}-wp-engine.so
336 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*