Disable gcov
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time       60
4 %define popup_service_idle_timeout_time 10
5
6 # Configure engine file system.
7 #
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
13
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 #                  concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
20
21 %define with_sample_engine 1
22
23 Summary: A general purpose content screening and reputation solution
24 Name: csr-framework
25 Version: 2.3.7
26 Release: 0
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
30 URL: http://tizen.org
31 BuildRequires: cmake
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 BuildRequires: pkgconfig(libtzplatform-config)
45 BuildRequires: pkgconfig(cynara-client)
46 Requires:      lib%{name}-common = %{version}-%{release}
47 %{?systemd_requires}
48
49 %description
50 General purpose content screening and reputation solution. Can scan
51 file contents and checking url to prevent malicious items.
52
53 %global service_name                 csr
54 %global bin_dir                      %{_bindir}
55 %global sbin_dir                     /sbin
56 %global ro_data_dir                  %{_datadir}
57 %global rw_data_dir                  /opt/share
58 %global ro_db_dir                    %{ro_data_dir}/%{service_name}/dbspace
59 %global rw_db_dir                    %{rw_data_dir}/%{service_name}/dbspace
60 %global ro_res_dir                   %{ro_data_dir}/%{service_name}/res
61 %global engine_rw_working_dir        %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
62 %global engine_dir                   %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
63 %global test_dir                     %{rw_data_dir}/%{service_name}-test
64 %global test_res_dir                 %{ro_data_dir}/%{service_name}-test
65
66 %global service_user                 security_fw
67 %global service_group                security_fw
68 %global test_user                    owner
69 %global popup_service_env_file_path  /run/tizen-system-env
70 %global smack_domain_name            System
71 %global popup_unitdir                %{_unitdir_user}
72
73 %package -n lib%{name}-common
74 Summary: CSR framework (common library)
75 License: Apache-2.0
76 Group:   Security/Libraries
77 BuildRequires: pkgconfig(cynara-creds-socket)
78 Requires: %{sbin_dir}/ldconfig
79
80 %description -n lib%{name}-common
81 Content Screening and Reputation framework package (common library)
82
83 %package -n lib%{name}-client
84 Summary: CSR framework (client library)
85 License: Apache-2.0
86 Group:   Security/Libraries
87 BuildRequires: pkgconfig(capi-base-common)
88 Requires: %{name} = %{version}-%{release}
89 Requires: %{sbin_dir}/ldconfig
90
91 %description -n lib%{name}-client
92 Content Screening and Reputation framework package (client library)
93
94 %package devel
95 Summary: CSR framework (development files)
96 LICENSE: Apache-2.0
97 Group:   Security/Development
98 BuildRequires: pkgconfig(capi-base-common)
99 Requires:      %{name} = %{version}-%{release}
100 Requires:      lib%{name}-client
101
102 %description devel
103 Content Screening and Reputation framework development files like headers and pkgconfigs
104
105 %package engine-devel
106 Summary: CSR framework (engine development files)
107 LICENSE: Apache-2.0
108 Group:   Security/Development
109
110 %description engine-devel
111 Content Screening and Reputation framework engine development files like headers and
112 pkgconfigs
113
114 %package test
115 Summary: CSR framework (test program)
116 License: Apache-2.0 and BSL-1.0
117 Group:   Security/Testing
118 BuildRequires: boost-devel
119 BuildRequires: pkgconfig(pkgmgr-info)
120 BuildRequires: pkgconfig(glib-2.0)
121 BuildRequires: pkgconfig(storage)
122 Requires:      boost-test
123 Requires:      %{name} = %{version}
124
125 %description test
126 Content Screening and Reputation framework (test program)
127
128 %prep
129 %setup -q
130
131 %build
132
133 # define build architecture
134 %ifarch %{ix86}
135 %define test_target emulator
136 %else
137 %define test_target target
138 %endif
139
140 %cmake . \
141     -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
142     -DCMAKE_VERBOSE_MAKEFILE=ON \
143     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
144     -DSERVICE_USER=%{service_user} \
145     -DSERVICE_GROUP=%{service_group} \
146     -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
147     -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
148     -DSERVICE_NAME=%{service_name} \
149     -DVERSION=%{version} \
150     -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
151     -DBIN_DIR:PATH=%{bin_dir} \
152     -DSYSTEMD_UNIT_DIR=%{_unitdir} \
153     -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
154     -DRO_DBSPACE:PATH=%{ro_db_dir} \
155     -DRW_DBSPACE:PATH=%{rw_db_dir} \
156     -DRO_RES_DIR:PATH=%{ro_res_dir} \
157     -DRO_DATA_DIR:PATH=%{ro_data_dir} \
158     -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
159     -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
160     -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
161     -DENGINE_DIR:PATH=%{engine_dir} \
162     -DTEST_TARGET=%{test_target} \
163     -DTEST_DIR:PATH=%{test_dir} \
164     -DTEST_RES_DIR:PATH=%{test_res_dir} \
165 %if 0%{?with_detailed_base_url}
166     -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
167 %endif
168 %if 0%{?with_sample_engine}
169     -DWITH_SAMPLE_ENGINE:BOOL=ON \
170 %else
171     -DWITH_SAMPLE_ENGINE:BOOL=OFF \
172 %endif
173     -DTZ_SYS_STORAGE=%TZ_SYS_STORAGE \
174     -DTZ_SYS_RW_APP=%TZ_SYS_RW_APP \
175     -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
176
177 make %{?jobs:-j%jobs}
178
179 %install
180 %make_install
181 %install_service sockets.target.wants %{service_name}-cs.socket
182 %install_service sockets.target.wants %{service_name}-wp.socket
183 %install_service sockets.target.wants %{service_name}-admin.socket
184 %install_service ../user/sockets.target.wants %{service_name}-popup.socket
185
186 mkdir -p %{buildroot}%{rw_db_dir}
187 mkdir -p %{buildroot}%{ro_db_dir}
188 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
189
190 mkdir -p %{buildroot}%{engine_dir}
191 mkdir -p %{buildroot}%{engine_rw_working_dir}
192
193 %find_lang %{service_name}
194
195 %post
196 rm -f %{rw_db_dir}/.%{service_name}.db*
197
198 systemctl daemon-reload
199 if [ $1 = 1 ]; then
200     systemctl start %{service_name}-cs.socket
201     systemctl start %{service_name}-wp.socket
202     systemctl start %{service_name}-admin.socket
203     systemctl start %{service_name}.service
204
205     systemctl --user start %{service_name}-popup.socket
206     systemctl --user start %{service_name}-popup.service
207 elif [ $1 = 2 ]; then
208     systemctl stop %{service_name}-cs.socket
209     systemctl stop %{service_name}-wp.socket
210     systemctl stop %{service_name}-admin.socket
211     systemctl restart %{service_name}.service
212
213     systemctl --user stop %{service_name}-popup.socket
214     systemctl --user restart %{service_name}-popup.service
215 fi
216
217 %preun
218 if [ $1 = 0 ]; then
219     systemctl stop %{service_name}-cs.socket
220     systemctl stop %{service_name}-wp.socket
221     systemctl stop %{service_name}-admin.socket
222     systemctl stop %{service_name}.service
223
224     systemctl --user stop %{service_name}-popup.socket
225     systemctl --user stop %{service_name}-popup.service
226 fi
227
228 %postun
229 if [ $1 = 0 ]; then
230     systemctl daemon-reload
231 fi
232
233 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
234 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
235 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
236 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
237
238 %post -n %{name}-test
239 chsmack -a "_" %{test_dir}/test_dir/dir1
240 %if 0%{?with_sample_engine}
241 systemctl stop %{service_name}-cs.socket
242 systemctl stop %{service_name}-wp.socket
243 systemctl stop %{service_name}-admin.socket
244 systemctl restart %{service_name}.service
245
246 touch %{engine_rw_working_dir}/csret_cs_virus_signatures
247 touch %{engine_rw_working_dir}/csret_wp_risky_urls
248 %endif
249
250 %files -f %{service_name}.lang
251 %defattr(-,root,root,-)
252 %manifest %{service_name}.manifest
253 %license LICENSE
254 %license LICENSE.BSL-1.0
255 %{bin_dir}/%{service_name}-server
256 %{bin_dir}/%{service_name}-popup
257 %{_unitdir}/%{service_name}.service
258 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
259 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
260 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
261 %{_unitdir}/%{service_name}-cs.socket
262 %{_unitdir}/%{service_name}-wp.socket
263 %{_unitdir}/%{service_name}-admin.socket
264 %{popup_unitdir}/%{service_name}-popup.socket
265 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
266 %{popup_unitdir}/%{service_name}-popup.service
267 %{ro_res_dir}/default-icon.png
268
269 %dir %{ro_data_dir}/%{service_name}
270 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
271 %dir %{ro_db_dir}
272 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
273 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
274
275 %dir %{engine_dir}
276 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
277
278 %files -n lib%{name}-common
279 %defattr(-,root,root,-)
280 %manifest %{service_name}-common.manifest
281 %license LICENSE
282 %{_libdir}/lib%{service_name}-common.so.*
283
284 %files -n lib%{name}-client
285 %defattr(-,root,root,-)
286 %manifest %{service_name}-client.manifest
287 %license LICENSE
288 %{_libdir}/lib%{service_name}-client.so.*
289
290 %files devel
291 %defattr(-,root,root,-)
292 %{_includedir}/csr/csr-content-screening.h
293 %{_includedir}/csr/csr-content-screening-types.h
294 %{_includedir}/csr/csr-web-protection.h
295 %{_includedir}/csr/csr-web-protection-types.h
296 %{_includedir}/csr/csr-error.h
297 %{_includedir}/csr/csr-engine-manager.h
298 %{_libdir}/pkgconfig/%{service_name}.pc
299 %{_libdir}/lib%{service_name}-client.so
300 %{_libdir}/lib%{service_name}-common.so
301
302 %files engine-devel
303 %defattr(-,root,root,-)
304 %{_includedir}/csre/csre-content-screening-engine-info.h
305 %{_includedir}/csre/csre-content-screening.h
306 %{_includedir}/csre/csre-content-screening-types.h
307 %{_includedir}/csre/csre-error.h
308 %{_includedir}/csre/csre-web-protection-engine-info.h
309 %{_includedir}/csre/csre-web-protection.h
310 %{_includedir}/csre/csre-web-protection-types.h
311 %{_libdir}/pkgconfig/%{service_name}-engine.pc
312
313 %files test
314 %defattr(-,root,root,-)
315 %manifest %{service_name}-test.manifest
316 %license LICENSE
317 %license LICENSE.BSL-1.0
318 %{_libdir}/lib%{service_name}-test-common.so
319 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
320 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
321 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
322 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
323
324 # test resources
325 %dir %attr(-, %{test_user}, %{service_group}) %{test_dir}
326 %attr(-, %{test_user}, %{service_group}) %{test_dir}/*
327
328 %dir %attr(-, %{test_user}, %{service_group}) %{test_res_dir}
329 %attr(-, %{test_user}, %{service_group}) %{test_res_dir}/*
330
331 # sample engine related files
332 %if 0%{?with_sample_engine}
333 %{engine_dir}/lib%{service_name}-cs-engine.so
334 %{engine_dir}/lib%{service_name}-wp-engine.so
335 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*
336 %endif