Add libclient requirement to devel package
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time       60
4 %define popup_service_idle_timeout_time 10
5
6 # Configure engine file system.
7 #
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
13
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 #                  concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
20
21 %define with_sample_engine 1
22
23 Summary: A general purpose content screening and reputation solution
24 Name: csr-framework
25 Version: 2.2.0
26 Release: 0
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
30 URL: http://tizen.org
31 BuildRequires: cmake
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd-daemon)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 %if "%{?tizen_version}" == "3.0"
45 BuildRequires: pkgconfig(cynara-client)
46 %else
47 BuildRequires: pkgconfig(libsmack)
48 %endif
49 Requires:      lib%{name}-common = %{version}-%{release}
50 %{?systemd_requires}
51
52 %description
53 General purpose content screening and reputation solution. Can scan
54 file contents and checking url to prevent malicious items.
55
56 %global service_name                 csr
57 %global bin_dir                      %{_bindir}
58 %global sbin_dir                     /sbin
59 %global ro_data_dir                  %{_datadir}
60 %global rw_data_dir                  /opt/share
61 %global ro_db_dir                    %{ro_data_dir}/%{service_name}/dbspace
62 %global rw_db_dir                    %{rw_data_dir}/%{service_name}/dbspace
63 %global ro_res_dir                   %{ro_data_dir}/%{service_name}/res
64 %global engine_rw_working_dir        %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
65 %global engine_dir                   %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
66 %global test_dir                     %{rw_data_dir}/%{service_name}-test
67 %global test_res_dir                 %{ro_data_dir}/%{service_name}-test
68
69 %if "%{?tizen_version}" == "3.0"
70 %global service_user                 security_fw
71 %global service_group                security_fw
72 %global test_user                    owner
73 %global popup_service_env_file_path  /run/tizen-system-env
74 %global smack_domain_name            System
75 %global popup_unitdir                %{_unitdir_user}
76 %global upgrade_script_dir           %{ro_data_dir}/upgrade/scripts
77 %else
78 %global service_user                 system
79 %global service_group                system
80 %global test_user                    system
81 %global smack_domain_name            %{service_name}
82 %global popup_service_env_file_path  /run/tizen-mobile-env
83 %global popup_unitdir                %{_unitdir}
84 %endif
85
86 %package -n lib%{name}-common
87 Summary: Common library package for %{name}
88 License: Apache-2.0
89 Group:   Security/Libraries
90 %if "%{?tizen_version}" == "3.0"
91 BuildRequires: pkgconfig(cynara-creds-socket)
92 %else
93 BuildRequires: pkgconfig(libsmack)
94 %endif
95 Requires: %{sbin_dir}/ldconfig
96
97 %description -n lib%{name}-common
98 csr-framework common library package.
99
100 %package -n lib%{name}-client
101 Summary: Client library package for %{name}
102 License: Apache-2.0
103 Group:   Security/Libraries
104 BuildRequires: pkgconfig(capi-base-common)
105 Requires: %{name} = %{version}-%{release}
106 Requires: %{sbin_dir}/ldconfig
107
108 %description -n lib%{name}-client
109 csr-framework client library package.
110
111 %package devel
112 Summary: Development files for %{name}
113 LICENSE: Apache-2.0
114 Group:   Security/Development
115 BuildRequires: pkgconfig(capi-base-common)
116 Requires:      %{name} = %{version}-%{release}
117 Requires:      lib%{name}-client
118
119 %description devel
120 csr-framework development files including headers and pkgconfig file.
121
122 %package engine-devel
123 Summary: Development files for %{name} engine
124 LICENSE: Apache-2.0
125 Group:   Security/Development
126
127 %description engine-devel
128 csr-framework engine development files including headers and pkgconfig file.
129
130 %package test
131 Summary: test program for %{name}
132 License: Apache-2.0 and BSL-1.0
133 Group:   Security/Testing
134 BuildRequires: boost-devel
135 BuildRequires: pkgconfig(pkgmgr-info)
136 BuildRequires: pkgconfig(glib-2.0)
137 Requires:      %{name} = %{version}
138
139 %description test
140 test program of csr-framework
141
142 %prep
143 %setup -q
144
145 %build
146
147 # define build architecture
148 %ifarch %{ix86}
149 %define test_target emulator
150 %else
151 %define test_target target
152 %endif
153
154 %cmake . \
155     -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
156     -DCMAKE_VERBOSE_MAKEFILE=ON \
157     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
158     -DSERVICE_USER=%{service_user} \
159     -DSERVICE_GROUP=%{service_group} \
160     -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
161     -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
162     -DSERVICE_NAME=%{service_name} \
163     -DVERSION=%{version} \
164     -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
165     -DBIN_DIR:PATH=%{bin_dir} \
166     -DSYSTEMD_UNIT_DIR=%{_unitdir} \
167     -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
168     -DRO_DBSPACE:PATH=%{ro_db_dir} \
169     -DRW_DBSPACE:PATH=%{rw_db_dir} \
170     -DRO_RES_DIR:PATH=%{ro_res_dir} \
171     -DRO_DATA_DIR:PATH=%{ro_data_dir} \
172     -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
173     -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
174     -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
175     -DENGINE_DIR:PATH=%{engine_dir} \
176     -DTEST_TARGET=%{test_target} \
177     -DTEST_DIR:PATH=%{test_dir} \
178     -DTEST_RES_DIR:PATH=%{test_res_dir} \
179 %if 0%{?with_detailed_base_url}
180     -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
181 %endif
182 %if 0%{?with_sample_engine}
183     -DWITH_SAMPLE_ENGINE:BOOL=ON \
184 %else
185     -DWITH_SAMPLE_ENGINE:BOOL=OFF \
186 %endif
187 %if "%{?tizen_version}" == "3.0"
188     -DPLATFORM_VERSION_3:BOOL=ON
189 %else
190     -DPLATFORM_VERSION_3:BOOL=OFF
191 %endif
192
193 make %{?jobs:-j%jobs}
194
195 %install
196 %make_install
197 mkdir -p %{buildroot}%{_unitdir}/sockets.target.wants
198 mkdir -p %{buildroot}%{popup_unitdir}/sockets.target.wants
199 ln -s ../%{service_name}-cs.socket %{buildroot}%{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
200 ln -s ../%{service_name}-wp.socket %{buildroot}%{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
201 ln -s ../%{service_name}-admin.socket %{buildroot}%{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
202 ln -s ../%{service_name}-popup.socket %{buildroot}%{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
203
204 mkdir -p %{buildroot}%{ro_data_dir}/license
205 cp LICENSE %{buildroot}%{ro_data_dir}/license/%{name}
206 cp LICENSE.BSL-1.0 %{buildroot}%{ro_data_dir}/license/%{name}.BSL-1.0
207 cp LICENSE %{buildroot}%{ro_data_dir}/license/lib%{name}-client
208 cp LICENSE %{buildroot}%{ro_data_dir}/license/lib%{name}-common
209
210 cp LICENSE %{buildroot}%{ro_data_dir}/license/%{name}-test
211 cp LICENSE.BSL-1.0 %{buildroot}%{ro_data_dir}/license/%{name}-test.BSL-1.0
212
213 mkdir -p %{buildroot}%{rw_db_dir}
214 mkdir -p %{buildroot}%{ro_db_dir}
215 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
216
217 %if "%{?tizen_version}" == "3.0"
218 mkdir -p %{buildroot}%{upgrade_script_dir}
219 cp data/scripts/%{service_name}-upgrade.sh %{buildroot}%{upgrade_script_dir}
220 %endif
221
222 mkdir -p %{buildroot}%{engine_dir}
223 mkdir -p %{buildroot}%{engine_rw_working_dir}
224
225 %post
226 rm -f %{rw_db_dir}/.%{service_name}.db*
227
228 systemctl daemon-reload
229 if [ $1 = 1 ]; then
230     systemctl start %{service_name}-cs.socket
231     systemctl start %{service_name}-wp.socket
232     systemctl start %{service_name}-admin.socket
233     systemctl start %{service_name}-popup.socket
234
235     systemctl start %{service_name}.service
236     systemctl start %{service_name}-popup.service
237 fi
238
239 if [ $1 = 2 ]; then
240     systemctl stop %{service_name}-cs.socket
241     systemctl stop %{service_name}-wp.socket
242     systemctl stop %{service_name}-admin.socket
243     systemctl stop %{service_name}-popup.socket
244
245     systemctl stop %{service_name}-popup.service
246     systemctl stop %{service_name}.service
247
248     systemctl restart %{service_name}.service
249     systemctl restart %{service_name}-popup.service
250 fi
251
252 %preun
253 if [ $1 = 0 ]; then
254     systemctl stop %{service_name}-popup.service
255     systemctl stop %{service_name}.service
256     systemctl stop %{service_name}-cs.socket
257     systemctl stop %{service_name}-wp.socket
258     systemctl stop %{service_name}-admin.socket
259     systemctl stop %{service_name}-popup.socket
260 fi
261
262 %postun
263 if [ $1 = 0 ]; then
264     systemctl daemon-reload
265 fi
266
267 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
268 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
269 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
270 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
271
272 %post -n %{name}-test
273 chsmack -a "_" %{test_dir}/test_dir/dir1
274
275 %files
276 %defattr(-,root,root,-)
277 %manifest %{service_name}.manifest
278 %{ro_data_dir}/license/%{name}
279 %{ro_data_dir}/license/%{name}.BSL-1.0
280 %{bin_dir}/%{service_name}-server
281 %{bin_dir}/%{service_name}-popup
282 %{_unitdir}/%{service_name}.service
283 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
284 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
285 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
286 %{_unitdir}/%{service_name}-cs.socket
287 %{_unitdir}/%{service_name}-wp.socket
288 %{_unitdir}/%{service_name}-admin.socket
289 %{popup_unitdir}/%{service_name}-popup.socket
290 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
291 %{popup_unitdir}/%{service_name}-popup.service
292 %{ro_data_dir}/locale/*
293 %{ro_res_dir}/default-icon.png
294
295 %dir %{ro_data_dir}/%{service_name}
296 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
297 %dir %{ro_db_dir}
298 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
299 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
300
301 %dir %{engine_dir}
302 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
303
304 # RW area platform upgrade script
305 %if "%{?tizen_version}" == "3.0"
306 %attr(755, -, -) %{upgrade_script_dir}/%{service_name}-upgrade.sh
307 %endif
308
309 %files -n lib%{name}-common
310 %defattr(-,root,root,-)
311 %manifest %{service_name}-common.manifest
312 %{ro_data_dir}/license/lib%{name}-common
313 %{_libdir}/lib%{service_name}-common.so.*
314
315 %files -n lib%{name}-client
316 %defattr(-,root,root,-)
317 %manifest %{service_name}-client.manifest
318 %{ro_data_dir}/license/lib%{name}-client
319 %{_libdir}/lib%{service_name}-client.so.*
320
321 %files devel
322 %defattr(-,root,root,-)
323 %{_includedir}/csr/csr-content-screening.h
324 %{_includedir}/csr/csr-content-screening-types.h
325 %{_includedir}/csr/csr-web-protection.h
326 %{_includedir}/csr/csr-web-protection-types.h
327 %{_includedir}/csr/csr-error.h
328 %{_includedir}/csr/csr-engine-manager.h
329 %{_libdir}/pkgconfig/%{service_name}.pc
330 %{_libdir}/lib%{service_name}-client.so
331 %{_libdir}/lib%{service_name}-common.so
332
333 %files engine-devel
334 %defattr(-,root,root,-)
335 %{_includedir}/csre/csre-content-screening-engine-info.h
336 %{_includedir}/csre/csre-content-screening.h
337 %{_includedir}/csre/csre-content-screening-types.h
338 %{_includedir}/csre/csre-error.h
339 %{_includedir}/csre/csre-web-protection-engine-info.h
340 %{_includedir}/csre/csre-web-protection.h
341 %{_includedir}/csre/csre-web-protection-types.h
342 %{_libdir}/pkgconfig/%{service_name}-engine.pc
343
344 %files test
345 %defattr(-,root,root,-)
346 %manifest %{service_name}-test.manifest
347 %{ro_data_dir}/license/%{name}-test
348 %{ro_data_dir}/license/%{name}-test.BSL-1.0
349 %{_libdir}/lib%{service_name}-test-common.so
350 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
351 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
352 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
353 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
354
355 # test resources
356 %dir %attr(777, %{test_user}, %{service_group}) %{test_dir}
357 %attr(777, %{test_user}, %{service_group}) %{test_dir}/*
358
359 %dir %attr(777, %{test_user}, %{service_group}) %{test_res_dir}
360 %attr(777, %{test_user}, %{service_group}) %{test_res_dir}/*
361
362 # sample engine related files
363 %if 0%{?with_sample_engine}
364 %{engine_dir}/lib%{service_name}-cs-engine.so
365 %{engine_dir}/lib%{service_name}-wp-engine.so
366 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*
367 %endif