1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time 60
4 %define popup_service_idle_timeout_time 10
6 # Configure engine file system.
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 # concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
21 %define with_sample_engine 1
23 Summary: A general purpose content screening and reputation solution
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd-daemon)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 BuildRequires: pkgconfig(libtzplatform-config)
45 BuildRequires: pkgconfig(cynara-client)
46 Requires: lib%{name}-common = %{version}-%{release}
50 General purpose content screening and reputation solution. Can scan
51 file contents and checking url to prevent malicious items.
53 %global service_name csr
54 %global bin_dir %{_bindir}
55 %global sbin_dir /sbin
56 %global ro_data_dir %{_datadir}
57 %global rw_data_dir /opt/share
58 %global ro_db_dir %{ro_data_dir}/%{service_name}/dbspace
59 %global rw_db_dir %{rw_data_dir}/%{service_name}/dbspace
60 %global ro_res_dir %{ro_data_dir}/%{service_name}/res
61 %global engine_rw_working_dir %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
62 %global engine_dir %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
63 %global test_dir %{rw_data_dir}/%{service_name}-test
64 %global test_res_dir %{ro_data_dir}/%{service_name}-test
66 %global service_user security_fw
67 %global service_group security_fw
68 %global test_user owner
69 %global popup_service_env_file_path /run/tizen-system-env
70 %global smack_domain_name System
71 %global popup_unitdir %{_unitdir_user}
72 %global upgrade_script_dir %{ro_data_dir}/upgrade/scripts
74 %package -n lib%{name}-common
75 Summary: CSR framework (common library)
77 Group: Security/Libraries
78 BuildRequires: pkgconfig(cynara-creds-socket)
79 Requires: %{sbin_dir}/ldconfig
81 %description -n lib%{name}-common
82 Content Screening and Reputation framework package (common library)
84 %package -n lib%{name}-client
85 Summary: CSR framework (client library)
87 Group: Security/Libraries
88 BuildRequires: pkgconfig(capi-base-common)
89 Requires: %{name} = %{version}-%{release}
90 Requires: %{sbin_dir}/ldconfig
92 %description -n lib%{name}-client
93 Content Screening and Reputation framework package (client library)
96 Summary: CSR framework (development files)
98 Group: Security/Development
99 BuildRequires: pkgconfig(capi-base-common)
100 Requires: %{name} = %{version}-%{release}
101 Requires: lib%{name}-client
104 Content Screening and Reputation framework development files like headers and pkgconfigs
106 %package engine-devel
107 Summary: CSR framework (engine development files)
109 Group: Security/Development
111 %description engine-devel
112 Content Screening and Reputation framework engine development files like headers and
116 Summary: CSR framework (test program)
117 License: Apache-2.0 and BSL-1.0
118 Group: Security/Testing
119 BuildRequires: boost-devel
120 BuildRequires: pkgconfig(pkgmgr-info)
121 BuildRequires: pkgconfig(glib-2.0)
122 BuildRequires: pkgconfig(storage)
123 Requires: %{name} = %{version}
126 Content Screening and Reputation framework (test program)
133 # define build architecture
135 %define test_target emulator
137 %define test_target target
141 -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
142 -DCMAKE_VERBOSE_MAKEFILE=ON \
143 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
144 -DSERVICE_USER=%{service_user} \
145 -DSERVICE_GROUP=%{service_group} \
146 -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
147 -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
148 -DSERVICE_NAME=%{service_name} \
149 -DVERSION=%{version} \
150 -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
151 -DBIN_DIR:PATH=%{bin_dir} \
152 -DSYSTEMD_UNIT_DIR=%{_unitdir} \
153 -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
154 -DRO_DBSPACE:PATH=%{ro_db_dir} \
155 -DRW_DBSPACE:PATH=%{rw_db_dir} \
156 -DRO_RES_DIR:PATH=%{ro_res_dir} \
157 -DRO_DATA_DIR:PATH=%{ro_data_dir} \
158 -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
159 -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
160 -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
161 -DENGINE_DIR:PATH=%{engine_dir} \
162 -DTEST_TARGET=%{test_target} \
163 -DTEST_DIR:PATH=%{test_dir} \
164 -DTEST_RES_DIR:PATH=%{test_res_dir} \
165 %if 0%{?with_detailed_base_url}
166 -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
168 %if 0%{?with_sample_engine}
169 -DWITH_SAMPLE_ENGINE:BOOL=ON \
171 -DWITH_SAMPLE_ENGINE:BOOL=OFF \
173 -DTZ_SYS_STORAGE=%TZ_SYS_STORAGE \
174 -DTZ_SYS_RW_APP=%TZ_SYS_RW_APP \
175 -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
177 make %{?jobs:-j%jobs}
181 %install_service sockets.target.wants %{service_name}-cs.socket
182 %install_service sockets.target.wants %{service_name}-wp.socket
183 %install_service sockets.target.wants %{service_name}-admin.socket
184 %install_service ../user/sockets.target.wants %{service_name}-popup.socket
186 mkdir -p %{buildroot}%{rw_db_dir}
187 mkdir -p %{buildroot}%{ro_db_dir}
188 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
190 mkdir -p %{buildroot}%{upgrade_script_dir}
191 cp data/scripts/500.%{service_name}.sh %{buildroot}%{upgrade_script_dir}
193 mkdir -p %{buildroot}%{engine_dir}
194 mkdir -p %{buildroot}%{engine_rw_working_dir}
196 %find_lang %{service_name}
199 set_cap_script=%{ro_data_dir}/security-config/set_capability
200 if [ -f $set_cap_script ]; then
204 rm -f %{rw_db_dir}/.%{service_name}.db*
206 systemctl daemon-reload
208 systemctl start %{service_name}-cs.socket
209 systemctl start %{service_name}-wp.socket
210 systemctl start %{service_name}-admin.socket
211 systemctl start %{service_name}.service
213 systemctl --user start %{service_name}-popup.socket
214 systemctl --user start %{service_name}-popup.service
215 elif [ $1 = 2 ]; then
216 systemctl stop %{service_name}-cs.socket
217 systemctl stop %{service_name}-wp.socket
218 systemctl stop %{service_name}-admin.socket
219 systemctl restart %{service_name}.service
221 systemctl --user stop %{service_name}-popup.socket
222 systemctl --user restart %{service_name}-popup.service
227 systemctl stop %{service_name}-cs.socket
228 systemctl stop %{service_name}-wp.socket
229 systemctl stop %{service_name}-admin.socket
230 systemctl stop %{service_name}.service
232 systemctl --user stop %{service_name}-popup.socket
233 systemctl --user stop %{service_name}-popup.service
238 systemctl daemon-reload
241 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
242 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
243 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
244 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
246 %post -n %{name}-test
247 chsmack -a "_" %{test_dir}/test_dir/dir1
248 %if 0%{?with_sample_engine}
249 systemctl stop %{service_name}-cs.socket
250 systemctl stop %{service_name}-wp.socket
251 systemctl stop %{service_name}-admin.socket
252 systemctl restart %{service_name}.service
255 %files -f %{service_name}.lang
256 %defattr(-,root,root,-)
257 %manifest %{service_name}.manifest
259 %license LICENSE.BSL-1.0
260 %{bin_dir}/%{service_name}-server
261 %{bin_dir}/%{service_name}-popup
262 %{_unitdir}/%{service_name}.service
263 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
264 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
265 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
266 %{_unitdir}/%{service_name}-cs.socket
267 %{_unitdir}/%{service_name}-wp.socket
268 %{_unitdir}/%{service_name}-admin.socket
269 %{popup_unitdir}/%{service_name}-popup.socket
270 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
271 %{popup_unitdir}/%{service_name}-popup.service
272 %{ro_res_dir}/default-icon.png
274 %dir %{ro_data_dir}/%{service_name}
275 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
277 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
278 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
281 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
283 # RW area platform upgrade script
284 %attr(755, -, -) %{upgrade_script_dir}/500.%{service_name}.sh
286 %files -n lib%{name}-common
287 %defattr(-,root,root,-)
288 %manifest %{service_name}-common.manifest
290 %{_libdir}/lib%{service_name}-common.so.*
292 %files -n lib%{name}-client
293 %defattr(-,root,root,-)
294 %manifest %{service_name}-client.manifest
296 %{_libdir}/lib%{service_name}-client.so.*
299 %defattr(-,root,root,-)
300 %{_includedir}/csr/csr-content-screening.h
301 %{_includedir}/csr/csr-content-screening-types.h
302 %{_includedir}/csr/csr-web-protection.h
303 %{_includedir}/csr/csr-web-protection-types.h
304 %{_includedir}/csr/csr-error.h
305 %{_includedir}/csr/csr-engine-manager.h
306 %{_libdir}/pkgconfig/%{service_name}.pc
307 %{_libdir}/lib%{service_name}-client.so
308 %{_libdir}/lib%{service_name}-common.so
311 %defattr(-,root,root,-)
312 %{_includedir}/csre/csre-content-screening-engine-info.h
313 %{_includedir}/csre/csre-content-screening.h
314 %{_includedir}/csre/csre-content-screening-types.h
315 %{_includedir}/csre/csre-error.h
316 %{_includedir}/csre/csre-web-protection-engine-info.h
317 %{_includedir}/csre/csre-web-protection.h
318 %{_includedir}/csre/csre-web-protection-types.h
319 %{_libdir}/pkgconfig/%{service_name}-engine.pc
322 %defattr(-,root,root,-)
323 %manifest %{service_name}-test.manifest
325 %license LICENSE.BSL-1.0
326 %{_libdir}/lib%{service_name}-test-common.so
327 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
328 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
329 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
330 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
333 %dir %attr(-, %{test_user}, %{service_group}) %{test_dir}
334 %attr(-, %{test_user}, %{service_group}) %{test_dir}/*
336 %dir %attr(-, %{test_user}, %{service_group}) %{test_res_dir}
337 %attr(-, %{test_user}, %{service_group}) %{test_res_dir}/*
339 # sample engine related files
340 %if 0%{?with_sample_engine}
341 %{engine_dir}/lib%{service_name}-cs-engine.so
342 %{engine_dir}/lib%{service_name}-wp-engine.so
343 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*