Add multi-user support
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1
2 Summary:       Content Security Framework
3 Name:          csr-framework
4 Version:       1.0.0
5 Release:       0
6 License:       BSD-3-Clause
7 Group:         Security/Libraries
8 URL:           http://tizen.org
9 Source:        %{name}-%{version}.tar.gz
10 Source1001:    csr-framework.manifest
11 BuildRequires: pkgconfig(libtzplatform-config)
12
13 %description
14 A general purpose content screening and reputation solution. 
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build 
21 make all
22
23 %install
24 rm -rf %{buildroot}
25 mkdir -p %{buildroot}%{_libdir}/
26 install -D lib/libsecfw.so %{buildroot}%{_libdir}/
27
28 %post -p /sbin/ldconfig
29
30 %postun -p /sbin/ldconfig
31
32 %files 
33 %manifest %{name}.manifest
34 %{_libdir}/libsecfw.so
35