[LCOV] Prepare to measure the line coverage
[platform/upstream/csr-framework.git] / packaging / csr-framework.spec
1 # services timeoout time on idle for on-demand activation.
2 # give it '-1' if don't want to timeout on idle.
3 %define service_idle_timeout_time       60
4 %define popup_service_idle_timeout_time 10
5
6 # Configure engine file system.
7 #
8 # ro_dir_name / rw_dir_name
9 # - dir name is directory name inside of CSR directory.
10 # - 'dbspace' cannot be used as a dir_name.
11 %define engine_ro_dir_name engine
12 %define engine_rw_dir_name engine
13
14 # base of detailed url of content screening engine.
15 # If it's defined, detailed_url for client will be generated by
16 #                  concatenating base url + malware name.
17 # Else it's not defined, detailed_url getter in engine API will be used.
18 %define with_detailed_base_url 0
19 %define detailed_base_url %nil
20
21 %define with_sample_engine 1
22
23 Summary: A general purpose content screening and reputation solution
24 Name: csr-framework
25 Version: 2.3.4
26 Release: 0
27 Source: %{name}-%{version}.tar.gz
28 License: Apache-2.0 and BSL-1.0
29 Group: Security/Service
30 URL: http://tizen.org
31 BuildRequires: cmake
32 BuildRequires: gettext-tools
33 BuildRequires: pkgconfig(dlog)
34 BuildRequires: pkgconfig(libsystemd-daemon)
35 BuildRequires: pkgconfig(vconf)
36 BuildRequires: pkgconfig(sqlite3)
37 BuildRequires: pkgconfig(pkgmgr)
38 BuildRequires: pkgconfig(pkgmgr-info)
39 BuildRequires: pkgconfig(libsmack)
40 BuildRequires: pkgconfig(capi-appfw-application)
41 BuildRequires: pkgconfig(elementary)
42 BuildRequires: pkgconfig(efl-extension)
43 BuildRequires: pkgconfig(icu-i18n)
44 BuildRequires: pkgconfig(libtzplatform-config)
45 BuildRequires: pkgconfig(cynara-client)
46 Requires:      lib%{name}-common = %{version}-%{release}
47 %{?systemd_requires}
48
49 %description
50 General purpose content screening and reputation solution. Can scan
51 file contents and checking url to prevent malicious items.
52
53 %global service_name                 csr
54 %global bin_dir                      %{_bindir}
55 %global sbin_dir                     /sbin
56 %global ro_data_dir                  %{_datadir}
57 %global rw_data_dir                  /opt/share
58 %global ro_db_dir                    %{ro_data_dir}/%{service_name}/dbspace
59 %global rw_db_dir                    %{rw_data_dir}/%{service_name}/dbspace
60 %global ro_res_dir                   %{ro_data_dir}/%{service_name}/res
61 %global engine_rw_working_dir        %{rw_data_dir}/%{service_name}/%{engine_rw_dir_name}
62 %global engine_dir                   %{ro_data_dir}/%{service_name}/%{engine_ro_dir_name}
63 %global test_dir                     %{rw_data_dir}/%{service_name}-test
64 %global test_res_dir                 %{ro_data_dir}/%{service_name}-test
65
66 %global service_user                 security_fw
67 %global service_group                security_fw
68 %global test_user                    owner
69 %global popup_service_env_file_path  /run/tizen-system-env
70 %global smack_domain_name            System
71 %global popup_unitdir                %{_unitdir_user}
72
73 %package -n lib%{name}-common
74 Summary: CSR framework (common library)
75 License: Apache-2.0
76 Group:   Security/Libraries
77 BuildRequires: pkgconfig(cynara-creds-socket)
78 Requires: %{sbin_dir}/ldconfig
79
80 %description -n lib%{name}-common
81 Content Screening and Reputation framework package (common library)
82
83 %package -n lib%{name}-client
84 Summary: CSR framework (client library)
85 License: Apache-2.0
86 Group:   Security/Libraries
87 BuildRequires: pkgconfig(capi-base-common)
88 Requires: %{name} = %{version}-%{release}
89 Requires: %{sbin_dir}/ldconfig
90
91 %description -n lib%{name}-client
92 Content Screening and Reputation framework package (client library)
93
94 %package devel
95 Summary: CSR framework (development files)
96 LICENSE: Apache-2.0
97 Group:   Security/Development
98 BuildRequires: pkgconfig(capi-base-common)
99 Requires:      %{name} = %{version}-%{release}
100 Requires:      lib%{name}-client
101
102 %description devel
103 Content Screening and Reputation framework development files like headers and pkgconfigs
104
105 %package engine-devel
106 Summary: CSR framework (engine development files)
107 LICENSE: Apache-2.0
108 Group:   Security/Development
109
110 %description engine-devel
111 Content Screening and Reputation framework engine development files like headers and
112 pkgconfigs
113
114 %package test
115 Summary: CSR framework (test program)
116 License: Apache-2.0 and BSL-1.0
117 Group:   Security/Testing
118 BuildRequires: boost-devel
119 BuildRequires: pkgconfig(pkgmgr-info)
120 BuildRequires: pkgconfig(glib-2.0)
121 BuildRequires: pkgconfig(storage)
122 Requires:      %{name} = %{version}
123
124 %description test
125 Content Screening and Reputation framework (test program)
126
127 %prep
128 %setup -q
129
130 %build
131
132 # define build architecture
133 %ifarch %{ix86}
134 %define test_target emulator
135 %else
136 %define test_target target
137 %endif
138
139 export CXXFLAGS="-fprofile-arcs -ftest-coverage"
140 export LDFLAGS="-lgcov"
141
142 %cmake . \
143     -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}%{!?build_type:RELEASE} \
144     -DCMAKE_VERBOSE_MAKEFILE=ON \
145     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
146     -DSERVICE_USER=%{service_user} \
147     -DSERVICE_GROUP=%{service_group} \
148     -DSMACK_DOMAIN_NAME=%{smack_domain_name} \
149     -DPOPUP_SERVICE_ENV_FILE_PATH:PATH=%{popup_service_env_file_path} \
150     -DSERVICE_NAME=%{service_name} \
151     -DVERSION=%{version} \
152     -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
153     -DBIN_DIR:PATH=%{bin_dir} \
154     -DSYSTEMD_UNIT_DIR=%{_unitdir} \
155     -DPOPUP_SYSTEMD_UNIT_DIR=%{popup_unitdir} \
156     -DRO_DBSPACE:PATH=%{ro_db_dir} \
157     -DRW_DBSPACE:PATH=%{rw_db_dir} \
158     -DRO_RES_DIR:PATH=%{ro_res_dir} \
159     -DRO_DATA_DIR:PATH=%{ro_data_dir} \
160     -DSERVICE_IDLE_TIMEOUT_TIME=%{service_idle_timeout_time} \
161     -DPOPUP_SERVICE_IDLE_TIMEOUT_TIME=%{popup_service_idle_timeout_time} \
162     -DENGINE_RW_WORKING_DIR:PATH=%{engine_rw_working_dir} \
163     -DENGINE_DIR:PATH=%{engine_dir} \
164     -DTEST_TARGET=%{test_target} \
165     -DTEST_DIR:PATH=%{test_dir} \
166     -DTEST_RES_DIR:PATH=%{test_res_dir} \
167 %if 0%{?with_detailed_base_url}
168     -DDETAILED_URL_BASE:STRING=%{detailed_base_url} \
169 %endif
170 %if 0%{?with_sample_engine}
171     -DWITH_SAMPLE_ENGINE:BOOL=ON \
172 %else
173     -DWITH_SAMPLE_ENGINE:BOOL=OFF \
174 %endif
175     -DTZ_SYS_STORAGE=%TZ_SYS_STORAGE \
176     -DTZ_SYS_RW_APP=%TZ_SYS_RW_APP \
177     -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP
178
179 make %{?jobs:-j%jobs}
180
181 %install
182 %make_install
183 %install_service sockets.target.wants %{service_name}-cs.socket
184 %install_service sockets.target.wants %{service_name}-wp.socket
185 %install_service sockets.target.wants %{service_name}-admin.socket
186 %install_service ../user/sockets.target.wants %{service_name}-popup.socket
187 %install_service ../system/user-sockets@.target.wants %{service_name}-popup@.socket
188
189 mkdir -p %{buildroot}%{rw_db_dir}
190 mkdir -p %{buildroot}%{ro_db_dir}
191 cp data/scripts/*.sql %{buildroot}%{ro_db_dir}
192
193 mkdir -p %{buildroot}%{engine_dir}
194 mkdir -p %{buildroot}%{engine_rw_working_dir}
195
196 %find_lang %{service_name}
197
198 %post
199 set_cap_script=%{ro_data_dir}/security-config/set_capability
200 if [ -f $set_cap_script ]; then
201     $set_cap_script
202 fi
203
204 rm -f %{rw_db_dir}/.%{service_name}.db*
205
206 systemctl daemon-reload
207 if [ $1 = 1 ]; then
208     systemctl start %{service_name}-cs.socket
209     systemctl start %{service_name}-wp.socket
210     systemctl start %{service_name}-admin.socket
211     systemctl start %{service_name}.service
212
213     systemctl --user start %{service_name}-popup.socket
214     systemctl --user start %{service_name}-popup.service
215 elif [ $1 = 2 ]; then
216     systemctl stop %{service_name}-cs.socket
217     systemctl stop %{service_name}-wp.socket
218     systemctl stop %{service_name}-admin.socket
219     systemctl restart %{service_name}.service
220
221     systemctl --user stop %{service_name}-popup.socket
222     systemctl --user restart %{service_name}-popup.service
223 fi
224
225 %preun
226 if [ $1 = 0 ]; then
227     systemctl stop %{service_name}-cs.socket
228     systemctl stop %{service_name}-wp.socket
229     systemctl stop %{service_name}-admin.socket
230     systemctl stop %{service_name}.service
231
232     systemctl --user stop %{service_name}-popup.socket
233     systemctl --user stop %{service_name}-popup.service
234 fi
235
236 %postun
237 if [ $1 = 0 ]; then
238     systemctl daemon-reload
239 fi
240
241 %post -n lib%{name}-common -p %{sbin_dir}/ldconfig
242 %post -n lib%{name}-client -p %{sbin_dir}/ldconfig
243 %postun -n lib%{name}-common -p %{sbin_dir}/ldconfig
244 %postun -n lib%{name}-client -p %{sbin_dir}/ldconfig
245
246 %post -n %{name}-test
247 chsmack -a "_" %{test_dir}/test_dir/dir1
248 %if 0%{?with_sample_engine}
249 systemctl stop %{service_name}-cs.socket
250 systemctl stop %{service_name}-wp.socket
251 systemctl stop %{service_name}-admin.socket
252 systemctl restart %{service_name}.service
253
254 touch %{engine_rw_working_dir}/csret_cs_virus_signatures
255 touch %{engine_rw_working_dir}/csret_wp_risky_urls
256 %endif
257
258 %files -f %{service_name}.lang
259 %defattr(-,root,root,-)
260 %manifest %{service_name}.manifest
261 %license LICENSE
262 %license LICENSE.BSL-1.0
263 %{bin_dir}/%{service_name}-server
264 %{bin_dir}/%{service_name}-popup
265 %{_unitdir}/%{service_name}.service
266 %{_unitdir}/sockets.target.wants/%{service_name}-cs.socket
267 %{_unitdir}/sockets.target.wants/%{service_name}-wp.socket
268 %{_unitdir}/sockets.target.wants/%{service_name}-admin.socket
269 %{_unitdir}/%{service_name}-cs.socket
270 %{_unitdir}/%{service_name}-wp.socket
271 %{_unitdir}/%{service_name}-admin.socket
272 %{popup_unitdir}/%{service_name}-popup.socket
273 %{popup_unitdir}/sockets.target.wants/%{service_name}-popup.socket
274 %{popup_unitdir}/%{service_name}-popup.service
275 %{_unitdir}/%{service_name}-popup@.socket
276 %{_unitdir}/user-sockets@.target.wants/%{service_name}-popup@.socket
277 %{_unitdir}/%{service_name}-popup@.service
278 %{ro_res_dir}/default-icon.png
279
280 %dir %{ro_data_dir}/%{service_name}
281 %dir %attr(-, %{service_user}, %{service_group}) %{rw_data_dir}/%{service_name}
282 %dir %{ro_db_dir}
283 %dir %attr(-, %{service_user}, %{service_group}) %{rw_db_dir}
284 %attr(444, %{service_user}, %{service_group}) %{ro_db_dir}/*.sql
285
286 %dir %{engine_dir}
287 %dir %attr(775, %{service_user}, %{service_group}) %{engine_rw_working_dir}
288
289 %files -n lib%{name}-common
290 %defattr(-,root,root,-)
291 %manifest %{service_name}-common.manifest
292 %license LICENSE
293 %{_libdir}/lib%{service_name}-common.so.*
294
295 %files -n lib%{name}-client
296 %defattr(-,root,root,-)
297 %manifest %{service_name}-client.manifest
298 %license LICENSE
299 %{_libdir}/lib%{service_name}-client.so.*
300
301 %files devel
302 %defattr(-,root,root,-)
303 %{_includedir}/csr/csr-content-screening.h
304 %{_includedir}/csr/csr-content-screening-types.h
305 %{_includedir}/csr/csr-web-protection.h
306 %{_includedir}/csr/csr-web-protection-types.h
307 %{_includedir}/csr/csr-error.h
308 %{_includedir}/csr/csr-engine-manager.h
309 %{_libdir}/pkgconfig/%{service_name}.pc
310 %{_libdir}/lib%{service_name}-client.so
311 %{_libdir}/lib%{service_name}-common.so
312
313 %files engine-devel
314 %defattr(-,root,root,-)
315 %{_includedir}/csre/csre-content-screening-engine-info.h
316 %{_includedir}/csre/csre-content-screening.h
317 %{_includedir}/csre/csre-content-screening-types.h
318 %{_includedir}/csre/csre-error.h
319 %{_includedir}/csre/csre-web-protection-engine-info.h
320 %{_includedir}/csre/csre-web-protection.h
321 %{_includedir}/csre/csre-web-protection-types.h
322 %{_libdir}/pkgconfig/%{service_name}-engine.pc
323
324 %files test
325 %defattr(-,root,root,-)
326 %manifest %{service_name}-test.manifest
327 %license LICENSE
328 %license LICENSE.BSL-1.0
329 %{_libdir}/lib%{service_name}-test-common.so
330 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-test
331 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-internal-test
332 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-popup-test
333 %attr(-, %{test_user}, %{service_group}) %{bin_dir}/%{service_name}-threadpool-test
334
335 # test resources
336 %dir %attr(-, %{test_user}, %{service_group}) %{test_dir}
337 %attr(-, %{test_user}, %{service_group}) %{test_dir}/*
338
339 %dir %attr(-, %{test_user}, %{service_group}) %{test_res_dir}
340 %attr(-, %{test_user}, %{service_group}) %{test_res_dir}/*
341
342 # sample engine related files
343 %if 0%{?with_sample_engine}
344 %{engine_dir}/lib%{service_name}-cs-engine.so
345 %{engine_dir}/lib%{service_name}-wp-engine.so
346 %attr(-, %{service_user}, %{service_group}) %{engine_rw_working_dir}/*
347 %endif