Fixed the HTTP test code for TWP testing per Samsung report
[platform/upstream/csf-framework.git] / packaging / csf-framework.spec
1 Summary:       Content Security Framework
2 Name:          csf-framework
3 Version:       2.0.2
4 Release:       0
5 License:       BSD-3-Clause
6 Group:         Security/Libraries
7 URL:           http://tizen.org
8 Source:        %{name}-%{version}.tar.gz
9 Source1001:    csf-framework.manifest
10 BuildRequires: pkgconfig(libtzplatform-config)
11 BuildRequires: pkgconfig(dbus-glib-1)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(libxml-2.0)
14
15 %description
16 A general purpose content screening and reputation solution.
17
18 %prep
19 %setup -q
20 cp %{SOURCE1001} .
21
22 %build
23 cd framework
24
25 # Build Framework Library
26 make -f Makefile all
27
28 # Build IPC Client Library
29 make -f Makefile_channel_client all
30
31 # Build IPC Server Library
32 make -f Makefile_channel_server all
33
34 # Build Plugin Control Service
35 make -f Makefile_TPCSSerDaemon all
36
37 # Build Web Protection Control Service
38 make -f Makefile_TWPSerDaemon all
39
40 %install
41 rm -rf %{buildroot}
42 mkdir -p %{buildroot}%{_libdir}/
43 mkdir -p %{buildroot}%{_bindir}/
44 install -D framework/lib/libsecfw.so %{buildroot}%{_libdir}/
45 install -D framework/lib/libscclient.so %{buildroot}%{_libdir}/
46 install -D framework/lib/libscserver.so %{buildroot}%{_libdir}/
47 install -D framework/bin/TPCSSerDaemon %{buildroot}%{_bindir}/
48 install -D framework/bin/TWPSerDaemon %{buildroot}%{_bindir}/
49
50 %post -p /sbin/ldconfig
51
52 %postun -p /sbin/ldconfig
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-,root,root,-)
57 %{_libdir}/libsecfw.so
58 %{_libdir}/libscclient.so
59 %{_libdir}/libscserver.so
60 %attr(755,root,root) %{_bindir}/TPCSSerDaemon
61 %attr(755,root,root) %{_bindir}/TWPSerDaemon