Intial version of STT C# API
[platform/core/csapi/uix-stt.git] / packaging / csapi-uix-stt.spec
1 %{!?dotnet_assembly_path: %define dotnet_assembly_path %{_datadir}/assembly}
2 %{!?dotnet_core_path: %define dotnet_core_path %{_datadir}/tizen.net/ref}
3
4 %if 0%{?tizen_build_devel_mode}
5 %define BUILDCONF Debug
6 %else
7 %define BUILDCONF Release
8 %endif
9
10 Name:       csapi-uix-stt
11 Summary:    Tizen STT Uix API for C#
12 Version:    1.0.0
13 Release:    1
14 Group:      Development/Libraries
15 License:    Apache-2.0
16 URL:        https://www.tizen.org
17 Source0:    %{name}-%{version}.tar.gz
18 Source1:    %{name}.manifest
19
20 # Mono
21 BuildRequires: mono-compiler
22 BuildRequires: mono-devel
23
24 # .NETCore
25 %if 0%{?_with_corefx}
26 AutoReqProv: no
27 BuildRequires: corefx-managed-32b-ref
28 %endif
29
30 # C# API Requires
31 BuildRequires: csapi-tizen
32
33 # .Net supports only armv7l and x86_64
34 ExcludeArch: %{ix86} aarch64
35
36 %description
37 Tizen Uix API for C#
38
39 %prep
40 %setup -q
41 cp %{SOURCE1} .
42
43 %define Assemblies Tizen.Uix
44
45 %build
46 for ASM in %{Assemblies}; do
47 xbuild $ASM/$ASM.csproj \
48 %if 0%{?_with_corefx}
49         /p:NoStdLib=True \
50         /p:TargetFrameworkVersion=v5.0 \
51         /p:AddAdditionalExplicitAssemblyReferences=False \
52         /p:CoreFxPath=%{dotnet_core_path} \
53 %endif
54         /p:Configuration=%{BUILDCONF} \
55         /p:ReferencePath=%{dotnet_assembly_path}
56 done
57
58 %install
59 mkdir -p %{buildroot}%{dotnet_assembly_path}
60 for ASM in %{Assemblies}; do
61 install -p -m 644 $ASM/bin/%{BUILDCONF}/$ASM.dll %{buildroot}%{dotnet_assembly_path}
62 done
63
64 %files
65 %manifest %{name}.manifest
66 %license LICENSE
67 %attr(644,root,root) %{dotnet_assembly_path}/*.dll