1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 8
4 %define TIZEN_NET_RPM_VERSION 8.0.0.15389+nui21916
5 %define TIZEN_NET_NUGET_VERSION 8.0.0.15389
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
11 %define DOTNET_PRELOAD_PATH /usr/share/dotnet.tizen/preload
12 %define DOTNET_NUGET_SOURCE /nuget
14 %define TIZEN_NET_RUNTIME_IDENTIFIERS 4.0.0:5.0.0:5.5.0:6.0.0
17 Summary: Assemblies of Tizen .NET
18 Version: %{TIZEN_NET_RPM_VERSION}
20 Group: Development/Libraries
21 License: Apache-2.0 and MIT
22 URL: https://www.tizen.org
23 Source0: %{name}-%{version}.tar.gz
24 Source1: %{name}.manifest
30 BuildRequires: dotnet-build-tools
31 Requires(post): /usr/bin/vconftool
33 # BuildRequires for StructValidator
34 %if %{defined enable_struct_test}
36 BuildRequires: pkgconfig(elementary)
37 BuildRequires: pkgconfig(efl-extension)
38 BuildRequires: pkgconfig(capi-media-camera)
39 BuildRequires: pkgconfig(rua)
40 BuildRequires: pkgconfig(component-based-core-base)
41 BuildRequires: pkgconfig(notification)
42 BuildRequires: pkgconfig(capi-appfw-service-application)
43 BuildRequires: pkgconfig(capi-appfw-application)
44 BuildRequires: pkgconfig(capi-appfw-widget-application)
45 BuildRequires: pkgconfig(data-control)
46 BuildRequires: pkgconfig(capi-location-manager)
47 BuildRequires: pkgconfig(capi-media-vision)
48 BuildRequires: pkgconfig(capi-network-bluetooth)
49 BuildRequires: pkgconfig(capi-network-wifi-direct)
50 BuildRequires: pkgconfig(key-manager)
51 BuildRequires: pkgconfig(capi-system-sensor)
52 BuildRequires: pkgconfig(capi-system-runtime-info)
53 BuildRequires: pkgconfig(capi-ui-inputmethod)
54 BuildRequires: pkgconfig(stt-engine)
55 BuildRequires: pkgconfig(tts-engine)
56 BuildRequires: pkgconfig(chromium-efl)
57 %if "%{profile}" == "tv"
58 BuildRequires: pkgconfig(trustzone-nwd)
60 BuildRequires: pkgconfig(capi-appfw-watch-application)
61 BuildRequires: pkgconfig(capi-telephony)
62 BuildRequires: pkgconfig(tef-libteec)
70 Summary: NuGet package for %{name}
71 Group: Development/Libraries
75 NuGet package for %{name}
78 Summary: Tools for TizenFX
79 Group: Development/Libraries
86 Summary: not used package
87 Group: Development/Libraries
94 Summary: All Tizen .NET assemblies
95 Group: Development/Libraries
96 Requires: %{name} = %{version}-%{release}
100 All Tizen .NET assemblies
103 Summary: All .pdb files of Tizen .NET
104 Group: Development/Libraries
108 All .pdb files of Tizen .NET
111 Summary: Tizen .NET assemblies for Common profile
112 Group: Development/Libraries
113 Requires: %{name} = %{version}-%{release}
117 Tizen .NET assemblies for Common profile
120 Summary: Tizen .NET assemblies for Mobile profile
121 Group: Development/Libraries
122 Requires: %{name} = %{version}-%{release}
126 Tizen .NET assemblies for Mobile profile
129 Summary: Tizen .NET assemblies for Emulator of Mobile profile
130 Group: Development/Libraries
131 Requires: %{name} = %{version}-%{release}
134 %description mobile-emul
135 Tizen .NET assemblies for Emulator of Mobile profile
138 Summary: Tizen .NET assemblies for TV profile
139 Group: Development/Libraries
140 Requires: %{name} = %{version}-%{release}
144 Tizen .NET assemblies for TV profile
147 Summary: Tizen .NET assemblies for Wearable profile
148 Group: Development/Libraries
149 Requires: %{name} = %{version}-%{release}
152 %description wearable
153 Tizen .NET assemblies for Wearable profile
160 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
162 %define _tizenfx_bin_path Artifacts
164 rm -fr %{_tizenfx_bin_path}
165 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
167 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
168 %if %{defined profile}
169 %{build_cmd} --full /p:BuildProfile=%{profile}
173 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
175 %if %{defined enable_struct_test}
176 dotnet validate-struct %{_tizenfx_bin_path}/bin/public || echo "
177 #######################################################
178 ##################### W A R N I N G ###################
179 #######################################################
180 # The sturct size mismatches MUST BE FIXED. #
181 # It will make building errors later #
182 #######################################################
186 # Generate filelist for rpm packaging
189 cat packaging/PlatformFileList.txt | grep -v "\.preload" | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
190 for f in $(cat packaging/PlatformFileList.txt | grep -v -E "#$PROFILE[[:space:]]|#$PROFILE$|\.preload" | cut -d# -f1); do
191 if [ -f %{_tizenfx_bin_path}/bin/dummy/$f ]; then
192 echo "%{DOTNET_ASSEMBLY_PATH}/ref/$f"
195 for f in $(cat packaging/PlatformFileList.txt | grep "\.preload" | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1); do
196 if [ -f packaging/preload/$f ]; then
197 echo "%{DOTNET_PRELOAD_PATH}/$f"
202 GetFileList common > common.filelist
203 GetFileList mobile > mobile.filelist
204 GetFileList mobile-emul > mobile-emul.filelist
205 GetFileList tv > tv.filelist
206 GetFileList wearable > wearable.filelist
209 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
210 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
211 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
212 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
213 mkdir -p %{buildroot}%{DOTNET_TOOLS_PATH}
214 mkdir -p %{buildroot}%{DOTNET_PRELOAD_PATH}
216 # Install Runtime Assemblies
217 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
218 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
220 # Install Debug Symbols
221 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
222 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
224 # Install Resource files
225 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
226 && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
227 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
228 && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
230 # Install Dummy Assemblies
231 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
233 # Install NuGet Packages
234 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
235 install -p -m 644 packaging/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
238 install -p -m 644 tools/bin/* %{buildroot}%{DOTNET_TOOLS_PATH}
241 install -p -m 644 packaging/preload/*.preload %{buildroot}%{DOTNET_PRELOAD_PATH}
244 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
245 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
246 /usr/bin/vconftool set -t string db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS} -f
253 %{DOTNET_NUGET_SOURCE}/*.nupkg
256 %manifest %{name}.manifest
257 %{DOTNET_TOOLS_PATH}/*
262 %manifest %{name}.manifest
263 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
264 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
265 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
268 %manifest %{name}.manifest
269 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
271 %files common -f common.filelist
272 %manifest %{name}.manifest
274 %files mobile -f mobile.filelist
275 %manifest %{name}.manifest
277 %files mobile-emul -f mobile-emul.filelist
278 %manifest %{name}.manifest
280 %files tv -f tv.filelist
281 %manifest %{name}.manifest
283 %files wearable -f wearable.filelist
284 %manifest %{name}.manifest