1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 5
4 %define TIZEN_NET_RPM_VERSION 5.0.0.14338+nui500
5 %define TIZEN_NET_NUGET_VERSION 5.0.0.14338
6 %define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.14338
8 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
9 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
10 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
11 %define DOTNET_NUGET_SOURCE /nuget
14 Summary: Assemblies of Tizen .NET
15 Version: %{TIZEN_NET_RPM_VERSION}
17 Group: Development/Libraries
19 URL: https://www.tizen.org
20 Source0: %{name}-%{version}.tar.gz
21 Source1: %{name}.manifest
27 BuildRequires: dotnet-build-tools
28 Requires(post): /usr/bin/vconftool
34 Summary: NuGet package for %{name}
35 Group: Development/Libraries
39 NuGet package for %{name}
42 Summary: Dummy assemblies of Tizen .NET
43 Group: Development/Libraries
47 Dummy assemblies of Tizen .NET
50 Summary: All Tizen .NET assemblies
51 Group: Development/Libraries
52 Requires: %{name} = %{version}-%{release}
56 All Tizen .NET assemblies
59 Summary: All .pdb files of Tizen .NET
60 Group: Development/Libraries
64 All .pdb files of Tizen .NET
67 Summary: Tizen .NET assemblies for Common profile
68 Group: Development/Libraries
69 Requires: %{name} = %{version}-%{release}
70 Requires: csapi-tizenfx-dummy = %{version}-%{release}
74 Tizen .NET assemblies for Common profile
77 Summary: Tizen .NET assemblies for Mobile profile
78 Group: Development/Libraries
79 Requires: %{name} = %{version}-%{release}
80 Requires: csapi-tizenfx-dummy = %{version}-%{release}
84 Tizen .NET assemblies for Mobile profile
87 Summary: Tizen .NET assemblies for Emulator of Mobile profile
88 Group: Development/Libraries
89 Requires: %{name} = %{version}-%{release}
90 Requires: csapi-tizenfx-dummy = %{version}-%{release}
93 %description mobile-emul
94 Tizen .NET assemblies for Emulator of Mobile profile
97 Summary: Tizen .NET assemblies for TV profile
98 Group: Development/Libraries
99 Requires: %{name} = %{version}-%{release}
100 Requires: csapi-tizenfx-dummy = %{version}-%{release}
104 Tizen .NET assemblies for TV profile
107 Summary: Tizen .NET assemblies for IVI profile
108 Group: Development/Libraries
109 Requires: %{name} = %{version}-%{release}
110 Requires: csapi-tizenfx-dummy = %{version}-%{release}
114 Tizen .NET assemblies for IVI profile
117 Summary: Tizen .NET assemblies for Wearable profile
118 Group: Development/Libraries
119 Requires: %{name} = %{version}-%{release}
120 Requires: csapi-tizenfx-dummy = %{version}-%{release}
123 %description wearable
124 Tizen .NET assemblies for Wearable profile
131 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
133 %define _tizenfx_bin_path Artifacts
137 cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
140 GetFileList common > common.filelist
141 GetFileList mobile > mobile.filelist
142 GetFileList mobile-emul > mobile-emul.filelist
143 GetFileList tv > tv.filelist
144 GetFileList ivi > ivi.filelist
145 GetFileList wearable > wearable.filelist
147 rm -fr %{_tizenfx_bin_path}
148 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
151 ./build.sh --pack %{TIZEN_NET_NUGET_VERSION} %{TIZEN_NET_INTERNAL_NUGET_VERSION}
154 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
155 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
156 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
157 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
159 # Install Runtime Assemblies
160 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
161 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
163 # Install Debug Symbols
164 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
165 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
167 # Install Resource files
168 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
169 && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
170 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
171 && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
173 # Install Dummy Assemblies
174 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
176 # Install NuGet Packages
177 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
180 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
187 %{DOTNET_NUGET_SOURCE}/*.nupkg
190 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
193 %manifest %{name}.manifest
194 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
195 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
198 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
200 %files common -f common.filelist
201 %manifest %{name}.manifest
203 %files mobile -f mobile.filelist
204 %manifest %{name}.manifest
206 %files mobile-emul -f mobile-emul.filelist
207 %manifest %{name}.manifest
209 %files tv -f tv.filelist
210 %manifest %{name}.manifest
212 %files ivi -f ivi.filelist
213 %manifest %{name}.manifest
215 %files wearable -f wearable.filelist
216 %manifest %{name}.manifest