1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 4
4 %define TIZEN_NET_RPM_VERSION 4.0.1.57+nui79
5 %define TIZEN_NET_NUGET_VERSION 4.0.1-preview1-00057
6 %define TIZEN_NET_INTERNAL_NUGET_VERSION 4.0.1.57
7 %define NATIVE_DALI_VERSION 1.2.79
8 %define CHECK_NATIVE_DEPS 1
10 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
11 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
12 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
13 %define DOTNET_NUGET_SOURCE /nuget
16 Summary: Assemblies of Tizen .NET
17 Version: %{TIZEN_NET_RPM_VERSION}
19 Group: Development/Libraries
21 URL: https://www.tizen.org
22 Source0: %{name}-%{version}.tar.gz
23 Source1: %{name}.manifest
29 BuildRequires: dotnet-build-tools
30 Requires(post): /usr/bin/vconftool
32 %if 0%{CHECK_NATIVE_DEPS}
33 BuildRequires: dali = %{NATIVE_DALI_VERSION}
40 Summary: NuGet package for %{name}
41 Group: Development/Libraries
45 NuGet package for %{name}
48 Summary: Dummy assemblies of Tizen .NET
49 Group: Development/Libraries
53 Dummy assemblies of Tizen .NET
56 Summary: All Tizen .NET assemblies
57 Group: Development/Libraries
58 Requires: %{name} = %{version}-%{release}
62 All Tizen .NET assemblies
65 Summary: All .pdb files of Tizen .NET
66 Group: Development/Libraries
70 All .pdb files of Tizen .NET
73 Summary: Tizen .NET assemblies for Common profile
74 Group: Development/Libraries
75 Requires: %{name} = %{version}-%{release}
76 Requires: csapi-tizenfx-dummy = %{version}-%{release}
80 Tizen .NET assemblies for Common profile
83 Summary: Tizen .NET assemblies for Mobile profile
84 Group: Development/Libraries
85 Requires: %{name} = %{version}-%{release}
86 Requires: csapi-tizenfx-dummy = %{version}-%{release}
90 Tizen .NET assemblies for Mobile profile
93 Summary: Tizen .NET assemblies for Emulator of Mobile profile
94 Group: Development/Libraries
95 Requires: %{name} = %{version}-%{release}
96 Requires: csapi-tizenfx-dummy = %{version}-%{release}
99 %description mobile-emul
100 Tizen .NET assemblies for Emulator of Mobile profile
103 Summary: Tizen .NET assemblies for TV profile
104 Group: Development/Libraries
105 Requires: %{name} = %{version}-%{release}
106 Requires: csapi-tizenfx-dummy = %{version}-%{release}
110 Tizen .NET assemblies for TV profile
113 Summary: Tizen .NET assemblies for IVI profile
114 Group: Development/Libraries
115 Requires: %{name} = %{version}-%{release}
116 Requires: csapi-tizenfx-dummy = %{version}-%{release}
120 Tizen .NET assemblies for IVI profile
123 Summary: Tizen .NET assemblies for Wearable profile
124 Group: Development/Libraries
125 Requires: %{name} = %{version}-%{release}
126 Requires: csapi-tizenfx-dummy = %{version}-%{release}
129 %description wearable
130 Tizen .NET assemblies for Wearable profile
138 %define _tizenfx_bin_path Artifacts
142 cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
145 GetFileList common > common.filelist
146 GetFileList mobile > mobile.filelist
147 GetFileList mobile-emul > mobile-emul.filelist
148 GetFileList tv > tv.filelist
149 GetFileList ivi > ivi.filelist
150 GetFileList wearable > wearable.filelist
152 rm -fr %{_tizenfx_bin_path}
153 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
156 ./build.sh --pack %{TIZEN_NET_NUGET_VERSION} %{TIZEN_NET_INTERNAL_NUGET_VERSION}
159 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
160 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
161 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
162 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
164 # Install Runtime Assemblies
165 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
166 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
168 # Install Debug Symbols
169 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
170 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
172 # Install Resource files
173 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
174 && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
175 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
176 && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
178 # Install Dummy Assemblies
179 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
181 # Install NuGet Packages
182 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
185 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
192 %{DOTNET_NUGET_SOURCE}/*.nupkg
195 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
198 %manifest %{name}.manifest
199 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
200 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
203 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
205 %files common -f common.filelist
206 %manifest %{name}.manifest
208 %files mobile -f mobile.filelist
209 %manifest %{name}.manifest
211 %files mobile-emul -f mobile-emul.filelist
212 %manifest %{name}.manifest
214 %files tv -f tv.filelist
215 %manifest %{name}.manifest
217 %files ivi -f ivi.filelist
218 %manifest %{name}.manifest
220 %files wearable -f wearable.filelist
221 %manifest %{name}.manifest