1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 11
4 %define TIZEN_NET_RPM_VERSION 11.0.0.18155+nui22302
5 %define TIZEN_NET_NUGET_VERSION 11.0.0.18155
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
11 %define DOTNET_PRELOAD_PATH /usr/share/dotnet.tizen/preload
12 %define DOTNET_LIBRARY_PATH /usr/share/dotnet.tizen/lib
13 %define DOTNET_NUGET_SOURCE /nuget
15 %define TIZEN_NET_RUNTIME_IDENTIFIERS 8.0.0:7.0.0:6.5.0:6.0.0:5.5.0:5.0.0:4.0.0
16 %define TIZEN_NET_TARGET_FRAMEWORK_MONIKERS net6.0-tizen8.0:net6.0-tizen:net6.0:tizen10.0:tizen90:tizen80:tizen70:tizen60:tizen50:tizen40
18 %define UPGRADE_SCRIPT_PATH /usr/share/upgrade/scripts
21 Summary: Assemblies of Tizen .NET
22 Version: %{TIZEN_NET_RPM_VERSION}
24 Group: Development/Libraries
25 License: Apache-2.0 and MIT
26 URL: https://www.tizen.org
27 Source0: %{name}-%{version}.tar.gz
28 Source1: %{name}.manifest
33 BuildRequires: dotnet-build-tools
34 BuildRequires: pkgconfig(dali2-csharp-binder)
35 Requires(post): /usr/bin/vconftool
37 # BuildRequires for StructValidator
38 %if %{defined enable_struct_test}
40 BuildRequires: pkgconfig(elementary)
41 BuildRequires: pkgconfig(efl-extension)
42 BuildRequires: pkgconfig(capi-media-camera)
43 BuildRequires: pkgconfig(rua)
44 BuildRequires: pkgconfig(component-based-core-base)
45 BuildRequires: pkgconfig(notification)
46 BuildRequires: pkgconfig(capi-appfw-service-application)
47 BuildRequires: pkgconfig(capi-appfw-application)
48 BuildRequires: pkgconfig(capi-appfw-widget-application)
49 BuildRequires: pkgconfig(data-control)
50 BuildRequires: pkgconfig(capi-location-manager)
51 BuildRequires: pkgconfig(capi-media-vision)
52 BuildRequires: pkgconfig(capi-network-bluetooth)
53 BuildRequires: pkgconfig(capi-network-wifi-direct)
54 BuildRequires: pkgconfig(key-manager)
55 BuildRequires: pkgconfig(capi-system-sensor)
56 BuildRequires: pkgconfig(capi-system-runtime-info)
57 BuildRequires: pkgconfig(capi-ui-inputmethod)
58 BuildRequires: pkgconfig(stt-engine)
59 BuildRequires: pkgconfig(tts-engine)
60 BuildRequires: pkgconfig(chromium-efl)
61 BuildRequires: pkgconfig(libsessiond)
62 %if "%{profile}" == "tv"
63 BuildRequires: pkgconfig(trustzone-nwd)
65 BuildRequires: pkgconfig(capi-appfw-watch-application)
66 BuildRequires: pkgconfig(capi-telephony)
67 BuildRequires: pkgconfig(tef-libteec)
75 Summary: NuGet package for %{name}
76 Group: Development/Libraries
80 NuGet package for %{name}
83 Summary: Tools for TizenFX
84 Group: Development/Libraries
91 Summary: not used package
92 Group: Development/Libraries
99 Summary: All Tizen .NET assemblies
100 Group: Development/Libraries
101 Requires: %{name} = %{version}-%{release}
105 All Tizen .NET assemblies
108 Summary: All .pdb files of Tizen .NET
109 Group: Development/Libraries
113 All .pdb files of Tizen .NET
116 Summary: Tizen .NET assemblies for Mobile profile
117 Group: Development/Libraries
118 Requires: %{name} = %{version}-%{release}
122 Tizen .NET assemblies for Mobile profile
125 Summary: Tizen .NET assemblies for TV profile
126 Group: Development/Libraries
127 Requires: %{name} = %{version}-%{release}
131 Tizen .NET assemblies for TV profile
134 Summary: Tizen .NET assemblies for Wearable profile
135 Group: Development/Libraries
136 Requires: %{name} = %{version}-%{release}
139 %description wearable
140 Tizen .NET assemblies for Wearable profile
149 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
152 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
153 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
155 # build full assemblies
156 %if %{defined profile}
157 %{build_cmd} --full /p:BuildProfile=%{profile}
163 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
165 # check validation of struct size
166 %if %{defined enable_struct_test}
167 dotnet validate-struct Artifacts/bin/public || echo "
168 #######################################################
169 ##################### W A R N I N G ###################
170 #######################################################
171 # The sturct size mismatches MUST BE FIXED. #
172 # It will make building errors later #
173 #######################################################
179 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
180 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
181 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
182 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
183 mkdir -p %{buildroot}%{DOTNET_TOOLS_PATH}
184 mkdir -p %{buildroot}%{DOTNET_PRELOAD_PATH}
186 # Install Runtime Assemblies
187 install -p -m 644 Artifacts/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
188 install -p -m 644 Artifacts/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
190 # Install Debug Symbols
191 install -p -m 644 Artifacts/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
192 install -p -m 644 Artifacts/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
194 # Install Resource files
195 [ -d Artifacts/bin/public/res ] \
196 && cp -fr Artifacts/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
197 [ -d Artifacts/bin/internal/res ] \
198 && cp -fr Artifacts/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
200 # Install Dummy Assemblies
201 install -p -m 644 Artifacts/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
204 install -p -m 644 Artifacts/preload/*.preload %{buildroot}%{DOTNET_PRELOAD_PATH}
206 # Install NuGet Packages
207 install -p -m 644 Artifacts/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
208 install -p -m 644 packaging/depends/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
211 install -p -m 644 tools/bin/* %{buildroot}%{DOTNET_TOOLS_PATH}
214 # Install Upgrade Script
215 mkdir -p %{buildroot}%{UPGRADE_SCRIPT_PATH}
216 install -p -m 755 packaging/500.tizenfx_upgrade.sh %{buildroot}%{UPGRADE_SCRIPT_PATH}
219 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
220 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
221 mkdir -p %{DOTNET_LIBRARY_PATH}
222 touch %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
223 echo "db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS}" > %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
224 echo "db/dotnet/tizen_tfm_support %{TIZEN_NET_TARGET_FRAMEWORK_MONIKERS}" >> %{DOTNET_LIBRARY_PATH}/dotnet_resolving.info
229 %attr(0755,root,root) %{UPGRADE_SCRIPT_PATH}/500.tizenfx_upgrade.sh
232 %{DOTNET_NUGET_SOURCE}/*.nupkg
235 %manifest %{name}.manifest
236 %{DOTNET_TOOLS_PATH}/*
241 %manifest %{name}.manifest
242 %defattr(644,root,root,755)
243 %{DOTNET_ASSEMBLY_PATH}/*.dll
244 %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
245 %{DOTNET_ASSEMBLY_RES_PATH}/*
246 %{DOTNET_PRELOAD_PATH}/*
249 %manifest %{name}.manifest
250 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
252 %files mobile -f Artifacts/mobile.filelist
253 %manifest %{name}.manifest
255 %files tv -f Artifacts/tv.filelist
256 %manifest %{name}.manifest
258 %files wearable -f Artifacts/wearable.filelist
259 %manifest %{name}.manifest