Release 4.0.0-preview1-00235
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
2 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
3 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
4 %define DOTNET_NUGET_SOURCE /nuget
5
6 %define _tizenfx_bin_path Artifacts
7
8 Name:       csapi-tizenfx
9 Summary:    Assemblies of Tizen .NET
10 Version:    4.0.0.235
11 Release:    1
12 Group:      Development/Libraries
13 License:    Apache-2.0
14 URL:        https://www.tizen.org
15 Source0:    %{name}-%{version}.tar.gz
16 Source1:    %{name}.manifest
17
18 BuildRequires: dotnet-build-tools
19
20 BuildArch: noarch
21 ExcludeArch: aarch64
22 AutoReqProv: no
23
24 %description
25 %{summary}
26
27 %package nuget
28 Summary:   NuGet package for %{name}
29 Group:     Development/Libraries
30 AutoReqProv: no
31
32 %description nuget
33 NuGet package for %{name}
34
35 %package dummy
36 Summary:   Dummy assemblies of Tizen .NET
37 Group:     Development/Libraries
38 AutoReqProv: no
39
40 %description dummy
41 Dummy assemblies of Tizen .NET
42
43 %package full
44 Summary:   All Tizen .NET assemblies
45 Group:     Development/Libraries
46 AutoReqProv: no
47
48 %description full
49 All Tizen .NET assemblies
50
51 %package debug
52 Summary:   All .pdb files of Tizen .NET
53 Group:     Development/Libraries
54 AutoReqProv: no
55
56 %description debug
57 All .pdb files of Tizen .NET
58
59 %package common
60 Summary:   Tizen .NET assemblies for Common profile
61 Group:     Development/Libraries
62 Requires:  csapi-tizenfx-dummy
63 AutoReqProv: no
64
65 %description common
66 Tizen .NET assemblies for Common profile
67
68 %package mobile
69 Summary:   Tizen .NET assemblies for Mobile profile
70 Group:     Development/Libraries
71 Requires:  csapi-tizenfx-dummy
72 AutoReqProv: no
73
74 %description mobile
75 Tizen .NET assemblies for Mobile profile
76
77 %package mobile-emul
78 Summary:   Tizen .NET assemblies for Emulator of Mobile profile
79 Group:     Development/Libraries
80 Requires:  csapi-tizenfx-dummy
81 AutoReqProv: no
82
83 %description mobile-emul
84 Tizen .NET assemblies for Emulator of Mobile profile
85
86 %package tv
87 Summary:   Tizen .NET assemblies for TV profile
88 Group:     Development/Libraries
89 Requires:  csapi-tizenfx-dummy
90 AutoReqProv: no
91
92 %description tv
93 Tizen .NET assemblies for TV profile
94
95 %package ivi
96 Summary:   Tizen .NET assemblies for IVI profile
97 Group:     Development/Libraries
98 Requires:  csapi-tizenfx-dummy
99 AutoReqProv: no
100
101 %description ivi
102 Tizen .NET assemblies for IVI profile
103
104 %package wearable
105 Summary:   Tizen .NET assemblies for Wearable profile
106 Group:     Development/Libraries
107 Requires:  csapi-tizenfx-dummy
108 AutoReqProv: no
109
110 %description wearable
111 Tizen .NET assemblies for Wearable profile
112
113 %prep
114 %setup -q
115 cp %{SOURCE1} .
116
117 %build
118
119 GetFileList() {
120   PROFILE=$1
121   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
122 }
123
124 GetFileList common > common.filelist
125 GetFileList mobile > mobile.filelist
126 GetFileList mobile-emul > mobile-emul.filelist
127 GetFileList tv > tv.filelist
128 GetFileList ivi > ivi.filelist
129 GetFileList wearable > wearable.filelist
130
131 rm -fr %{_tizenfx_bin_path}
132 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
133 ./build.sh --full
134 ./build.sh --dummy
135 ./build.sh --pack 4.0.0-preview1-00235
136
137 %install
138 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
139 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
140 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
141 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
142
143 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
144 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
145 install -p -m 644 %{_tizenfx_bin_path}/bin/platform/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
146 install -p -m 644 %{_tizenfx_bin_path}/bin/platform/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
147 install -p -m 644 %{_tizenfx_bin_path}/bin/platform/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
148 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
149 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
150
151 %files nuget
152 %{DOTNET_NUGET_SOURCE}/*.nupkg
153
154 %files dummy
155 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
156
157 %files full
158 %manifest %{name}.manifest
159 %license LICENSE
160 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
161 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
162
163 %files debug
164 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
165
166 %files common -f common.filelist
167 %manifest %{name}.manifest
168 %license LICENSE
169
170 %files mobile -f mobile.filelist
171 %manifest %{name}.manifest
172 %license LICENSE
173
174 %files mobile-emul -f mobile-emul.filelist
175 %manifest %{name}.manifest
176 %license LICENSE
177
178 %files tv -f tv.filelist
179 %manifest %{name}.manifest
180 %license LICENSE
181
182 %files ivi -f ivi.filelist
183 %manifest %{name}.manifest
184 %license LICENSE
185
186 %files wearable -f wearable.filelist
187 %manifest %{name}.manifest
188 %license LICENSE