Release 8.0.0.15407
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
2
3 %define TIZEN_NET_API_VERSION 8
4 %define TIZEN_NET_RPM_VERSION 8.0.0.15407+nui21916
5 %define TIZEN_NET_NUGET_VERSION 8.0.0.15407
6
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
11 %define DOTNET_PRELOAD_PATH /usr/share/dotnet.tizen/preload
12 %define DOTNET_NUGET_SOURCE /nuget
13
14 %define TIZEN_NET_RUNTIME_IDENTIFIERS 4.0.0:5.0.0:5.5.0:6.0.0
15
16 Name:       csapi-tizenfx
17 Summary:    Assemblies of Tizen .NET
18 Version:    %{TIZEN_NET_RPM_VERSION}
19 Release:    1
20 Group:      Development/Libraries
21 License:    Apache-2.0 and MIT
22 URL:        https://www.tizen.org
23 Source0:    %{name}-%{version}.tar.gz
24 Source1:    %{name}.manifest
25
26 BuildArch:   noarch
27 ExcludeArch: aarch64
28 AutoReqProv: no
29
30 BuildRequires: dotnet-build-tools
31 Requires(post): /usr/bin/vconftool
32
33 # BuildRequires for StructValidator
34 %if %{defined enable_struct_test}
35 BuildRequires: coregl
36 BuildRequires: pkgconfig(elementary)
37 BuildRequires: pkgconfig(efl-extension)
38 BuildRequires: pkgconfig(capi-media-camera)
39 BuildRequires: pkgconfig(rua)
40 BuildRequires: pkgconfig(component-based-core-base)
41 BuildRequires: pkgconfig(notification)
42 BuildRequires: pkgconfig(capi-appfw-service-application)
43 BuildRequires: pkgconfig(capi-appfw-application)
44 BuildRequires: pkgconfig(capi-appfw-widget-application)
45 BuildRequires: pkgconfig(data-control)
46 BuildRequires: pkgconfig(capi-location-manager)
47 BuildRequires: pkgconfig(capi-media-vision)
48 BuildRequires: pkgconfig(capi-network-bluetooth)
49 BuildRequires: pkgconfig(capi-network-wifi-direct)
50 BuildRequires: pkgconfig(key-manager)
51 BuildRequires: pkgconfig(capi-system-sensor)
52 BuildRequires: pkgconfig(capi-system-runtime-info)
53 BuildRequires: pkgconfig(capi-ui-inputmethod)
54 BuildRequires: pkgconfig(stt-engine)
55 BuildRequires: pkgconfig(tts-engine)
56 BuildRequires: pkgconfig(chromium-efl)
57 %if "%{profile}" == "tv"
58 BuildRequires: pkgconfig(trustzone-nwd)
59 %else
60 BuildRequires: pkgconfig(capi-appfw-watch-application)
61 BuildRequires: pkgconfig(capi-telephony)
62 BuildRequires: pkgconfig(tef-libteec)
63 %endif
64 %endif
65
66 %description
67 %{summary}
68
69 %package nuget
70 Summary:   NuGet package for %{name}
71 Group:     Development/Libraries
72 AutoReqProv: no
73
74 %description nuget
75 NuGet package for %{name}
76
77 %package tools
78 Summary:   Tools for TizenFX
79 Group:     Development/Libraries
80 AutoReqProv: no
81
82 %description tools
83 Tools for TizenFX
84
85 %package dummy
86 Summary:   not used package
87 Group:     Development/Libraries
88 AutoReqProv: no
89
90 %description dummy
91 not used package
92
93 %package full
94 Summary:   All Tizen .NET assemblies
95 Group:     Development/Libraries
96 Requires:  %{name} = %{version}-%{release}
97 AutoReqProv: no
98
99 %description full
100 All Tizen .NET assemblies
101
102 %package debug
103 Summary:   All .pdb files of Tizen .NET
104 Group:     Development/Libraries
105 AutoReqProv: no
106
107 %description debug
108 All .pdb files of Tizen .NET
109
110 %package common
111 Summary:   Tizen .NET assemblies for Common profile
112 Group:     Development/Libraries
113 Requires:  %{name} = %{version}-%{release}
114 AutoReqProv: no
115
116 %description common
117 Tizen .NET assemblies for Common profile
118
119 %package mobile
120 Summary:   Tizen .NET assemblies for Mobile profile
121 Group:     Development/Libraries
122 Requires:  %{name} = %{version}-%{release}
123 AutoReqProv: no
124
125 %description mobile
126 Tizen .NET assemblies for Mobile profile
127
128 %package mobile-emul
129 Summary:   Tizen .NET assemblies for Emulator of Mobile profile
130 Group:     Development/Libraries
131 Requires:  %{name} = %{version}-%{release}
132 AutoReqProv: no
133
134 %description mobile-emul
135 Tizen .NET assemblies for Emulator of Mobile profile
136
137 %package tv
138 Summary:   Tizen .NET assemblies for TV profile
139 Group:     Development/Libraries
140 Requires:  %{name} = %{version}-%{release}
141 AutoReqProv: no
142
143 %description tv
144 Tizen .NET assemblies for TV profile
145
146 %package wearable
147 Summary:   Tizen .NET assemblies for Wearable profile
148 Group:     Development/Libraries
149 Requires:  %{name} = %{version}-%{release}
150 AutoReqProv: no
151
152 %description wearable
153 Tizen .NET assemblies for Wearable profile
154
155 %prep
156 %setup -q
157 cp %{SOURCE1} .
158
159 %build
160 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
161
162 %define _tizenfx_bin_path Artifacts
163
164 rm -fr %{_tizenfx_bin_path}
165 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
166
167 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
168 %if %{defined profile}
169 %{build_cmd} --full /p:BuildProfile=%{profile}
170 %else
171 %{build_cmd} --full
172 %endif
173 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
174
175 %if %{defined enable_struct_test}
176 dotnet validate-struct %{_tizenfx_bin_path}/bin/public || echo "
177     #######################################################
178     ##################### W A R N I N G ###################
179     #######################################################
180     # The sturct size mismatches MUST BE FIXED.           #
181     # It will make building errors later                  #
182     #######################################################
183 "
184 %endif
185
186 # Generate filelist for rpm packaging
187 GetFileList() {
188   PROFILE=$1
189   cat packaging/PlatformFileList.txt | grep -v "\.preload" | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
190   for f in $(cat packaging/PlatformFileList.txt | grep -v -E "#$PROFILE[[:space:]]|#$PROFILE$|\.preload" | cut -d# -f1); do
191     if [ -f %{_tizenfx_bin_path}/bin/dummy/$f ]; then
192       echo "%{DOTNET_ASSEMBLY_PATH}/ref/$f"
193     fi
194   done
195   for f in $(cat packaging/PlatformFileList.txt | grep "\.preload" | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1); do
196     if [ -f packaging/preload/$f ]; then
197       echo "%{DOTNET_PRELOAD_PATH}/$f"
198     fi
199   done
200 }
201
202 GetFileList common > common.filelist
203 GetFileList mobile > mobile.filelist
204 GetFileList mobile-emul > mobile-emul.filelist
205 GetFileList tv > tv.filelist
206 GetFileList wearable > wearable.filelist
207
208 %install
209 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
210 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
211 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
212 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
213 mkdir -p %{buildroot}%{DOTNET_TOOLS_PATH}
214 mkdir -p %{buildroot}%{DOTNET_PRELOAD_PATH}
215
216 # Install Runtime Assemblies
217 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
218 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
219
220 # Install Debug Symbols
221 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
222 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
223
224 # Install Resource files
225 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
226   && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
227 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
228   && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
229
230 # Install Dummy Assemblies
231 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
232
233 # Install NuGet Packages
234 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
235 install -p -m 644 packaging/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
236
237 # Install Tools
238 install -p -m 644 tools/bin/* %{buildroot}%{DOTNET_TOOLS_PATH}
239
240 # Install Preload
241 install -p -m 644 packaging/preload/*.preload %{buildroot}%{DOTNET_PRELOAD_PATH}
242
243 %post
244 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
245 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
246 /usr/bin/vconftool set -t string db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS} -f
247
248 %files
249 %license LICENSE
250 %license LICENSE.MIT
251
252 %files nuget
253 %{DOTNET_NUGET_SOURCE}/*.nupkg
254
255 %files tools
256 %manifest %{name}.manifest
257 %{DOTNET_TOOLS_PATH}/*
258
259 %files dummy
260
261 %files full
262 %manifest %{name}.manifest
263 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
264 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
265 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
266
267 %files debug
268 %manifest %{name}.manifest
269 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
270
271 %files common -f common.filelist
272 %manifest %{name}.manifest
273
274 %files mobile -f mobile.filelist
275 %manifest %{name}.manifest
276
277 %files mobile-emul -f mobile-emul.filelist
278 %manifest %{name}.manifest
279
280 %files tv -f tv.filelist
281 %manifest %{name}.manifest
282
283 %files wearable -f wearable.filelist
284 %manifest %{name}.manifest