1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 9
4 %define TIZEN_NET_RPM_VERSION 9.0.0.16823+nui22045
5 %define TIZEN_NET_NUGET_VERSION 9.0.0.16823
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
11 %define DOTNET_PRELOAD_PATH /usr/share/dotnet.tizen/preload
12 %define DOTNET_NUGET_SOURCE /nuget
14 %define TIZEN_NET_RUNTIME_IDENTIFIERS 4.0.0:5.0.0:5.5.0:6.0.0:6.5.0
15 %define TIZEN_NET_TARGET_FRAMEWORK_MONIKERS tizen90:tizen80:tizen70:tizen60:tizen50:tizen40
17 %define UPGRADE_SCRIPT_PATH /usr/share/upgrade/scripts
20 Summary: Assemblies of Tizen .NET
21 Version: %{TIZEN_NET_RPM_VERSION}
23 Group: Development/Libraries
24 License: Apache-2.0 and MIT
25 URL: https://www.tizen.org
26 Source0: %{name}-%{version}.tar.gz
27 Source1: %{name}.manifest
33 BuildRequires: dotnet-build-tools
34 Requires(post): /usr/bin/vconftool
36 # BuildRequires for StructValidator
37 %if %{defined enable_struct_test}
39 BuildRequires: pkgconfig(elementary)
40 BuildRequires: pkgconfig(efl-extension)
41 BuildRequires: pkgconfig(capi-media-camera)
42 BuildRequires: pkgconfig(rua)
43 BuildRequires: pkgconfig(component-based-core-base)
44 BuildRequires: pkgconfig(notification)
45 BuildRequires: pkgconfig(capi-appfw-service-application)
46 BuildRequires: pkgconfig(capi-appfw-application)
47 BuildRequires: pkgconfig(capi-appfw-widget-application)
48 BuildRequires: pkgconfig(data-control)
49 BuildRequires: pkgconfig(capi-location-manager)
50 BuildRequires: pkgconfig(capi-media-vision)
51 BuildRequires: pkgconfig(capi-network-bluetooth)
52 BuildRequires: pkgconfig(capi-network-wifi-direct)
53 BuildRequires: pkgconfig(key-manager)
54 BuildRequires: pkgconfig(capi-system-sensor)
55 BuildRequires: pkgconfig(capi-system-runtime-info)
56 BuildRequires: pkgconfig(capi-ui-inputmethod)
57 BuildRequires: pkgconfig(stt-engine)
58 BuildRequires: pkgconfig(tts-engine)
59 BuildRequires: pkgconfig(chromium-efl)
60 %if "%{profile}" == "tv"
61 BuildRequires: pkgconfig(trustzone-nwd)
63 BuildRequires: pkgconfig(capi-appfw-watch-application)
64 BuildRequires: pkgconfig(capi-telephony)
65 BuildRequires: pkgconfig(tef-libteec)
73 Summary: NuGet package for %{name}
74 Group: Development/Libraries
78 NuGet package for %{name}
81 Summary: Tools for TizenFX
82 Group: Development/Libraries
89 Summary: not used package
90 Group: Development/Libraries
97 Summary: All Tizen .NET assemblies
98 Group: Development/Libraries
99 Requires: %{name} = %{version}-%{release}
103 All Tizen .NET assemblies
106 Summary: All .pdb files of Tizen .NET
107 Group: Development/Libraries
111 All .pdb files of Tizen .NET
114 Summary: Tizen .NET assemblies for Mobile profile
115 Group: Development/Libraries
116 Requires: %{name} = %{version}-%{release}
120 Tizen .NET assemblies for Mobile profile
123 Summary: Tizen .NET assemblies for TV profile
124 Group: Development/Libraries
125 Requires: %{name} = %{version}-%{release}
129 Tizen .NET assemblies for TV profile
132 Summary: Tizen .NET assemblies for Wearable profile
133 Group: Development/Libraries
134 Requires: %{name} = %{version}-%{release}
137 %description wearable
138 Tizen .NET assemblies for Wearable profile
147 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
150 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
151 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
153 # build full assemblies
154 %if %{defined profile}
155 %{build_cmd} --full /p:BuildProfile=%{profile}
161 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
163 # check validation of struct size
164 %if %{defined enable_struct_test}
165 dotnet validate-struct Artifacts/bin/public || echo "
166 #######################################################
167 ##################### W A R N I N G ###################
168 #######################################################
169 # The sturct size mismatches MUST BE FIXED. #
170 # It will make building errors later #
171 #######################################################
177 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
178 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
179 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
180 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
181 mkdir -p %{buildroot}%{DOTNET_TOOLS_PATH}
182 mkdir -p %{buildroot}%{DOTNET_PRELOAD_PATH}
184 # Install Runtime Assemblies
185 install -p -m 644 Artifacts/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
186 install -p -m 644 Artifacts/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
188 # Install Debug Symbols
189 install -p -m 644 Artifacts/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
190 install -p -m 644 Artifacts/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
192 # Install Resource files
193 [ -d Artifacts/bin/public/res ] \
194 && cp -fr Artifacts/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
195 [ -d Artifacts/bin/internal/res ] \
196 && cp -fr Artifacts/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
198 # Install Dummy Assemblies
199 install -p -m 644 Artifacts/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
202 install -p -m 644 Artifacts/preload/*.preload %{buildroot}%{DOTNET_PRELOAD_PATH}
204 # Install NuGet Packages
205 install -p -m 644 Artifacts/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
206 install -p -m 644 packaging/depends/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
209 install -p -m 644 tools/bin/* %{buildroot}%{DOTNET_TOOLS_PATH}
212 # Install Upgrade Script
213 mkdir -p %{buildroot}%{UPGRADE_SCRIPT_PATH}
214 install -p -m 755 packaging/500.tizenfx_upgrade.sh %{buildroot}%{UPGRADE_SCRIPT_PATH}
217 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
218 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
219 /usr/bin/vconftool set -t string db/dotnet/tizen_rid_version %{TIZEN_NET_RUNTIME_IDENTIFIERS} -f
220 /usr/bin/vconftool set -t string db/dotnet/tizen_tfm_support %{TIZEN_NET_TARGET_FRAMEWORK_MONIKERS} -f
225 %attr(0755,root,root) %{UPGRADE_SCRIPT_PATH}/500.tizenfx_upgrade.sh
228 %{DOTNET_NUGET_SOURCE}/*.nupkg
231 %manifest %{name}.manifest
232 %{DOTNET_TOOLS_PATH}/*
237 %manifest %{name}.manifest
238 %defattr(644,root,root,755)
239 %{DOTNET_ASSEMBLY_PATH}/*.dll
240 %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
241 %{DOTNET_ASSEMBLY_RES_PATH}/*
242 %{DOTNET_PRELOAD_PATH}/*
245 %manifest %{name}.manifest
246 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
248 %files mobile -f Artifacts/mobile.filelist
249 %manifest %{name}.manifest
251 %files tv -f Artifacts/tv.filelist
252 %manifest %{name}.manifest
254 %files wearable -f Artifacts/wearable.filelist
255 %manifest %{name}.manifest