1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
3 %define TIZEN_NET_API_VERSION 6
4 %define TIZEN_NET_RPM_VERSION 6.0.0.14969+nui550
5 %define TIZEN_NET_NUGET_VERSION 6.0.0.14969
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_TOOLS_PATH /usr/share/dotnet.tizen/tools
11 %define DOTNET_NUGET_SOURCE /nuget
14 Summary: Assemblies of Tizen .NET
15 Version: %{TIZEN_NET_RPM_VERSION}
17 Group: Development/Libraries
18 License: Apache-2.0 and MIT
19 URL: https://www.tizen.org
20 Source0: %{name}-%{version}.tar.gz
21 Source1: %{name}.manifest
27 BuildRequires: dotnet-build-tools
28 Requires(post): /usr/bin/vconftool
34 Summary: NuGet package for %{name}
35 Group: Development/Libraries
39 NuGet package for %{name}
42 Summary: Tools for TizenFX
43 Group: Development/Libraries
50 Summary: not used package
51 Group: Development/Libraries
58 Summary: All Tizen .NET assemblies
59 Group: Development/Libraries
60 Requires: %{name} = %{version}-%{release}
64 All Tizen .NET assemblies
67 Summary: All .pdb files of Tizen .NET
68 Group: Development/Libraries
72 All .pdb files of Tizen .NET
75 Summary: Tizen .NET assemblies for Common profile
76 Group: Development/Libraries
77 Requires: %{name} = %{version}-%{release}
81 Tizen .NET assemblies for Common profile
84 Summary: Tizen .NET assemblies for Mobile profile
85 Group: Development/Libraries
86 Requires: %{name} = %{version}-%{release}
90 Tizen .NET assemblies for Mobile profile
93 Summary: Tizen .NET assemblies for Emulator of Mobile profile
94 Group: Development/Libraries
95 Requires: %{name} = %{version}-%{release}
98 %description mobile-emul
99 Tizen .NET assemblies for Emulator of Mobile profile
102 Summary: Tizen .NET assemblies for TV profile
103 Group: Development/Libraries
104 Requires: %{name} = %{version}-%{release}
108 Tizen .NET assemblies for TV profile
111 Summary: Tizen .NET assemblies for Wearable profile
112 Group: Development/Libraries
113 Requires: %{name} = %{version}-%{release}
116 %description wearable
117 Tizen .NET assemblies for Wearable profile
124 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
126 %define _tizenfx_bin_path Artifacts
128 rm -fr %{_tizenfx_bin_path}
129 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
131 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
133 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
137 cat packaging/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
138 for f in $(cat packaging/PlatformFileList.txt | grep -v -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1); do
139 if [ -f %{_tizenfx_bin_path}/bin/dummy/$f ]; then
140 echo "%{DOTNET_ASSEMBLY_PATH}/ref/$f"
145 GetFileList common > common.filelist
146 GetFileList mobile > mobile.filelist
147 GetFileList mobile-emul > mobile-emul.filelist
148 GetFileList tv > tv.filelist
149 GetFileList wearable > wearable.filelist
152 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
153 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
154 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
155 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
156 mkdir -p %{buildroot}%{DOTNET_TOOLS_PATH}
158 # Install Runtime Assemblies
159 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
160 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
162 # Install Debug Symbols
163 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
164 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
166 # Install Resource files
167 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
168 && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
169 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
170 && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
172 # Install Dummy Assemblies
173 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
175 # Install NuGet Packages
176 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
177 install -p -m 644 packaging/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
180 install -p -m 644 tools/bin/* %{buildroot}%{DOTNET_TOOLS_PATH}
183 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
184 /usr/bin/vconftool set -t string db/dotnet/tizen_api_path %{DOTNET_ASSEMBLY_PATH} -f
190 %{DOTNET_NUGET_SOURCE}/*.nupkg
193 %manifest %{name}.manifest
194 %{DOTNET_TOOLS_PATH}/*
199 %manifest %{name}.manifest
200 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
201 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
202 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
205 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
207 %files common -f common.filelist
208 %manifest %{name}.manifest
210 %files mobile -f mobile.filelist
211 %manifest %{name}.manifest
213 %files mobile-emul -f mobile-emul.filelist
214 %manifest %{name}.manifest
216 %files tv -f tv.filelist
217 %manifest %{name}.manifest
219 %files wearable -f wearable.filelist
220 %manifest %{name}.manifest