Release 5.0.0.14591
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
2
3 %define TIZEN_NET_API_VERSION 5
4 %define TIZEN_NET_RPM_VERSION 5.0.0.14591+nui505
5 %define TIZEN_NET_NUGET_VERSION 5.0.0.14591
6
7 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
8 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
9 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
10 %define DOTNET_NUGET_SOURCE /nuget
11
12 Name:       csapi-tizenfx
13 Summary:    Assemblies of Tizen .NET
14 Version:    %{TIZEN_NET_RPM_VERSION}
15 Release:    1
16 Group:      Development/Libraries
17 License:    Apache-2.0 and MIT
18 URL:        https://www.tizen.org
19 Source0:    %{name}-%{version}.tar.gz
20 Source1:    %{name}.manifest
21
22 BuildArch:   noarch
23 ExcludeArch: aarch64
24 AutoReqProv: no
25
26 BuildRequires: dotnet-build-tools
27 Requires(post): /usr/bin/vconftool
28
29 %description
30 %{summary}
31
32 %package nuget
33 Summary:   NuGet package for %{name}
34 Group:     Development/Libraries
35 AutoReqProv: no
36
37 %description nuget
38 NuGet package for %{name}
39
40 %package dummy
41 Summary:   Dummy assemblies of Tizen .NET
42 Group:     Development/Libraries
43 AutoReqProv: no
44
45 %description dummy
46 Dummy assemblies of Tizen .NET
47
48 %package full
49 Summary:   All Tizen .NET assemblies
50 Group:     Development/Libraries
51 Requires:  %{name} = %{version}-%{release}
52 AutoReqProv: no
53
54 %description full
55 All Tizen .NET assemblies
56
57 %package debug
58 Summary:   All .pdb files of Tizen .NET
59 Group:     Development/Libraries
60 AutoReqProv: no
61
62 %description debug
63 All .pdb files of Tizen .NET
64
65 %package common
66 Summary:   Tizen .NET assemblies for Common profile
67 Group:     Development/Libraries
68 Requires:  %{name} = %{version}-%{release}
69 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
70 AutoReqProv: no
71
72 %description common
73 Tizen .NET assemblies for Common profile
74
75 %package mobile
76 Summary:   Tizen .NET assemblies for Mobile profile
77 Group:     Development/Libraries
78 Requires:  %{name} = %{version}-%{release}
79 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
80 AutoReqProv: no
81
82 %description mobile
83 Tizen .NET assemblies for Mobile profile
84
85 %package mobile-emul
86 Summary:   Tizen .NET assemblies for Emulator of Mobile profile
87 Group:     Development/Libraries
88 Requires:  %{name} = %{version}-%{release}
89 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
90 AutoReqProv: no
91
92 %description mobile-emul
93 Tizen .NET assemblies for Emulator of Mobile profile
94
95 %package tv
96 Summary:   Tizen .NET assemblies for TV profile
97 Group:     Development/Libraries
98 Requires:  %{name} = %{version}-%{release}
99 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
100 AutoReqProv: no
101
102 %description tv
103 Tizen .NET assemblies for TV profile
104
105 %package ivi
106 Summary:   Tizen .NET assemblies for IVI profile
107 Group:     Development/Libraries
108 Requires:  %{name} = %{version}-%{release}
109 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
110 AutoReqProv: no
111
112 %description ivi
113 Tizen .NET assemblies for IVI profile
114
115 %package wearable
116 Summary:   Tizen .NET assemblies for Wearable profile
117 Group:     Development/Libraries
118 Requires:  %{name} = %{version}-%{release}
119 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
120 AutoReqProv: no
121
122 %description wearable
123 Tizen .NET assemblies for Wearable profile
124
125 %prep
126 %setup -q
127 cp %{SOURCE1} .
128
129 %build
130 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
131
132 %define _tizenfx_bin_path Artifacts
133
134 GetFileList() {
135   PROFILE=$1
136   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
137 }
138
139 GetFileList common > common.filelist
140 GetFileList mobile > mobile.filelist
141 GetFileList mobile-emul > mobile-emul.filelist
142 GetFileList tv > tv.filelist
143 GetFileList ivi > ivi.filelist
144 GetFileList wearable > wearable.filelist
145
146 rm -fr %{_tizenfx_bin_path}
147 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
148
149 %define build_cmd ./tools/scripts/retry.sh ./tools/scripts/timeout.sh -t 600 ./build.sh
150 %{build_cmd} --full
151 %{build_cmd} --dummy
152 %{build_cmd} --pack %{TIZEN_NET_NUGET_VERSION}
153
154 %install
155 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
156 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
157 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
158 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
159
160 # Install Runtime Assemblies
161 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
162 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
163
164 # Install Debug Symbols
165 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
166 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
167
168 # Install Resource files
169 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
170   && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
171 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
172   && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
173
174 # Install Dummy Assemblies
175 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
176
177 # Install NuGet Packages
178 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
179
180 %post
181 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
182
183
184 %files
185 %license LICENSE
186
187 %files nuget
188 %{DOTNET_NUGET_SOURCE}/*.nupkg
189
190 %files dummy
191 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
192
193 %files full
194 %manifest %{name}.manifest
195 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
196 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
197
198 %files debug
199 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
200
201 %files common -f common.filelist
202 %manifest %{name}.manifest
203
204 %files mobile -f mobile.filelist
205 %manifest %{name}.manifest
206
207 %files mobile-emul -f mobile-emul.filelist
208 %manifest %{name}.manifest
209
210 %files tv -f tv.filelist
211 %manifest %{name}.manifest
212
213 %files ivi -f ivi.filelist
214 %manifest %{name}.manifest
215
216 %files wearable -f wearable.filelist
217 %manifest %{name}.manifest