Release 5.0.0.14267
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
2
3 %define TIZEN_NET_API_VERSION 5
4 %define TIZEN_NET_RPM_VERSION 5.0.0.14267+nui83
5 %define TIZEN_NET_NUGET_VERSION 5.0.0.14267
6 %define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.14267
7
8 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
9 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
10 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
11 %define DOTNET_NUGET_SOURCE /nuget
12
13 Name:       csapi-tizenfx
14 Summary:    Assemblies of Tizen .NET
15 Version:    %{TIZEN_NET_RPM_VERSION}
16 Release:    1
17 Group:      Development/Libraries
18 License:    Apache-2.0
19 URL:        https://www.tizen.org
20 Source0:    %{name}-%{version}.tar.gz
21 Source1:    %{name}.manifest
22
23 BuildArch:   noarch
24 ExcludeArch: aarch64
25 AutoReqProv: no
26
27 BuildRequires: dotnet-build-tools
28 Requires(post): /usr/bin/vconftool
29
30 %description
31 %{summary}
32
33 %package nuget
34 Summary:   NuGet package for %{name}
35 Group:     Development/Libraries
36 AutoReqProv: no
37
38 %description nuget
39 NuGet package for %{name}
40
41 %package dummy
42 Summary:   Dummy assemblies of Tizen .NET
43 Group:     Development/Libraries
44 AutoReqProv: no
45
46 %description dummy
47 Dummy assemblies of Tizen .NET
48
49 %package full
50 Summary:   All Tizen .NET assemblies
51 Group:     Development/Libraries
52 Requires:  %{name} = %{version}-%{release}
53 AutoReqProv: no
54
55 %description full
56 All Tizen .NET assemblies
57
58 %package debug
59 Summary:   All .pdb files of Tizen .NET
60 Group:     Development/Libraries
61 AutoReqProv: no
62
63 %description debug
64 All .pdb files of Tizen .NET
65
66 %package common
67 Summary:   Tizen .NET assemblies for Common profile
68 Group:     Development/Libraries
69 Requires:  %{name} = %{version}-%{release}
70 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
71 AutoReqProv: no
72
73 %description common
74 Tizen .NET assemblies for Common profile
75
76 %package mobile
77 Summary:   Tizen .NET assemblies for Mobile profile
78 Group:     Development/Libraries
79 Requires:  %{name} = %{version}-%{release}
80 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
81 AutoReqProv: no
82
83 %description mobile
84 Tizen .NET assemblies for Mobile profile
85
86 %package mobile-emul
87 Summary:   Tizen .NET assemblies for Emulator of Mobile profile
88 Group:     Development/Libraries
89 Requires:  %{name} = %{version}-%{release}
90 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
91 AutoReqProv: no
92
93 %description mobile-emul
94 Tizen .NET assemblies for Emulator of Mobile profile
95
96 %package tv
97 Summary:   Tizen .NET assemblies for TV profile
98 Group:     Development/Libraries
99 Requires:  %{name} = %{version}-%{release}
100 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
101 AutoReqProv: no
102
103 %description tv
104 Tizen .NET assemblies for TV profile
105
106 %package ivi
107 Summary:   Tizen .NET assemblies for IVI profile
108 Group:     Development/Libraries
109 Requires:  %{name} = %{version}-%{release}
110 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
111 AutoReqProv: no
112
113 %description ivi
114 Tizen .NET assemblies for IVI profile
115
116 %package wearable
117 Summary:   Tizen .NET assemblies for Wearable profile
118 Group:     Development/Libraries
119 Requires:  %{name} = %{version}-%{release}
120 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
121 AutoReqProv: no
122
123 %description wearable
124 Tizen .NET assemblies for Wearable profile
125
126 %prep
127 %setup -q
128 cp %{SOURCE1} .
129
130 %build
131
132 %define _tizenfx_bin_path Artifacts
133
134 GetFileList() {
135   PROFILE=$1
136   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
137 }
138
139 GetFileList common > common.filelist
140 GetFileList mobile > mobile.filelist
141 GetFileList mobile-emul > mobile-emul.filelist
142 GetFileList tv > tv.filelist
143 GetFileList ivi > ivi.filelist
144 GetFileList wearable > wearable.filelist
145
146 rm -fr %{_tizenfx_bin_path}
147 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
148 ./build.sh --full
149 ./build.sh --dummy
150 ./build.sh --pack %{TIZEN_NET_NUGET_VERSION} %{TIZEN_NET_INTERNAL_NUGET_VERSION}
151
152 %install
153 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
154 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
155 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
156 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
157
158 # Install Runtime Assemblies
159 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
160 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
161
162 # Install Debug Symbols
163 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
164 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
165
166 # Install Resource files
167 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
168   && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
169 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
170   && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
171
172 # Install Dummy Assemblies
173 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
174
175 # Install NuGet Packages
176 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
177
178 %post
179 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
180
181
182 %files
183 %license LICENSE
184
185 %files nuget
186 %{DOTNET_NUGET_SOURCE}/*.nupkg
187
188 %files dummy
189 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
190
191 %files full
192 %manifest %{name}.manifest
193 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
194 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
195
196 %files debug
197 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
198
199 %files common -f common.filelist
200 %manifest %{name}.manifest
201
202 %files mobile -f mobile.filelist
203 %manifest %{name}.manifest
204
205 %files mobile-emul -f mobile-emul.filelist
206 %manifest %{name}.manifest
207
208 %files tv -f tv.filelist
209 %manifest %{name}.manifest
210
211 %files ivi -f ivi.filelist
212 %manifest %{name}.manifest
213
214 %files wearable -f wearable.filelist
215 %manifest %{name}.manifest