Release 4.0.0-preview1-00051
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
2 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
3 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
4 %define DOTNET_NUGET_SOURCE /nuget
5
6 Name:       csapi-tizenfx
7 Summary:    Assemblies of Tizen .NET
8 Version:    4.0.0.51
9 Release:    1
10 Group:      Development/Libraries
11 License:    Apache-2.0
12 URL:        https://www.tizen.org
13 Source0:    %{name}-%{version}.tar.gz
14 Source1:    %{name}.manifest
15
16 BuildArch: noarch
17 AutoReqProv: no
18
19 %description
20 %{summary}
21
22 %package nuget
23 Summary:   NuGet package for %{name}
24 Group:     Development/Libraries
25 AutoReqProv: no
26
27 %description nuget
28 NuGet package for %{name}
29
30 %package dummy
31 Summary:   Dummy assemblies of Tizen .NET
32 Group:     Development/Libraries
33 AutoReqProv: no
34
35 %description dummy
36 Dummy assemblies of Tizen .NET
37
38 %package tv
39 Summary:   Tizen .NET assemblies for TV profile
40 Group:     Development/Libraries
41 Requires:  csapi-tizenfx-dummy
42 AutoReqProv: no
43
44 %description tv
45 Tizen .NET assemblies for TV profile
46
47 %prep
48 %setup -q
49 cp %{SOURCE1} .
50
51 %build
52
53 %install
54 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
55 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
56 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
57 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
58
59 install -p -m 644 binaries/frameworks/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
60 install -p -m 644 binaries/frameworks/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
61 install -p -m 644 binaries/frameworks_dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
62 install -p -m 644 binaries/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
63
64 %files
65 %manifest %{name}.manifest
66 %license LICENSE
67 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
68 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
69
70 %files nuget
71 %{DOTNET_NUGET_SOURCE}/*.nupkg
72
73 %files dummy
74 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
75
76 %files tv -f csapi-tizenfx-tv.files
77 %manifest %{name}.manifest
78 %license LICENSE