Release 5.0.0.14392
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizenfx.spec
1 # Auto-generated from csapi-tizenfx.spec.in by makespec.sh
2
3 %define TIZEN_NET_API_VERSION 5
4 %define TIZEN_NET_RPM_VERSION 5.0.0.14392+nui502
5 %define TIZEN_NET_NUGET_VERSION 5.0.0.14392
6 %define TIZEN_NET_INTERNAL_NUGET_VERSION 5.0.0.14392
7
8 %define DOTNET_ASSEMBLY_PATH /usr/share/dotnet.tizen/framework
9 %define DOTNET_ASSEMBLY_DUMMY_PATH %{DOTNET_ASSEMBLY_PATH}/ref
10 %define DOTNET_ASSEMBLY_RES_PATH %{DOTNET_ASSEMBLY_PATH}/res
11 %define DOTNET_NUGET_SOURCE /nuget
12
13 Name:       csapi-tizenfx
14 Summary:    Assemblies of Tizen .NET
15 Version:    %{TIZEN_NET_RPM_VERSION}
16 Release:    1
17 Group:      Development/Libraries
18 License:    Apache-2.0
19 URL:        https://www.tizen.org
20 Source0:    %{name}-%{version}.tar.gz
21 Source1:    %{name}.manifest
22
23 BuildArch:   noarch
24 ExcludeArch: aarch64
25 AutoReqProv: no
26
27 BuildRequires: dotnet-build-tools
28 Requires(post): /usr/bin/vconftool
29
30 %description
31 %{summary}
32
33 %package nuget
34 Summary:   NuGet package for %{name}
35 Group:     Development/Libraries
36 AutoReqProv: no
37
38 %description nuget
39 NuGet package for %{name}
40
41 %package dummy
42 Summary:   Dummy assemblies of Tizen .NET
43 Group:     Development/Libraries
44 AutoReqProv: no
45
46 %description dummy
47 Dummy assemblies of Tizen .NET
48
49 %package full
50 Summary:   All Tizen .NET assemblies
51 Group:     Development/Libraries
52 Requires:  %{name} = %{version}-%{release}
53 AutoReqProv: no
54
55 %description full
56 All Tizen .NET assemblies
57
58 %package debug
59 Summary:   All .pdb files of Tizen .NET
60 Group:     Development/Libraries
61 AutoReqProv: no
62
63 %description debug
64 All .pdb files of Tizen .NET
65
66 %package common
67 Summary:   Tizen .NET assemblies for Common profile
68 Group:     Development/Libraries
69 Requires:  %{name} = %{version}-%{release}
70 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
71 AutoReqProv: no
72
73 %description common
74 Tizen .NET assemblies for Common profile
75
76 %package mobile
77 Summary:   Tizen .NET assemblies for Mobile profile
78 Group:     Development/Libraries
79 Requires:  %{name} = %{version}-%{release}
80 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
81 AutoReqProv: no
82
83 %description mobile
84 Tizen .NET assemblies for Mobile profile
85
86 %package mobile-emul
87 Summary:   Tizen .NET assemblies for Emulator of Mobile profile
88 Group:     Development/Libraries
89 Requires:  %{name} = %{version}-%{release}
90 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
91 AutoReqProv: no
92
93 %description mobile-emul
94 Tizen .NET assemblies for Emulator of Mobile profile
95
96 %package tv
97 Summary:   Tizen .NET assemblies for TV profile
98 Group:     Development/Libraries
99 Requires:  %{name} = %{version}-%{release}
100 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
101 AutoReqProv: no
102
103 %description tv
104 Tizen .NET assemblies for TV profile
105
106 %package ivi
107 Summary:   Tizen .NET assemblies for IVI profile
108 Group:     Development/Libraries
109 Requires:  %{name} = %{version}-%{release}
110 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
111 AutoReqProv: no
112
113 %description ivi
114 Tizen .NET assemblies for IVI profile
115
116 %package wearable
117 Summary:   Tizen .NET assemblies for Wearable profile
118 Group:     Development/Libraries
119 Requires:  %{name} = %{version}-%{release}
120 Requires:  csapi-tizenfx-dummy = %{version}-%{release}
121 AutoReqProv: no
122
123 %description wearable
124 Tizen .NET assemblies for Wearable profile
125
126 %prep
127 %setup -q
128 cp %{SOURCE1} .
129
130 %build
131 %{?asan:export ASAN_OPTIONS=use_sigaltstack=false:allow_user_segv_handler=true:handle_sigfpe=false:`cat /ASAN_OPTIONS`}
132
133 %define _tizenfx_bin_path Artifacts
134
135 GetFileList() {
136   PROFILE=$1
137   cat pkg/PlatformFileList.txt | grep -E "#$PROFILE[[:space:]]|#$PROFILE$" | cut -d# -f1 | sed "s#^#%{DOTNET_ASSEMBLY_PATH}/#"
138 }
139
140 GetFileList common > common.filelist
141 GetFileList mobile > mobile.filelist
142 GetFileList mobile-emul > mobile-emul.filelist
143 GetFileList tv > tv.filelist
144 GetFileList ivi > ivi.filelist
145 GetFileList wearable > wearable.filelist
146
147 rm -fr %{_tizenfx_bin_path}
148 export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
149 ./build.sh --full
150 ./build.sh --dummy
151 ./build.sh --pack %{TIZEN_NET_NUGET_VERSION} %{TIZEN_NET_INTERNAL_NUGET_VERSION}
152
153 %install
154 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_PATH}
155 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
156 mkdir -p %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
157 mkdir -p %{buildroot}%{DOTNET_NUGET_SOURCE}
158
159 # Install Runtime Assemblies
160 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
161 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.dll %{buildroot}%{DOTNET_ASSEMBLY_PATH}
162
163 # Install Debug Symbols
164 install -p -m 644 %{_tizenfx_bin_path}/bin/public/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
165 install -p -m 644 %{_tizenfx_bin_path}/bin/internal/*.pdb %{buildroot}%{DOTNET_ASSEMBLY_PATH}
166
167 # Install Resource files
168 [ -d %{_tizenfx_bin_path}/bin/public/res ] \
169   && install -p -m 644 %{_tizenfx_bin_path}/bin/public/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
170 [ -d %{_tizenfx_bin_path}/bin/internal/res ] \
171   && install -p -m 644 %{_tizenfx_bin_path}/bin/internal/res/* %{buildroot}%{DOTNET_ASSEMBLY_RES_PATH}
172
173 # Install Dummy Assemblies
174 install -p -m 644 %{_tizenfx_bin_path}/bin/dummy/*.dll %{buildroot}%{DOTNET_ASSEMBLY_DUMMY_PATH}
175
176 # Install NuGet Packages
177 install -p -m 644 %{_tizenfx_bin_path}/*.nupkg %{buildroot}%{DOTNET_NUGET_SOURCE}
178
179 %post
180 /usr/bin/vconftool set -t int db/dotnet/tizen_api_version %{TIZEN_NET_API_VERSION} -f
181
182
183 %files
184 %license LICENSE
185
186 %files nuget
187 %{DOTNET_NUGET_SOURCE}/*.nupkg
188
189 %files dummy
190 %attr(644,root,root) %{DOTNET_ASSEMBLY_DUMMY_PATH}/*.dll
191
192 %files full
193 %manifest %{name}.manifest
194 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.dll
195 %attr(644,root,root) %{DOTNET_ASSEMBLY_RES_PATH}/*
196
197 %files debug
198 %attr(644,root,root) %{DOTNET_ASSEMBLY_PATH}/*.pdb
199
200 %files common -f common.filelist
201 %manifest %{name}.manifest
202
203 %files mobile -f mobile.filelist
204 %manifest %{name}.manifest
205
206 %files mobile-emul -f mobile-emul.filelist
207 %manifest %{name}.manifest
208
209 %files tv -f tv.filelist
210 %manifest %{name}.manifest
211
212 %files ivi -f ivi.filelist
213 %manifest %{name}.manifest
214
215 %files wearable -f wearable.filelist
216 %manifest %{name}.manifest