084c7337fed29e03fca244935e30a809020a6ecb
[platform/core/csapi/tizenfx.git] / packaging / csapi-tizen.spec
1 Name:       csapi-tizen
2 Summary:    Tizen API for C#
3 Version:    1.0.3
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 %define Assemblies Tizen
17
18
19 %description
20 %{summary}
21
22 %dotnet_import_sub_packages
23
24 %prep
25 %setup -q
26 cp %{SOURCE1} .
27
28 %build
29 for ASM in %{Assemblies}; do
30 %dotnet_build $ASM
31 %dotnet_pack $ASM/$ASM.nuspec %{version}
32 done
33
34 %install
35 for ASM in %{Assemblies}; do
36 %dotnet_install $ASM
37 done
38
39 %files
40 %manifest %{name}.manifest
41 %license LICENSE
42 %attr(644,root,root) %{dotnet_assembly_files}