manual nui merge 0.2.38
[platform/core/csapi/tizenfx.git] / packaging / csapi-nui.spec
1 Name:       csapi-nui
2 Summary:    dali-NUI
3 Version:    0.2.38
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0 and BSD-3-Clause and MIT
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 # C# API Requires
17
18 BuildRequires: csapi-tizen-nuget
19 BuildRequires: csapi-application-nuget
20
21 %define Assemblies Tizen.NUI
22
23 %description
24 %{summary}
25
26 %_nuget_package
27
28 %prep
29 %setup -q
30 cp %{SOURCE1} .
31
32 %build
33 for ASM in %{Assemblies}; do
34 %dotnet_build $ASM /p:DefineConstants="DOT_NET_CORE","DEBUG_ON"
35 %dotnet_pack $ASM/$ASM.nuspec %{version}
36 done
37
38
39 %install
40 for ASM in %{Assemblies}; do
41 %dotnet_install $ASM
42 done
43
44 %files
45 %manifest %{name}.manifest
46 %license LICENSE
47 %attr(644,root,root) %{dotnet_assembly_files}