1 %{!?dotnet_assembly_path: %define dotnet_assembly_path /opt/usr/share/dotnet.tizen/framework}
3 %if 0%{?tizen_build_devel_mode}
4 %define BUILDCONF Debug
6 %define BUILDCONF Release
10 Summary: Tizen Multimedia API for C#
13 Group: Development/Libraries
15 URL: https://www.tizen.org
16 Source0: %{name}-%{version}.tar.gz
17 Source1: %{name}.manifest
21 BuildRequires: mono-compiler
22 BuildRequires: mono-devel
24 BuildRequires: dotnet-build-tools
27 BuildRequires: csapi-tizen-nuget
28 BuildRequires: elm-sharp-nuget
31 Tizen Multimedia API for C#
37 %define Assemblies Tizen.Multimedia
40 for ASM in %{Assemblies}; do
42 find $ASM/*.project.json -exec nuget restore {} \;
44 find $ASM/*.csproj -exec xbuild {} /p:Configuration=%{BUILDCONF} \;
46 nuget pack $ASM/$ASM.nuspec -Version %{version} -Properties Configuration=%{BUILDCONF}
51 mkdir -p %{buildroot}%{dotnet_assembly_path}
52 for ASM in %{Assemblies}; do
54 install -p -m 644 $ASM/bin/%{BUILDCONF}/$ASM.dll %{buildroot}%{dotnet_assembly_path}
56 install -p -m 644 $ASM/bin/%{BUILDCONF}/Net45/$ASM.dll %{buildroot}%{dotnet_assembly_path}
60 mkdir -p %{buildroot}/nuget
61 install -p -m 644 *.nupkg %{buildroot}/nuget
64 %manifest %{name}.manifest
66 %attr(644,root,root) %{dotnet_assembly_path}/*.dll
69 Summary: NuGet package for %{name}
70 Group: Development/Libraries
73 NuGet package for %{name}