Add TizenManagedRef project
[platform/core/csapi/meta-package.git] / packaging / csapi-meta-package.spec
1 Name:       csapi-meta-package
2 Summary:    Meta Packages for Tizen .NET
3 Version:    3.0.0
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 %description
17 Meta Packages for Tizen .NET
18
19 %package -n tizen-managed-ref
20 Summary:    Reference assemblies of Tizen .NET
21 Group:      Development/Libraries
22 AutoReqProv: no
23
24 %description -n tizen-managed-ref
25 Reference assemblies of Tizen .NET
26
27 %dotnet_nuget_package
28
29 %prep
30 %setup -q
31 cp %{SOURCE1} .
32
33 %build
34 # Make Tizen.Library
35 %dotnet_pack Tizen.Library/Tizen.Library.nuspec
36
37 # Make Tizen.NET
38 %dotnet_pack Tizen.NET/Tizen.NET.nuspec
39
40 %install
41 mkdir -p %{buildroot}/nuget
42 mkdir -p %{buildroot}%{dotnet_assembly_path}/ref/
43
44 # Install Tizen.Library
45 %dotnet_install_nuget Tizen.Library
46
47 # Install Tizen.NET
48 %dotnet_install_nuget Tizen.NET
49
50 # Install reference assemblies
51 cp -f TizenManagedRef/Output/*.dll %{buildroot}%{dotnet_assembly_path}/ref/
52
53 %files -n tizen-managed-ref
54 %{dotnet_assembly_path}/ref/