Merge "[Attach-panel] Add comment" into tizen
[platform/core/csapi/attach-panel.git] / packaging / csapi-attach-panel.spec
1 Name:       csapi-attach-panel
2 Summary:    Tizen attach panel API for C#
3 Version:    1.0.1
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 # C# API Requires
17 BuildRequires: csapi-tizen-nuget
18 BuildRequires: csapi-application-common-nuget
19
20 %define Assemblies Tizen.Applications.AttachPanel
21
22 %description
23 %{summary}
24
25 %dotnet_import_sub_packages
26
27 %prep
28 %setup -q
29 cp %{SOURCE1} .
30
31 %build
32 for ASM in %{Assemblies}; do
33 %dotnet_build $ASM
34 %dotnet_pack $ASM
35 done
36
37 %install
38 for ASM in %{Assemblies}; do
39 %dotnet_install $ASM
40 done
41
42 %files
43 %manifest %{name}.manifest
44 %license LICENSE
45 %attr(644,root,root) %{dotnet_assembly_files}