Apply dotnet RPM macros
[platform/core/csapi/tizenfx.git] / packaging / csapi-account-oauth2.spec
1 Name:       csapi-account-oauth2
2 Summary:    OAuth2.0 C# API for Tizen
3 Version:    1.0.3
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 BuildRequires: dotnet-build-tools
12
13 # C# API Requires
14 BuildRequires: csapi-tizen-nuget
15
16 %define Assemblies Tizen.Account.OAuth2
17
18 %dotnet_import_common
19
20 %description
21 %{summary}
22
23 %dotnet_import_sub_packages
24
25 %prep
26 %setup -q
27 cp %{SOURCE1} .
28
29 %build
30 for ASM in %{Assemblies}; do
31 %dotnet_build $ASM
32 %dotnet_pack $ASM/$ASM.nuspec %{version}
33 done
34
35 %install
36 for ASM in %{Assemblies}; do
37 %dotnet_install $ASM
38 done
39
40 %files
41 %manifest %{name}.manifest
42 %license LICENSE
43 %attr(644,root,root) %{dotnet_assembly_files}