Merge branch 'upstream' into tizen
[platform/upstream/cryptsetup.git] / packaging / cryptsetup.spec
1 Name:     cryptsetup
2 Summary:  The cryptsetup
3 Version:  1.6.7
4 Release:  1
5 License:  GPL-2.0+, LGPL-2.1+
6 Group:    Base/Device Management
7 URL:      http://code.google.com/p/cryptsetup/
8 Source0:  %{name}-%{version}.tar.xz
9 Source1:  cryptsetup.manifest
10
11 BuildRequires: linux-kernel-headers
12 BuildRequires: device-mapper-devel
13 BuildRequires: libgpg-error-devel
14 BuildRequires: libgcrypt-devel
15 BuildRequires: libuuid-devel
16 BuildRequires: util-linux
17 BuildRequires: popt-devel
18 BuildRequires: automake
19 BuildRequires: gettext
20
21 Requires:      libgpg-error
22 Requires:      device-mapper
23 Requires:      libgcrypt
24
25 %description
26 setup cryptographic volumes for dm-crypt (including LUKS extension)
27
28 %package devel
29 Summary:    The cryptsetup development package
30 Group:      Development/Libraries
31 License:    GPL-2.0+, LGPL-2.1+
32 Requires:   %{name} = %{version}-%{release}
33
34 %description devel
35 cryptsetup development package
36
37 %package locale
38 License:    GPL-2.0+
39 Summary:    The cryptsetup locale package
40 Group:      Base/Device Management
41 Requires:   %{name} = %{version}-%{release}
42
43 %description locale
44 locale package for cryptsetup
45
46 %package doc 
47 License:    GPL-2.0+
48 Summary:    The cryptsetup doc package
49 Group:      Base/Device Management
50 Requires:   %{name} = %{version}-%{release}
51
52 %description doc
53 doc package for cryptsetup
54
55 %prep
56 %setup -q
57
58 %build
59 cp %{SOURCE1} .
60
61 chmod +x ./autogen.sh
62 ./autogen.sh --prefix=%{_prefix} -localedir=%{_datarootdir}/locale -libdir=%{_libdir}
63
64 make %{?jobs:-j%jobs}
65
66 %install
67 rm -rf %{buildroot}
68 %make_install
69
70 %clean
71
72 %post -p /sbin/ldconfig
73
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(-,root,root,-)
78 %manifest cryptsetup.manifest
79 %license COPYING.GPL-2.0+ COPYING.LGPL-2.1+
80 %{_libdir}/libcryptsetup.so
81 %{_libdir}/libcryptsetup.so.4
82 %{_libdir}/libcryptsetup.so.4.7.0
83 %{_sbindir}/cryptsetup
84 %{_sbindir}/veritysetup
85
86 %files devel
87 %license COPYING.GPL-2.0+ COPYING.LGPL-2.1+
88 %{_includedir}/libcryptsetup.h
89 %{_libdir}/libcryptsetup.so
90 %{_libdir}/pkgconfig/libcryptsetup.pc
91
92 %files locale
93 %license COPYING.GPL-2.0+
94 %{_datarootdir}/locale/cs/LC_MESSAGES/cryptsetup.mo
95 %{_datarootdir}/locale/de/LC_MESSAGES/cryptsetup.mo
96 %{_datarootdir}/locale/fi/LC_MESSAGES/cryptsetup.mo
97 %{_datarootdir}/locale/fr/LC_MESSAGES/cryptsetup.mo
98 %{_datarootdir}/locale/id/LC_MESSAGES/cryptsetup.mo
99 %{_datarootdir}/locale/it/LC_MESSAGES/cryptsetup.mo
100 %{_datarootdir}/locale/nl/LC_MESSAGES/cryptsetup.mo
101 %{_datarootdir}/locale/pl/LC_MESSAGES/cryptsetup.mo
102 %{_datarootdir}/locale/sv/LC_MESSAGES/cryptsetup.mo
103 %{_datarootdir}/locale/uk/LC_MESSAGES/cryptsetup.mo
104 %{_datarootdir}/locale/vi/LC_MESSAGES/cryptsetup.mo
105 %{_datarootdir}/locale/es/LC_MESSAGES/cryptsetup.mo
106
107 %files doc
108 %license COPYING.GPL-2.0+
109 %{_mandir}/man8/cryptsetup.8.gz
110 %{_mandir}/man8/veritysetup.8.gz