Updating spec files with new scripts
[platform/upstream/gcc49.git] / packaging / cross-armv7l-gcc49.spec
1 %define pkgname cross-armv7l-gcc49
2 %define cross_arch armv7l
3 %define gcc_target_arch armv7l-tizen-linux-gnueabi
4 %define gcc_icecream 1
5 #
6 # spec file for package gcc (Version 4.8.2)
7 #
8 # Copyright (c) 2005 SUSE Linux AG, Nuernberg, Germany.
9 # This file and all modifications and additions to the pristine
10 # package are under the same license as the package itself.
11 #
12 # Please submit bugfixes or comments via http://www.suse.de/feedback/
13 #
14
15 %define build_cp 1
16 %define build_ada 0
17 %define build_libjava 0
18 %define build_java 0
19
20 %define build_fortran 0
21 %define build_objc 0
22 %define build_objcp 0
23 %define build_go 0
24 %define gcc_target_arch armv7l-tizen-linux-gnueabi
25
26 %define binutils_target %{cross_arch}
27 %if %{cross_arch} == "armv7l" || %{cross_arch} == "armv7hl"
28 %define binutils_target arm
29 %endif
30 %if %{cross_arch} == "armv6l" || %{cross_arch} == "armv6hl"
31 %define binutils_target arm
32 %endif
33 %if %{cross_arch} == "armv5tel"
34 %define binutils_target arm
35 %endif
36 %define canonical_target %(echo %{binutils_target} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
37 %if %{binutils_target} == "arm"
38 %define canonical_target_abi -gnueabi
39 %endif
40
41 %if 0%{?gcc_icecream:1}
42 %define build_sysroot /
43 %endif
44
45
46 Name:         %{pkgname}
47 ExcludeArch:  %{cross_arch}
48 BuildRequires: cross-%{binutils_target}-binutils
49 BuildRequires: gcc-c++
50 BuildRequires: bison
51 BuildRequires: flex
52 BuildRequires: gettext-devel
53 BuildRequires: glibc-devel-32bit
54 BuildRequires: mpc-devel
55 BuildRequires: mpfr-devel
56 BuildRequires: perl
57 BuildRequires: makeinfo
58 BuildRequires: zlib-devel
59 %ifarch %ix86 x86_64 ppc ppc64 s390 s390x ia64 %sparc hppa %arm
60 BuildRequires: cloog-devel
61 BuildRequires: ppl-devel
62 %endif
63 %ifarch ia64
64 BuildRequires: libunwind-devel
65 %endif
66 %if 0%{!?gcc_icecream:1}
67 BuildRequires: cross-%cross_arch-glibc-devel
68 %endif
69
70 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
71
72 URL:          http://gcc.gnu.org/
73 Version: 4.9.1
74 Release:      1
75 %define gcc_dir_version 4.9
76 %define binsuffix -4.9
77 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
78 Source:         gcc-%{version}.tar.bz2
79 Source1:        change_spec
80 Source2:        libffi49-rpmlintrc
81 Source3:        gcc49-rpmlintrc
82 Source4:        ecj.jar
83 Source5:        baselibs.conf
84 Source6:        libgcj49-rpmlintrc
85
86 Group:          Development/Building
87 Summary:        The GNU C Compiler and Support Files
88 License:        GPL-3.0+
89
90 %description
91 Core package for the GNU Compiler Collection, including the C language
92 frontend.
93
94 Language frontends other than C are split to different sub-packages,
95 namely gcc-ada, gcc-c++, gcc-fortran, gcc-java, gcc-objc and
96 gcc-obj-c++.
97
98
99
100
101 # Define the canonical target and host architecture
102 #   %gcc_target_arch  is supposed to be the full target triple
103 #   %TARGET_ARCH      is the canonicalized CPU part
104 #   %CONFIGURE_TARGET is the target triple used for --target=
105 %if 0%{?gcc_target_arch:1}
106 %define CONFIGURE_TARGET %{gcc_target_arch}
107 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
108 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc"
109 %define CONFIGURE_TARGET powerpc64-tizen-linux
110 %endif
111 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "powerpc64"
112 %define CONFIGURE_TARGET powerpc64-tizen-linux
113 %endif
114 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
115 %define CONFIGURE_TARGET i586-tizen-linux
116 %endif
117 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "aarch64"
118 %define CONFIGURE_TARGET aarch64-tizen-linux
119 %endif
120 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
121 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
122 %endif
123 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
124 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
125 %endif
126 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5tel"
127 %define CONFIGURE_TARGET armv5tel-tizen-linux-gnueabi
128 %endif
129 %else
130 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
131 %endif
132 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
133
134 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
135 %ifarch ppc
136 %define GCCDIST powerpc64-tizen-linux
137 %else
138 %ifarch %sparc
139 %define GCCDIST sparc64-tizen-linux
140 %else
141 %ifarch %arm
142 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
143 %else
144 %define GCCDIST %{HOST_ARCH}-tizen-linux
145 %endif
146 %endif
147 %endif
148
149 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
150 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
151
152
153 %prep
154 %setup -q -n gcc-%{version}
155
156 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
157 # the libstdc++ abi testsuite baseline files accordingly
158 %ifarch ppc
159 if [ -d libstdc++-v3/config/abi/post/powerpc64-linux-gnu ]; then
160   mkdir -p libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64
161   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/baseline_symbols.txt \
162         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/64/
163   mv libstdc++-v3/config/abi/post/powerpc64-linux-gnu/32/baseline_symbols.txt \
164         libstdc++-v3/config/abi/post/powerpc64-linux-gnu/
165 fi
166 %endif
167
168 %build
169 # Avoid rebuilding of generated files
170 contrib/gcc_update --touch
171 # Avoid fucking up testsuite results with Java and indirect dispatch
172 export LD_AS_NEEDED=0
173 # Split version file into version used for directories (X.Y) and
174 # version to report with --version (X.Y.Z).
175 # See also gcc-dir-version.patch.
176 # Also decrement the patchlevel version by one if possible and remove
177 # the 'prerelease' tagging in this case
178 if test `cat gcc/DEV-PHASE` == "prerelease"; then
179   if test `cat gcc/BASE-VER | cut -d '.' -f 3` != "0"; then
180     : > gcc/DEV-PHASE
181   fi
182   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
183 else
184   mv gcc/BASE-VER gcc/FULL-VER
185 fi
186 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
187
188 rm -rf obj-%{GCCDIST}
189 mkdir obj-%{GCCDIST}
190 cd obj-%{GCCDIST}
191 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g' -e 's/-fexceptions//' -e 's/\([[:space:]]\+.*-D_FORTIFY_SOURCE=\)[[:alnum:]]\+/\10/g'
192 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D__USE_FORTIFY_LEVEL=0"`
193 %ifarch %ix86
194 # -mcpu is superceded by -mtune but -mtune is not supported by
195 # our bootstrap compiler.  -mcpu gives a warning that stops
196 # the build process, so remove it for now.  Also remove all other
197 # -march and -mtune flags.  They are superseeded by proper
198 # default compiler settings now.
199 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
200 %endif
201 %ifarch s390 s390x
202 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fsigned-char//g'`
203 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-O1/-O2/g'`
204 %endif
205 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
206 # Kill all -march/tune/cpu because that screws building the target libs
207 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
208 %endif
209 # Replace 2 spaces by one finally
210 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
211
212 languages=c
213 %if %{build_cp}
214 languages=$languages,c++
215 %endif
216 %if %{build_objc}
217 languages=$languages,objc
218 %endif
219 %if %{build_fortran}
220 languages=$languages,fortran
221 %endif
222 %if %{build_objcp}
223 languages=$languages,obj-c++
224 %endif
225 %if %{build_java}
226 languages=$languages,java
227 %endif
228 %if %{build_ada}
229 languages=$languages,ada
230 %endif
231 %if %{build_go}
232 languages=$languages,go
233 %endif
234
235 J=%{?jobs:%jobs}
236 if test -z "$J"; then
237   J=$(getconf _NPROCESSORS_CONF)
238   JL=$(($J * 2))
239 else
240   test 1 -gt "$J" && J=1
241   JL=$(($(getconf _NPROCESSORS_CONF)*2))
242 fi
243 if test "$J" == "0"; then
244   J=1
245 fi
246 if test "$JL" == "0"; then
247   JL=1
248 fi
249 PARALLEL="-j$J -l$JL"
250
251 # we don't want some miscompiles in the testsuite, or some fault in
252 # the compiler to kill the machine.  Hence we limit the amount of memory
253 # by the physical RAM plus half of swap
254 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
255 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
256 #ulimit -v $(((MEM + SWAP/2)*1024))
257
258 # In general we want to ship release checking enabled compilers
259 # and run BETA with checking enabled.
260 #ENABLE_CHECKING="--enable-checking=yes"
261 ENABLE_CHECKING="--enable-checking=release"
262
263 # Work around tail/head -1 changes
264 export _POSIX2_VERSION=199209
265
266 %if %{build_ada}
267 # Using the host gnatmake like
268 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
269 #   GNATMAKE="gnatmake%{hostsuffix}"
270 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
271 # available
272 mkdir -p host-tools/bin
273 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
274 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
275 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
276 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
277 ln -sf /usr/%{_lib} host-tools/%{_lib}
278 export PATH="`pwd`/host-tools/bin:$PATH"
279 %endif
280 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
281 #%else
282 #       --enable-threads=posix \
283 #%endif
284 #       --enable-shared \
285 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
286 # temporary workaround for a miscompilation of hash functions in java code
287 GCJ_EXTRA_FLAGS="-marm"
288 %endif
289
290 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
291 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
292 ../configure \
293         --prefix=%{_prefix} \
294         --infodir=%{_infodir} \
295         --mandir=%{_mandir} \
296         --libdir=%{_libdir} \
297         --libexecdir=%{_libdir} \
298         --enable-languages=$languages \
299         $ENABLE_CHECKING \
300         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
301         --enable-ssp \
302         --disable-libssp \
303         --disable-bootstrap \
304 %if 0%{!?build_libvtv:1}
305         --disable-libvtv \
306 %endif
307         --disable-plugin \
308         --with-bugurl="http://bugs.tizen.org/" \
309         --with-pkgversion="Tizen" \
310 %if !%{build_fortran}
311         --disable-libquadmath \
312 %endif
313 %if !%{build_libjava}
314         --disable-libgcj \
315 %else
316         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
317         --with-ecj-jar=%{libsubdir}/ecj.jar \
318         --disable-java-awt \
319 %if !%{biarch_libjava}
320         --disable-libjava-multilib \
321 %endif
322 %endif
323         --with-slibdir=/%{_lib} \
324         --with-system-zlib \
325         --enable-__cxa_atexit \
326         --enable-libstdcxx-allocator=new \
327         --disable-libstdcxx-pch \
328         --enable-version-specific-runtime-libs \
329         --enable-linker-build-id \
330         --enable-linux-futex \
331         --program-suffix=%{binsuffix} \
332 %if 0%{!?gcc_target_arch:1}
333 %ifarch ia64
334         --with-system-libunwind \
335 %else
336         --without-system-libunwind \
337 %endif
338 %endif
339 %if 0%{?gcc_target_arch:1}
340         --program-prefix=%{gcc_target_arch}- \
341         --target=%{gcc_target_arch} \
342         --disable-nls \
343 %if 0%{?sysroot:1}
344         --with-sysroot=%sysroot \
345 %else
346         --with-sysroot=%{_prefix}/%{gcc_target_arch} \
347 %endif
348 %if 0%{?build_sysroot:1}
349         --with-build-sysroot=%{build_sysroot} \
350 %else
351 %if 0%{?sysroot:1}
352         --with-build-sysroot=%{sysroot} \
353 %else
354         --with-build-sysroot=%{_prefix}/%{gcc_target_arch} \
355 %endif
356 %endif
357 %if 0%{?canonical_target:1}
358         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
359 %endif
360 %if "%{TARGET_ARCH}" == "spu"
361         --with-gxx-include-dir=%sysroot/include/c++/%{gcc_dir_version} \
362         --with-newlib \
363 %endif
364 %endif
365 %if "%{TARGET_ARCH}" == "armv5tel"
366         --with-arch=armv5te \
367         --with-float=soft \
368         --with-mode=arm \
369         --with-abi=aapcs-linux \
370         --disable-sjlj-exceptions \
371 %endif
372 %if "%{TARGET_ARCH}" == "armv7l"
373         --with-arch=armv7-a \
374         --with-tune=cortex-a8 \
375         --with-float=softfp \
376         --with-fpu=vfpv3 \
377         --with-mode=thumb \
378         --disable-sjlj-exceptions \
379 %endif
380 %if "%{TARGET_ARCH}" == "armv7hl"
381         --with-arch=armv7-a \
382         --with-tune=cortex-a9 \
383         --with-float=hard \
384         --with-abi=aapcs-linux \
385         --with-fpu=vfpv3-d16 \
386         --disable-sjlj-exceptions \
387 %endif
388 %if  "%{TARGET_ARCH}" == "aarch64"
389         --with-arch=armv8-a \
390         --disable-sjlj-exceptions \
391 %endif
392 %if "%{TARGET_ARCH}" == "powerpc" || "%{TARGET_ARCH}" == "powerpc64"
393 %if "%{TARGET_ARCH}" == "powerpc"
394         --with-cpu=default32 \
395 %endif
396 %if "%{TARGET_ARCH}" == "powerpc64le"
397         --with-cpu=power7 \
398 %else
399         --with-cpu-64=power4 \
400 %endif
401         --enable-secureplt \
402         --with-long-double-128 \
403 %if "%{TARGET_ARCH}" == "powerpc64le"
404         --disable-multilib \
405 %endif
406 %endif
407 %if "%{TARGET_ARCH}" == "sparc64"
408         --with-cpu=ultrasparc \
409         --with-long-double-128 \
410 %endif
411 %if "%{TARGET_ARCH}" == "sparc"
412         --with-cpu=v8 \
413         --with-long-double-128 \
414 %endif
415 %if "%{TARGET_ARCH}" == "i586"
416         --with-arch-32=i586 \
417         --with-tune=generic \
418 %endif
419 %if "%{TARGET_ARCH}" == "x86_64"
420         --with-arch-32=i586 \
421         --with-tune=generic \
422         --enable-multilib \
423 %endif
424 %if "%{TARGET_ARCH}" == "s390"
425         --with-tune=zEC12 --with-arch=z196 \
426         --with-long-double-128 \
427         --enable-decimal-float \
428 %endif
429 %if "%{TARGET_ARCH}" == "s390x"
430         --with-tune=zEC12 --with-arch=z196 \
431         --with-long-double-128 \
432         --enable-decimal-float \
433 %endif
434 %if "%{TARGET_ARCH}" == "m68k"
435         --disable-multilib \
436 %endif
437         --build=%{GCCDIST} \
438         --host=%{GCCDIST}
439
440
441 %if 0%{!?gcc_icecream:1}
442 make %{?jobs:-j%jobs}
443 %else
444 make %{?jobs:-j%jobs} all-host
445 %endif
446
447 %package -n cross-%cross_arch-gcc49-icecream-backend
448 Summary: Icecream backend for the GNU C Compiler
449 Group:  Development/Languages/C and C++
450
451 %description -n cross-%cross_arch-gcc49-icecream-backend
452 This package contains the icecream environment for the GNU C Compiler
453
454
455 %define targetlibsubdir %{_libdir}/gcc/%{gcc_target_arch}/%{gcc_dir_version}
456
457 %install
458 cd obj-%{GCCDIST}
459
460 # install and fixup host parts
461 make DESTDIR=$RPM_BUILD_ROOT install-host
462 # with the present setup fixincludes are for the build includes which
463 # is wrong - get rid of them
464 rm -rf $RPM_BUILD_ROOT/%{targetlibsubdir}/include-fixed
465 rm -f $RPM_BUILD_ROOT/%{targetlibsubdir}/liblto_plugin.la
466 # common fixup
467 rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
468
469 # remove docs and disable automated generation
470 %remove_docs
471 %define disable_docs_package 1
472
473 # install and fixup target parts
474 # ???  don't do this - debugedit is not prepared for this and crashes
475 # so expect the sysroot to be populated from natively built binaries
476 #%if 0%{?sysroot:1}
477 #make DESTDIR=$RPM_BUILD_ROOT/%{sysroot} install-target
478 #%else
479 #make DESTDIR=$RPM_BUILD_ROOT/%{_prefix}/%{gcc_target_arch} install-target
480 #%endif
481
482
483 # Build an icecream environment
484 # The assembler comes from the cross-binutils, and hence is _not_
485 # named funnily, not even on ppc, so there we need the original target
486 install -s -D %{_prefix}/bin/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}-as   $RPM_BUILD_ROOT/env/usr/bin/as
487 install -s $RPM_BUILD_ROOT/%{_prefix}/bin/%{gcc_target_arch}-g++%{binsuffix}    $RPM_BUILD_ROOT/env/usr/bin/g++
488 install -s $RPM_BUILD_ROOT/%{_prefix}/bin/%{gcc_target_arch}-gcc%{binsuffix}    $RPM_BUILD_ROOT/env/usr/bin/gcc
489
490 for back in cc1 cc1plus; do
491         install -s -D $RPM_BUILD_ROOT/%{targetlibsubdir}/$back          $RPM_BUILD_ROOT/env%{targetlibsubdir}/$back
492 done
493 if test -f $RPM_BUILD_ROOT/%{targetlibsubdir}/liblto_plugin.so; then
494   install -s -D $RPM_BUILD_ROOT/%{targetlibsubdir}/liblto_plugin.so             $RPM_BUILD_ROOT/env%{targetlibsubdir}/liblto_plugin.so
495 fi
496
497 # Make sure to also pull in all shared library requirements for the
498 # binaries we put into the environment which is operated by chrooting
499 # into it and execing the compiler
500 libs=`for bin in $RPM_BUILD_ROOT/env/usr/bin/* $RPM_BUILD_ROOT/env%{targetlibsubdir}/*; do   ldd $bin | sed -n '\,^[^/]*\(/[^ ]*\).*,{ s//\1/; p; }'  ;done | sort -u`
501 for lib in $libs; do
502   # Check wether the same library also exists in the parent directory,
503   # and prefer that on the assumption that it is a more generic one.
504   baselib=`echo "$lib" | sed 's,/[^/]*\(/[^/]*\)$,\1,'`
505   test -f "$baselib" && lib=$baselib
506   install -s -D $lib $RPM_BUILD_ROOT/env$lib
507 done
508
509 cd $RPM_BUILD_ROOT/env
510 %if 0%{?gcc_icecream:1}
511 tar cvzf ../%{name}-icecream-backend_%{_arch}.tar.gz *
512 %else
513 tar cvzf ../%{name}_%{_arch}.tar.gz *
514 %endif
515 cd ..
516 mkdir -p usr/share/icecream-envs
517 %if 0%{?gcc_icecream:1}
518 mv %{name}-icecream-backend_%{_arch}.tar.gz usr/share/icecream-envs
519 %else
520 mv %{name}_%{_arch}.tar.gz usr/share/icecream-envs
521 %endif
522 rpm -q --changelog glibc >  usr/share/icecream-envs/%{name}_%{_arch}.glibc
523 rpm -q --changelog binutils >  usr/share/icecream-envs/%{name}_%{_arch}.binutils
524 rm -r env
525
526 %files
527 %defattr(-,root,root)
528 %{_prefix}/bin
529 %dir %{targetlibsubdir}
530 %dir %{_libdir}/gcc/%{gcc_target_arch}
531 %{targetlibsubdir}
532
533 %files -n cross-%cross_arch-gcc49-icecream-backend
534 %defattr(-,root,root)
535 /usr/share/icecream-envs
536