3fea883a4338e2de6a9110ea1ac3b48cb37ab6c0
[platform/core/system/crash-worker.git] / packaging / crash-worker_system-tests.spec
1 %global __debug_package 1
2 # because of this is debug package, there are source files (kenny.cpp and
3 # btee.c) that will be copied to the destination directory, but we don't want
4 # them in the rpm package so this flag is to avoid RPM build error:
5 %define _unpackaged_files_terminate_build 0
6 %define _with_livedumper on
7 %bcond_with livedumper
8
9 Name:          crash-worker_system-tests
10 Summary:       Package with binaries and scripts for crash-worker system tests
11 Version:       5.5.21
12 Release:       1
13 Group:         Framework/system
14 License:       Apache-2.0 and BSD
15 Source0:       %{name}-%{version}.tar.gz
16 Source1001:    crash-worker_system-tests.manifest
17 BuildRequires: pkgconfig(glib-2.0)
18 BuildRequires: pkgconfig(rpm)
19 BuildRequires: cmake
20
21 Requires:      diff
22 Requires:      gdb
23 Requires:      coreutils
24 Requires:      tlm
25 Requires:      /bin/bash
26 Requires:      /usr/bin/unzip
27 Requires:      /usr/bin/mcookie
28 Requires:      crash-worker
29 Requires:      %{_sbindir}/minicoredumper
30
31 %description
32 This package contains installable tests in Bash.
33
34 %prep
35 %setup -q
36
37
38 %build
39 cp %{SOURCE1001} .
40
41 export CFLAGS+=" -Werror"
42
43 cd tests/system
44 %cmake . -DCRASH_SYSTEM_TESTS_PATH=%{_libdir}/crash-worker_system-tests
45
46 make %{?jobs:-j%jobs}
47
48 %install
49 rm -rf %{buildroot}
50 cd tests/system
51 %make_install
52
53 %files -f debugfiles.list
54 %manifest %{name}.manifest
55 %defattr(0750,system_fw,system_fw)
56 %{_libdir}/crash-worker_system-tests/check_minicore_mem/check_minicore_mem.sh
57 %{_libdir}/crash-worker_system-tests/check_minicore_mem/cp.sh
58 %{_libdir}/crash-worker_system-tests/cmp_backtraces/cmp_backtraces.sh
59 %{_libdir}/crash-worker_system-tests/cmp_backtraces/cp.sh
60 %{_libdir}/crash-worker_system-tests/crash_root_path/crash_root_path.sh
61 %{_libdir}/crash-worker_system-tests/critical_process/critical_process.sh
62 %{_libdir}/crash-worker_system-tests/dbus_notify/dbus_notify.sh
63 %{_libdir}/crash-worker_system-tests/dump_systemstate_extras/dump_systemstate_extras.sh
64 %{_libdir}/crash-worker_system-tests/extra_script/extra_script.sh
65 %{_libdir}/crash-worker_system-tests/info_file/info_file.sh
66 %{_libdir}/crash-worker_system-tests/log_dump_crash_root_path/log_dump_crash_root_path.sh
67 %{_libdir}/crash-worker_system-tests/log_dump_normal/log_dump_normal.sh
68 %{_libdir}/crash-worker_system-tests/log_dump_short/log_dump_short.sh
69 %{_libdir}/crash-worker_system-tests/log_file/log_file.sh
70 %{_libdir}/crash-worker_system-tests/report_basic/report_basic.sh
71 %{_libdir}/crash-worker_system-tests/report_type_info/report_type_info.sh
72 %{_libdir}/crash-worker_system-tests/run.sh
73 %{_libdir}/crash-worker_system-tests/so_info_file/so_info_file.sh
74 %{_libdir}/crash-worker_system-tests/time_test/cp.sh
75 %{_libdir}/crash-worker_system-tests/time_test/time_test.sh
76 %{_libdir}/crash-worker_system-tests/utils/btee
77 %{_libdir}/crash-worker_system-tests/utils/kenny
78 %{_libdir}/crash-worker_system-tests/utils/minicore-utils.sh
79 %{_libdir}/crash-worker_system-tests/wait_for_opt_usr/wait_for_opt_usr.sh
80 %{_libdir}/crash-worker_system-tests/without_core/without_core.sh
81 %{_libdir}/crash-worker_system-tests/output_param/output_param.sh
82 %if %{with livedumper}
83 %{_libdir}/crash-worker_system-tests/livedumper/livedumper.sh
84 %endif
85 %defattr(-,root,root)
86
87 # %post
88 # /usr/bin/chsmack -a "_" -e "SSSystem::Privileged" -r %{_libdir}/crash-worker_system-tests/
89