Add crash manager API
[platform/core/system/crash-worker.git] / packaging / crash-worker_system-tests.spec
1 %global __debug_package 1
2 # because of this is debug package, there are source files (kenny.cpp and
3 # btee.c) that will be copied to the destination directory, but we don't want
4 # them in the rpm package so this flag is to avoid RPM build error:
5 %define _unpackaged_files_terminate_build 0
6 %define _with_livedumper on
7 %bcond_with livedumper
8
9 Name:          crash-worker_system-tests
10 Summary:       Package with binaries and scripts for crash-worker system tests
11 Version:       5.5.21
12 Release:       1
13 Group:         Framework/system
14 License:       Apache-2.0 and BSD
15 Source0:       %{name}-%{version}.tar.gz
16 Source1001:    crash-worker_system-tests.manifest
17 BuildRequires: pkgconfig(glib-2.0)
18 BuildRequires: pkgconfig(rpm)
19 BuildRequires: pkgconfig(dlog)
20 BuildRequires: pkgconfig(glib-2.0)
21 BuildRequires: pkgconfig(crash-service)
22 BuildRequires: cmake
23
24 Requires:      diff
25 Requires:      gdb
26 Requires:      coreutils
27 Requires:      tlm
28 Requires:      /bin/bash
29 Requires:      /usr/bin/unzip
30 Requires:      /usr/bin/mcookie
31 Requires:      crash-worker
32 Requires:      %{_sbindir}/minicoredumper
33
34 %description
35 This package contains installable tests in Bash.
36
37 %prep
38 %setup -q
39
40
41 %build
42 cp %{SOURCE1001} .
43
44 export CFLAGS+=" -Werror"
45
46 cd tests/system
47 %cmake . -DCRASH_SYSTEM_TESTS_PATH=%{_libdir}/crash-worker_system-tests
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 cd tests/system
54 %make_install
55
56 %files -f debugfiles.list
57 %manifest %{name}.manifest
58 %defattr(0750,system_fw,system_fw)
59 %{_libdir}/crash-worker_system-tests/check_minicore_mem/check_minicore_mem.sh
60 %{_libdir}/crash-worker_system-tests/check_minicore_mem/cp.sh
61 %{_libdir}/crash-worker_system-tests/cmp_backtraces/cmp_backtraces.sh
62 %{_libdir}/crash-worker_system-tests/cmp_backtraces/cp.sh
63 %{_libdir}/crash-worker_system-tests/crash_root_path/crash_root_path.sh
64 %{_libdir}/crash-worker_system-tests/critical_process/critical_process.sh
65 %{_libdir}/crash-worker_system-tests/dbus_notify/dbus_notify.sh
66 %{_libdir}/crash-worker_system-tests/dump_systemstate_extras/dump_systemstate_extras.sh
67 %{_libdir}/crash-worker_system-tests/extra_script/extra_script.sh
68 %{_libdir}/crash-worker_system-tests/info_file/info_file.sh
69 %{_libdir}/crash-worker_system-tests/log_dump_crash_root_path/log_dump_crash_root_path.sh
70 %{_libdir}/crash-worker_system-tests/log_dump_normal/log_dump_normal.sh
71 %{_libdir}/crash-worker_system-tests/log_dump_short/log_dump_short.sh
72 %{_libdir}/crash-worker_system-tests/log_file/log_file.sh
73 %{_libdir}/crash-worker_system-tests/report_basic/report_basic.sh
74 %{_libdir}/crash-worker_system-tests/report_type_info/report_type_info.sh
75 %{_libdir}/crash-worker_system-tests/run.sh
76 %{_libdir}/crash-worker_system-tests/so_info_file/so_info_file.sh
77 %{_libdir}/crash-worker_system-tests/time_test/cp.sh
78 %{_libdir}/crash-worker_system-tests/time_test/time_test.sh
79 %{_libdir}/crash-worker_system-tests/utils/btee
80 %{_libdir}/crash-worker_system-tests/utils/kenny
81 %{_libdir}/crash-worker_system-tests/utils/libcrash-servicetest
82 %{_libdir}/crash-worker_system-tests/utils/minicore-utils.sh
83 %{_libdir}/crash-worker_system-tests/wait_for_opt_usr/wait_for_opt_usr.sh
84 %{_libdir}/crash-worker_system-tests/without_core/without_core.sh
85 %{_libdir}/crash-worker_system-tests/output_param/output_param.sh
86 %{_libdir}/crash-worker_system-tests/libcrash-service/libcrash-service.sh
87 %if %{with livedumper}
88 %{_libdir}/crash-worker_system-tests/livedumper/livedumper.sh
89 %endif
90 %defattr(-,root,root)
91
92 # %post
93 # /usr/bin/chsmack -a "_" -e "SSSystem::Privileged" -r %{_libdir}/crash-worker_system-tests/
94