41ed29b375fdd5f02c92611e76624d53209f30fa
[profile/ivi/connman-qt.git] / packaging / connman-qt.spec
1 %define buildwayland 0 
2 %if %{buildwayland}
3 %define backend -wayland
4 %else
5 %define backend -xlib
6 %endif
7
8 Name:       connman-qt%{backend}
9 Summary:    qt bindings for connman
10 Version:    0.1.4
11 Release:    1
12 Group:      System/GUI/Other
13 License:    Apache License
14 URL:        http://www.meego.com
15 Source0:    connman-qt-%{version}.tar.bz2
16 Requires:   connman-qt%{backend}-declarative
17 Requires(post): /sbin/ldconfig
18 Requires(postun): /sbin/ldconfig
19 BuildRequires:  pkgconfig(QtCore%{backend})
20 BuildRequires:  pkgconfig(QtDBus%{backend})
21 BuildRequires:  pkgconfig(QtOpenGL%{backend})
22 BuildRequires:  pkgconfig(QtGui%{backend})
23 BuildRequires:  pkgconfig(dbus-1)
24 BuildRequires:  doxygen
25
26 %description
27 This is a library for working with connman using Qt
28
29
30
31 %package tests
32 Summary:    tests for connman-qt
33 Group:      Development/Libraries
34 Requires:   %{name} = %{version}-%{release}
35 Requires:   connman-qt%{backend}-declarative
36
37 %description tests
38 This package contains the test applications for testing libconnman-qt
39
40
41 %package declarative
42 Summary:    Declarative plugin for Qt Quick for connman-qt
43 Group:      Development/Libraries
44 Requires:   %{name} = %{version}-%{release}
45 Requires:   connman-qt%{backend}
46
47 %description declarative
48 This package contains the files necessary to develop
49 applications using libconnman-qt
50
51
52 %package devel
53 Summary:    Development files for connman-qt
54 Group:      Development/Libraries
55 Requires:   %{name} = %{version}-%{release}
56
57 %description devel
58 This package contains the files necessary to develop
59 applications using libconnman-qt
60
61
62
63 %prep
64 %setup -q -n connman-qt-%{version}
65
66 # >> setup
67 # << setup
68
69 %build
70 # >> build pre
71 export PATH=$PATH:/usr/lib/qt4/bin
72 qmake install_prefix=/usr
73 # << build pre
74
75 %qmake 
76
77 make %{?jobs:-j%jobs}
78
79 # >> build post
80 # << build post
81 %install
82 rm -rf %{buildroot}
83 # >> install pre
84 export INSTALL_ROOT=%{buildroot}
85 # << install pre
86 %qmake_install
87
88 # >> install post
89 # << install post
90
91
92
93 %post -p /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97
98
99
100
101
102
103
104
105
106
107 %files
108 %defattr(-,root,root,-)
109 %{_libdir}/libconnman-qt4.so.*
110 # >> files
111 # << files
112
113
114 %files tests
115 %defattr(-,root,root,-)
116 %{_usr}/lib/libconnman-qt4/test
117 # >> files tests
118 # << files tests
119
120 %files declarative
121 %defattr(-,root,root,-)
122 %{_usr}/lib/qt4/imports/Connman/Qt
123 # >> files declarative
124 # << files declarative
125
126 %files devel
127 %defattr(-,root,root,-)
128 %{_usr}/include/connman-qt
129 %{_usr}/lib/pkgconfig/connman-qt4.pc
130 %{_usr}/lib/connman-qt4.pc
131 %{_usr}/lib/libconnman-qt4.prl
132 %{_usr}/lib/libconnman-qt4.so
133 # >> files devel
134 # << files devel
135