CHIP Test: Pack basic test tools into test RPM
[platform/upstream/connectedhomeip.git] / packaging / connectedhomeip.spec
1 Name:       connectedhomeip
2 Summary:    Project Connected Home over IP
3 Version:    0.0.1
4 Release:    1
5 Group:      Network & Connectivity/Other
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    %{name}.manifest
9
10 BuildRequires: pkgconfig(dbus-1)
11 BuildRequires: pkgconfig(gio-2.0)
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(gio-unix-2.0)
14 BuildRequires: pkgconfig(avahi-client)
15
16 BuildRequires: python3
17 BuildRequires: gn
18 BuildRequires: ninja
19 Requires(post): /sbin/ldconfig
20 Requires(postun): /sbin/ldconfig
21
22 %description
23 Project Connected Home over IP is a new Working Group within the Zigbee Alliance.
24 This Working Group plans to develop and promote the adoption of a new, royalty-free
25 connectivity standard to increase compatibility among smart home products, with security as a fundamental design tenet
26
27 %prep
28 %setup -q
29 chmod 644 %{SOURCE0}
30 cp %{SOURCE1} ./%{name}.manifest
31
32 %build
33 gn gen out/host --args='is_debug=true target_os="linux" current_cpu="arm"'
34 ninja -C out/host
35
36 %install
37 # ninja install
38 mkdir -p %{buildroot}%{_bindir}
39
40 cp out/host/chip-tool %{buildroot}%{_bindir}/
41 cp out/host/chip-lighting-app %{buildroot}%{_bindir}/
42 cp out/host/chip-all-clusters-app %{buildroot}%{_bindir}/
43 cp out/host/chip-shell %{buildroot}%{_bindir}/
44 cp out/host/minimal-mdns-client %{buildroot}%{_bindir}/
45 cp out/host/minimal-mdns-server %{buildroot}%{_bindir}/
46
47 %post
48
49 %files
50 %manifest %{name}.manifest
51 %license LICENSE
52
53 %package test
54 Summary: Connected Home over IP Test applications
55 Requires: %{name} = %{version}-%{release}
56
57 %description test
58 This package is for CHIP test applications
59
60 %files test
61 %manifest %{name}.manifest
62 %{_bindir}/chip-tool
63 %{_bindir}/chip-lighting-app
64 %{_bindir}/chip-all-clusters-app
65 %{_bindir}/chip-shell
66 %{_bindir}/minimal-mdns-client
67 %{_bindir}/minimal-mdns-server