cleanup specfile for packaging
[profile/ivi/cogl.git] / packaging / cogl.spec
1 Name:       cogl
2 Summary:    Open Source 3D graphics library for creating rich graphical applications
3 Version:    1.10.2
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.clutter-project.org/
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1:    http://source.clutter-project.org/sources/cogl/1.10/cogl-%{version}.sha256sum
10 Patch0: gl-header-include-fix.patch
11 Requires(post): /sbin/ldconfig
12 Requires(postun): /sbin/ldconfig
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(pango)
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(xcomposite)
17 BuildRequires:  pkgconfig(xdamage)
18 BuildRequires:  pkgconfig(xext)
19 BuildRequires:  pkgconfig(xfixes)
20 BuildRequires:  pkgconfig(glesv2)
21 BuildRequires:  pkgconfig(glesv1_cm)
22 BuildRequires:  pkgconfig(gl)
23 BuildRequires:  pkgconfig(egl)
24 BuildRequires:  pkgconfig(gdk-pixbuf-2.0)
25 BuildRequires:  pkgconfig(libdrm)
26 BuildRequires:  pkgconfig(dri2proto)
27 BuildRequires:  pkgconfig(glproto)
28 BuildRequires:  pkgconfig(xxf86vm)
29 BuildRequires:  pkgconfig(wayland-client)
30 BuildRequires:  pkgconfig(wayland-egl)
31 BuildRequires:  intltool
32
33
34 %description
35 Cogl is a modern 3D graphics library that avoids the flat state-machine API style of OpenGL making it easier to write orthogonal rendering code. Cogl supports using OpenGL and OpenGLES 1.1/2.0 as backends so a wide range of devices can be targetted. Also because Cogl can integrate the huge number of vendor specific OpenGL extensions behind a consistent interface it helps you get the very best out of your specific device for less effort than using OpenGL.
36
37
38
39 %package devel
40 Summary:    Cogl header files and development libraries
41 Group:      Development/Libraries
42 Requires:   %{name} = %{version}-%{release}
43
44 %description devel
45 Development environment for Cogl
46
47 %package examples
48 Summary:    Cogl examples
49 Group:      Amusements/Graphics
50 Requires:   %{name} = %{version}-%{release}
51
52 %description examples
53 Example Cogl apps
54
55
56 %prep
57 %setup -q -n %{name}-%{version}
58 %patch0 -p1
59
60 %build
61
62 %configure --disable-static \
63     --enable-gl \
64     --enable-gles1 \
65     --enable-gles2 \
66     --enable-wayland-egl-platform=yes \
67     --enable-xlib-egl-platform=yes \
68     --enable-examples-install
69
70 make %{?jobs:-j%jobs}
71
72 %install
73 rm -rf %{buildroot}
74 %make_install
75
76 %find_lang cogl
77
78
79 %post -p /sbin/ldconfig
80
81 %postun -p /sbin/ldconfig
82
83
84
85
86 %files -f cogl.lang
87 %defattr(-,root,root,-)
88 %doc COPYING README
89 %{_libdir}/*.so.*
90
91 %files devel
92 %defattr(-,root,root,-)
93 %{_includedir}/*
94 %{_libdir}/*.so
95 %{_libdir}/pkgconfig/*
96
97 %files examples
98 %defattr(-,root,root,-)
99 %{_datadir}/cogl/*
100 %{_bindir}/*
101