cleanup specfile for packaging
[profile/ivi/clutter.git] / packaging / clutter.spec
1 Name:       clutter
2 Summary:    Open Source software library for creating rich graphical user interfaces
3 Version:    1.10.0
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2+
7 URL:        http://www.clutter-project.org/
8 Source0:    %{name}-%{version}.tar.bz2
9 Source1:    http://source.clutter-project.org/sources/clutter/1.10/clutter-%{version}.sha256sum
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(json-glib-1.0) >= 0.12.0
14 BuildRequires:  pkgconfig(pango)
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(xcomposite)
17 BuildRequires:  pkgconfig(xdamage)
18 BuildRequires:  pkgconfig(xext)
19 BuildRequires:  pkgconfig(xfixes)
20 BuildRequires:  pkgconfig(gl)
21 BuildRequires:  pkgconfig(glesv2)
22 BuildRequires:  pkgconfig(gdk-pixbuf-2.0)
23 BuildRequires:  pkgconfig(atk) >= 2.1.5
24 BuildRequires:  pkgconfig(cogl-1.0) >= 1.9.6
25 BuildRequires:  pkgconfig(wayland-client)
26 BuildRequires:  pkgconfig(xkbcommon)
27 BuildRequires:  intltool
28 BuildRequires:  gettext
29
30 %description
31 Clutter is an open source software library for creating fast, visually rich graphical user interfaces. The most obvious example of potential usage is in media center type applications. We hope however it can be used for a lot more.
32
33
34
35 %package devel
36 Summary:    Clutter header files and development libraries
37 Group:      Development/Libraries
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 Development environment for Clutter
42
43 %package doc
44 Summary:    Clutter API reference
45 Group:      Development/Libraries
46 Requires:   %{name} = %{version}-%{release}
47 Requires:   gtk-doc
48
49 %description doc
50 Documentation for Clutter
51
52
53 %prep
54 %setup -q -n %{name}-%{version}
55
56 %build
57
58 %configure --disable-static \
59     --disable-maintainer-flags \
60     --enable-xinput \
61     --enable-wayland-backend \
62     --enable-introspection=no
63
64 make %{?jobs:-j%jobs}
65
66 %install
67 rm -rf %{buildroot}
68 %make_install
69
70 %find_lang clutter-1.0
71
72
73
74 %post -p /sbin/ldconfig
75
76 %postun -p /sbin/ldconfig
77
78
79
80
81
82
83
84
85 %files -f clutter-1.0.lang
86 %defattr(-,root,root,-)
87 %doc COPYING
88 %{_libdir}/lib*.so.*
89
90
91
92 %files devel
93 %defattr(-,root,root,-)
94 %doc ChangeLog NEWS README
95 %{_includedir}/*
96 %{_libdir}/lib*.so
97 %{_libdir}/pkgconfig/*.pc
98
99
100 %files doc
101 %defattr(-,root,root,-)
102 %doc %{_datadir}/gtk-doc/html/*
103