resetting manifest requested domain to floor
[platform/upstream/cloog.git] / packaging / cloog.spec
1 %define keepstatic 1
2
3 Name:           cloog
4 Version:        0.15.10
5 Release:        0
6 Summary:        The Chunky Loop Generator
7 License:        GPL-2.0+
8 Group:          Development/Languages/C and C++
9 Url:            http://www.cloog.org/
10 Source:         cloog-ppl-0.15.10.tar.bz2
11 Source1:        baselibs.conf
12 Source1001:     cloog.manifest
13 BuildRequires:  libtool
14 BuildRequires:  ppl-devel
15
16 %description
17 CLooG is a free software and library to generate code for scanning
18 Z-polyhedra. It is used by the GCC Graphite optimization framework.
19
20 %package devel
21 Summary:        Development tools for CLOOG
22 Group:          Development/Languages/C and C++
23 Requires:       libcloog = %{version}-%{release}
24
25 %description devel
26 Development tools and headers for the Chunky Loop Generator.
27
28 %package -n libcloog
29 Summary:        The CLOOG shared library
30 Group:          Development/Languages/C and C++
31
32 %description -n libcloog
33 The shared library for the Chunky Loop Generator.
34
35 %prep
36 %setup -q -n cloog-ppl-0.15.10
37 cp %{SOURCE1001} .
38
39 %build
40 ./autogen.sh
41 %configure --with-ppl
42 make %{_smp_mflags}
43
44 %check
45 make %{_smp_mflags} check
46
47 %install
48 %make_install
49
50 %post -n libcloog -p /sbin/ldconfig
51
52 %postun -n libcloog -p /sbin/ldconfig
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-,root,root,-)
57 %{_bindir}/cloog
58 %doc %{_infodir}/cloog.info*gz
59
60 %files -n libcloog
61 %manifest %{name}.manifest
62 %defattr(-,root,root,-)
63 %{_libdir}/libcloog.so.*
64
65 %files devel
66 %manifest %{name}.manifest
67 %defattr(-,root,root,-)
68 %{_includedir}/cloog
69 %{_libdir}/libcloog.so
70 %{_libdir}/libcloog.a
71
72 %changelog