Initial Import
[profile/ivi/check.git] / packaging / check.spec
1 Name:       check
2 Summary:    A unit test framework for C
3 Version:    0.9.8
4 Release:    1
5 Group:      Development/Tools
6 License:    LGPLv2+
7 URL:        http://check.sourceforge.net/
8 Source0:    http://download.sourceforge.net/check/%{name}-%{version}.tar.gz
9 Requires(post):  /sbin/ldconfig
10 Requires(postun):  /sbin/ldconfig
11 BuildRequires: autoconf, automake, libtool, texinfo
12
13 %description
14 Check is a unit test framework for C. It features a simple interface for 
15 defining unit tests, putting little in the way of the developer. Tests 
16 are run in a separate address space, so Check can catch both assertion 
17 failures and code errors that cause segmentation faults or other signals. 
18 The output from unit tests can be used within source code editors and IDEs.
19
20
21
22 %package devel
23 Summary:    Libraries and headers for developing programs with check
24 Group:      Development/Libraries
25 Requires:   %{name} = %{version}-%{release}
26 Requires:   pkgconfig
27
28 %description devel
29 Libraries and headers for developing programs with check
30
31
32 %prep
33 %setup -q -n %{name}-%{version}
34
35 %build
36
37 ./autogen.sh
38 %configure
39 # Call make instruction with smp support
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
47
48 %clean
49 rm -rf %{buildroot}
50
51
52
53 %post -p /sbin/ldconfig
54
55 %postun -p /sbin/ldconfig
56
57
58
59 %files
60 %defattr(-,root,root,-)
61 %doc COPYING.LESSER README
62 %{_libdir}/libcheck.so.*
63 %doc %{_infodir}/check*
64 %doc /usr/share/doc/check
65
66
67 %files devel
68 %defattr(-,root,root,-)
69 %{_includedir}/check.h
70 %{_libdir}/libcheck.so
71 %{_libdir}/pkgconfig/check.pc
72 %{_datadir}/aclocal/check.m4
73