c9f1679ae4293ee1688aa8076ce5c46841dedbf8
[platform/upstream/check.git] / packaging / check.spec
1 Name:           check
2 Version:        0.9.8
3 Release:        3
4 License:        LGPL-2.1+
5 Summary:        Unit Test Framework for C
6 Url:            http://check.sourceforge.net/
7 Group:          Development/Libraries/C and C++
8 Source:         %{name}-%{version}.tar.bz2
9 Source99:       baselibs.conf
10 Source1001:     check.manifest
11 BuildRequires:  pkg-config
12
13 %description
14 Check is a unit test framework for C. It features a simple interfacefor
15 defining unit tests, limitating the developer the less possible. Tests
16 are run in a separate address space, so Check cancatch both, assertion
17 failures and code errors that cause segmentationfaults or other
18 signals. The output of unit tests can be used within source code
19 editors and IDEs.
20
21 %package devel
22 License:        LGPL-2.1+
23 Summary:        Unit Test Framework for C
24 Group:          Development/Libraries/C and C++
25 Requires:       %{name} = %{version}
26 Requires:       glibc-devel
27 Recommends:     pgk-config
28
29 %description devel
30 Check is a unit test framework for C. It features a simple interface
31 for defining unit tests, putting little in the way of the developer.
32 Tests are run in a separate address space, so Check can catch both
33 assertion failures and code errors that cause segmentation faults or
34 other signals. The output from unit tests can be used within source
35 code editors and IDEs.
36
37 %prep
38 %setup -q
39 cp %{SOURCE1001} .
40
41 %build
42 export CFLAGS="%{optflags} -std=gnu99"
43 export CXXFLAGS="%{optflags} -std=gnu99"
44 export FFLAGS="%{optflags} -std=gnu99"
45 %configure --disable-static --with-pic
46 make %{?_smp_mflags} 
47
48 %install
49 %make_install 
50
51 %remove_docs
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56
57 %files
58 %manifest %{name}.manifest
59 %defattr (-, root, root)
60 %license COPYING.*
61 %{_libdir}/*.so.*
62
63 %files devel
64 %manifest %{name}.manifest
65 %defattr (-, root, root)
66 %dir %{_datadir}/aclocal
67 %{_datadir}/aclocal/*.m4
68 %{_includedir}/*.h
69 %{_libdir}/*.so
70 %{_libdir}/pkgconfig/*.pc
71
72 %changelog