[Check]: Disable the document to correct build error.
[platform/upstream/check.git] / packaging / check.spec
1 Name:           check
2 Version:        0.14.0
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        Unit Test Framework for C
6 Url:            http://check.sourceforge.net/
7 Group:          Development/Libraries/C and C++
8 Source:         %{name}-%{version}.tar.bz2
9 Source99:       baselibs.conf
10 Source1001:      check.manifest
11 BuildRequires:  pkg-config
12
13 %description
14 Check is a unit test framework for C. It features a simple interfacefor
15 defining unit tests, limitating the developer the less possible. Tests
16 are run in a separate address space, so Check cancatch both, assertion
17 failures and code errors that cause segmentationfaults or other
18 signals. The output of unit tests can be used within source code
19 editors and IDEs.
20
21 %package devel
22 License:        LGPL-2.1+
23 Summary:        Unit Test Framework for C
24 Group:          Development/Libraries/C and C++
25 Requires:       %{name} = %{version}
26 Requires:       glibc-devel
27 Recommends:     pkg-config
28
29 %description devel
30 Check is a unit test framework for C. It features a simple interface
31 for defining unit tests, putting little in the way of the developer.
32 Tests are run in a separate address space, so Check can catch both
33 assertion failures and code errors that cause segmentation faults or
34 other signals. The output from unit tests can be used within source
35 code editors and IDEs.
36
37 %prep
38 %setup -q
39 cp %{SOURCE1001} .
40
41 %build
42 export CFLAGS="%{optflags} -std=gnu99"
43 export CXXFLAGS="%{optflags} -std=gnu99"
44 export FFLAGS="%{optflags} -std=gnu99"
45 autoreconf -ivf
46 %configure --disable-static --with-pic --disable-build-docs
47 make %{?_smp_mflags} 
48
49 %install
50 %make_install 
51
52 %remove_docs
53 %post -p /sbin/ldconfig
54
55 %postun -p /sbin/ldconfig
56
57
58 %files
59 %manifest %{name}.manifest
60 %defattr (-, root, root)
61 %license COPYING.*
62 %exclude %{_bindir}/checkmk
63 %{_libdir}/*.so.*
64
65 %files devel
66 %manifest %{name}.manifest
67 %defattr (-, root, root)
68 %dir %{_datadir}/aclocal
69 %{_datadir}/aclocal/*.m4
70 %{_includedir}/*.h
71 %{_libdir}/*.so
72 %{_libdir}/pkgconfig/*.pc
73
74 %changelog