The base model is changed
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
1 %define ENABLE_DOWNLOAD_PROVIDER 1
2
3 Name:   capi-web-url-download
4 Summary:        CAPI for content download with web url
5 Version:        0.0.7
6 Release:        2
7 Group:          TO_BE_FILLED_IN
8 License:        TO_BE_FILLED_IN
9 URL:            N/A
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires: pkgconfig(capi-base-common)
12 BuildRequires: pkgconfig(bundle)
13 BuildRequires: pkgconfig(dlog)
14 %if %ENABLE_DOWNLOAD_PROVIDER
15 BuildRequires: pkgconfig(capi-appfw-app-manager)
16 BuildRequires: pkgconfig(capi-appfw-application)
17 BuildRequires: pkgconfig(download-provider)
18 %else
19 BuildRequires: pkgconfig(libdownload-agent)
20 %endif
21 BuildRequires: cmake
22 BuildRequires: expat-devel
23
24 %description
25 CAPI for the content download
26
27 %package devel
28 Summary:    url download
29 Group:      Development/Libraries
30 Requires:   %{name} = %{version}-%{release}
31
32 %description devel
33 CAPI for content downloading with web url (developement files)
34
35 %prep
36 %setup -q
37
38 %build
39 cmake . -DCMAKE_INSTALL_PREFIX="/"
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47 %post -p /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %defattr(-,root,root,-)
53 /usr/lib/libcapi-web-url-download.so
54
55 %files devel
56 %defattr(-,root,root,-)
57 /usr/lib/libcapi-web-url-download.so
58 /usr/lib/pkgconfig/capi-web-url-download.pc
59 /usr/include/web/url_download.h
60
61 %changelog
62 * Mon Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
63 - Add new APIs for notification function
64 - The TC is changed due to change of url_download_start
65 - When unseting the callback function, the callback should be initialized although the error is happened.
66 - It remove the stop function when is called twice when destroying handle
67 - Add pc requries for app.h
68
69 * Mon Aug 08 2012 Jungki Kwak <jungki.kwak@samsung.com>
70 - Change requestid to INTEGER from String
71
72 * Mon Aug 06 2012 Jungki Kwak <jungki.kwak@samsung.com>
73 - The base model is changed to download provider daemon
74