upload tizen1.0 source
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
1
2 Name:   capi-web-url-download
3 Summary:        CAPI for content download with web url
4 Version:        0.0.3
5 Release:        1
6 Group:          TO_BE_FILLED_IN
7 License:        TO_BE_FILLED_IN
8 URL:            N/A
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-base-common)
11 BuildRequires: pkgconfig(libdownload-agent)
12 BuildRequires: pkgconfig(bundle)
13 BuildRequires: pkgconfig(dlog)
14 BuildRequires: cmake
15 BuildRequires: expat-devel
16
17 %description
18 CAPI for the content download
19
20 %package devel
21 Summary:    url download
22 Group:      Development/Libraries
23 Requires:   %{name} = %{version}-%{release}
24
25 %description devel
26 CAPI for content downloading with web url (developement files)
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX="/usr/lib"
33
34 make %{?jobs:-j%jobs}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %defattr(-,root,root,-)
46 /usr/lib/libcapi-web-url-download.so
47
48 %files devel
49 %defattr(-,root,root,-)
50 /usr/lib/libcapi-web-url-download.so
51 /usr/lib/pkgconfig/capi-web-url-download.pc
52 /usr/include/web/url_download.h
53