Release a package
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
1
2 Name:   capi-web-url-download
3 Summary:        CAPI for content download with web url
4 Version:        0.0.8
5 Release:        8
6 Group:          TO_BE_FILLED_IN
7 License:        TO_BE_FILLED_IN
8 URL:            N/A
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-base-common)
11 BuildRequires: pkgconfig(bundle)
12 BuildRequires: pkgconfig(dlog)
13 BuildRequires: pkgconfig(capi-appfw-app-manager)
14 BuildRequires: pkgconfig(capi-appfw-application)
15 BuildRequires: pkgconfig(download-provider)
16 BuildRequires: cmake
17 BuildRequires: expat-devel
18
19 %description
20 CAPI for the content download
21
22 %package devel
23 Summary:    url download
24 Group:      Development/Libraries
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 CAPI for content downloading with web url (developement files)
29
30 %prep
31 %setup -q
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX="/"
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %defattr(-,root,root,-)
48 /usr/lib/libcapi-web-url-download.so
49
50 %files devel
51 %defattr(-,root,root,-)
52 /usr/lib/libcapi-web-url-download.so
53 /usr/lib/pkgconfig/capi-web-url-download.pc
54 /usr/include/web/url_download.h
55
56 %changelog
57 * Thu Sep 06 2012 Kwangmin Bang <justine.bang@samsung.com>
58 - check the state before clear socket
59 - add limitation in already completed state
60 - add checking INVALID_STATE error
61
62 * Tue Sep 04 2012 Jungki Kwak <jungki.kwak@samsung.com>
63 - Remove unused code which is base on libdownload-agent
64 - Change the name of application operation
65 - Add exception handling for non requestid
66 - Call clear_provider after getting the state
67 - url_download_get_state return IO error
68 - Resolve prevent defects
69
70 * Mon Sep 03 2012 Kwangmin Bang <justine.bang@samsung.com>
71 - stop the download even if no socket or callback
72 - pause/resume the download even if no socket or callback
73 - calling stopped callback in error case
74 - request STOP for free after finished download
75
76 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
77 - maxfd should be updated before created event thread
78
79 * Thu Aug 30 2012 Kwangmin Bang <justine.bang@samsung.com>
80 - remove duplicated call for creating socket
81 - fix the crash regarding pthread_kill
82 - allow to call url_download_stop in case of PAUSED state
83
84 * Mon Aug 27 2012 Kwangmin Bang <justine.bang@samsung.com>
85 - one thread model for event
86 - get state info from download-provider even if no connection
87 - fix the bug take a long time to receive first event
88
89 * Tue Aug 22 2012 Jungki Kwak <jungki.kwak@samsung.com>
90 - Enhance the exception handling in event thread
91 - Resolve a bug about state
92 - Add to pass service handle data to download daemon
93
94 * Mon Aug 17 2012 Jungki Kwak <jungki.kwak@samsung.com>
95 - Resolve a bug when getting a state
96 - Add error case for invalid id
97
98 * Mon Aug 16 2012 Jungki Kwak <jungki.kwak@samsung.com>
99 - Add new APIs for notification function
100 - The TC is changed due to change of url_download_start
101 - When unseting the callback function, the callback should be initialized although the error is happened.
102 - It remove the stop function when is called twice when destroying handle
103 - Add pc requries for app.h
104
105 * Mon Aug 08 2012 Jungki Kwak <jungki.kwak@samsung.com>
106 - Change requestid to INTEGER from String
107
108 * Mon Aug 06 2012 Jungki Kwak <jungki.kwak@samsung.com>
109 - The base model is changed to download provider daemon
110