Initialize Tizen 3.0
[framework/api/url-download.git] / packaging / capi-web-url-download.spec
1
2 Name:   capi-web-url-download
3 Summary:        CAPI for content download with web url
4 Version:        1.1.1
5 Release:        0
6 Group:          Development/Libraries
7 License:        Apache-2.0
8 URL:            https://review.tizen.org/git/?p=platform/core/api/url-download.git;a=summary
9 Source0:        %{name}-%{version}.tar.gz
10 BuildRequires: pkgconfig(capi-base-common)
11 BuildRequires: pkgconfig(dlog)
12 BuildRequires: pkgconfig(bundle)
13 BuildRequires: pkgconfig(download-provider-interface)
14 BuildRequires: cmake
15
16 %description
17 Core APIs for the content download with web url
18
19 %package devel
20 Summary:        CAPI web url development files
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}-%{release}
23
24 %description devel
25 CAPI for content downloading with web url (development files)
26
27 %prep
28 %setup -q
29
30 %build
31 %if 0%{?tizen_build_binary_release_type_eng}
32 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
33 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
34 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
35 %endif
36 %cmake .
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43 mkdir -p %{buildroot}/usr/share/license
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %defattr(-,root,root,-)
51 %manifest capi-web-url-download.manifest
52 %{_libdir}/libcapi-web-url-download.so.*
53 /usr/share/license/%{name}
54
55 %files devel
56 %defattr(-,root,root,-)
57 %manifest capi-web-url-download.manifest
58 %{_libdir}/libcapi-web-url-download.so
59 %{_libdir}/pkgconfig/capi-web-url-download.pc
60 %{_includedir}/web/download.h
61 %{_includedir}/web/download_doc.h
62
63 %changelog