7fb0ae383a66718bf56ff51db9a5ef7913491201
[platform/core/api/efl-util.git] / packaging / capi-ui-efl-util.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       capi-ui-efl-util
5 Summary:    An EFL utility library in SLP C API
6 Version:    0.1.2
7 Release:    1
8 Group:      Graphics & UI Framework/API
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 Source1001:     capi-ui-efl-util.manifest
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(dlog)
14 %if %{with x}
15 BuildRequires:  pkgconfig(x11)
16 BuildRequires:  pkgconfig(utilX)
17 BuildRequires:  pkgconfig(ecore-x)
18 %endif
19 BuildRequires:  pkgconfig(elementary)
20 BuildRequires:  pkgconfig(capi-base-common)
21
22 %description
23 An EFL utility library in SLP C API.
24
25
26 %package devel
27 Summary:  An EFL utility library in SLP C API (Development)
28 Requires: %{name} = %{version}-%{release}
29
30 %description devel
31 %devel_desc
32
33 %prep
34 %setup -q
35 cp %{SOURCE1001} .
36
37
38 %build
39 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
40 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
41 %if %{with wayland}
42 -DWITH_WAYLAND=TRUE
43 %endif
44 %if %{with x}
45 -DWITH_X11=TRUE
46 %endif
47
48 make %{?jobs:-j%jobs}
49
50 %install
51 %make_install
52
53 # for license notification
54 mkdir -p %{buildroot}/usr/share/license
55 cp -a LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
56
57 %post -p /sbin/ldconfig
58
59 %postun -p /sbin/ldconfig
60
61
62 %files
63 %manifest %{name}.manifest
64 %license LICENSE.APLv2
65 %{_libdir}/libcapi-ui-efl-util.so.*
66 /usr/share/license/%{name}
67
68 %files devel
69 %manifest %{name}.manifest
70 %{_includedir}/ui/efl_util.h
71 %{_libdir}/pkgconfig/*.pc
72 %{_libdir}/libcapi-ui-efl-util.so
73 %exclude %{_includedir}/ui/config.h