ecd39ec92df48f3946a834f4c831e68eab60adfa
[platform/core/uifw/autofill.git] / packaging / capi-ui-autofill.spec
1 Name:       capi-ui-autofill
2 Summary:    Autofill Library
3 Version:    0.1.21
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  tidl
10 BuildRequires:  pkgconfig(libtzplatform-config)
11 BuildRequires:  pkgconfig(capi-base-common)
12 BuildRequires:  pkgconfig(capi-appfw-service-application)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(eina)
15 BuildRequires:  pkgconfig(efl)
16 BuildRequires:  pkgconfig(rpc-port)
17 BuildRequires:  pkgconfig(glib-2.0)
18 BuildRequires:  pkgconfig(cynara-client)
19 BuildRequires:  pkgconfig(cynara-session)
20 BuildRequires:  pkgconfig(capi-appfw-app-manager)
21 BuildRequires:  pkgconfig(capi-appfw-preference)
22 Requires(post): /sbin/ldconfig
23 Requires(postun): /sbin/ldconfig
24
25 %description
26 Autofill Library
27
28
29 %package devel
30 Summary:  Autofill Library (Development)
31 Group:    Development/Libraries
32 Requires: %{name} = %{version}-%{release}
33
34 %description devel
35 Autofill Library (Development)
36
37 %package -n capi-ui-autofill-common
38 Summary:  Autofill Common Library
39 Group:    Graphics & UI Framework/Input
40 Requires: %{name} = %{version}-%{release}
41
42 %description -n capi-ui-autofill-common
43 Autofill Common Library
44
45 %package -n capi-ui-autofill-common-devel
46 Summary:  Autofill Common Library (Development)
47 Group:    Graphics & UI Framework/Input
48 Requires: %{name} = %{version}-%{release}
49
50 %description -n capi-ui-autofill-common-devel
51 Autofill Common Library (Development)
52
53
54 %package -n capi-ui-autofill-service
55 Summary:  Autofill Service Library
56 Group:    Graphics & UI Framework/Input
57 Requires: %{name} = %{version}-%{release}
58
59 %description -n capi-ui-autofill-service
60 Autofill Service Library
61
62
63 %package -n capi-ui-autofill-service-devel
64 Summary:  Autofill Service Library (Development)
65 Group:    Graphics & UI Framework/Input
66 Requires: %{name} = %{version}-%{release}
67
68 %description -n capi-ui-autofill-service-devel
69 Autofill Service Library (Development)
70
71
72 %package -n capi-ui-autofill-manager
73 Summary:  Autofill Manager Library
74 Group:    Graphics & UI Framework/Input
75 Requires: %{name} = %{version}-%{release}
76
77 %description -n capi-ui-autofill-manager
78 Autofill Manager Library
79
80
81 %package -n capi-ui-autofill-manager-devel
82 Summary:  Autofill Manager Library (Development)
83 Group:    Graphics & UI Framework/Input
84 Requires: %{name} = %{version}-%{release}
85
86 %description -n capi-ui-autofill-manager-devel
87 Autofill Manager Library (Development)
88
89
90 %prep
91 %setup -q
92
93 tidlc -p -l C -i tidl/autofill.tidl -o autofill_proxy
94 mv autofill_proxy.h ./client/
95 mv autofill_proxy.c ./client/
96
97 tidlc -s -l C -i tidl/autofill_service.tidl -o autofill_service_stub
98 mv autofill_service_stub.h ./service_lib/
99 mv autofill_service_stub.c ./service_lib/
100
101 tidlc -p -l C -i tidl/autofill_manager.tidl -o autofill_manager_proxy
102 mv autofill_manager_proxy.h ./manager/
103 mv autofill_manager_proxy.c ./manager/
104
105
106 %build
107
108 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
109 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden -Werror"
110 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
111
112 rm -rf CMakeFiles
113 rm -rf CMakeCache.txt
114 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
115 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
116 make %{?jobs:-j%jobs}
117
118 %install
119 rm -rf %{buildroot}
120 %make_install
121
122 %post
123 /sbin/ldconfig
124
125 %postun -p /sbin/ldconfig
126
127
128 %files
129 %manifest client/capi-ui-autofill.manifest
130 %{_libdir}/libcapi-ui-autofill.so.*
131 %license LICENSE
132
133 %files -n capi-ui-autofill-common
134 %manifest common/capi-ui-autofill-common.manifest
135 %{_libdir}/libcapi-ui-autofill-common.so.*
136 %license LICENSE
137
138 %files -n capi-ui-autofill-common-devel
139 %{_includedir}/autofill_common*.h
140 %{_includedir}/autofill_error.h
141 %{_libdir}/pkgconfig/capi-ui-autofill-common.pc
142 %{_libdir}/libcapi-ui-autofill-common.so
143
144 %files devel
145 %{_includedir}/autofill.h
146 %{_libdir}/pkgconfig/capi-ui-autofill.pc
147 %{_libdir}/libcapi-ui-autofill.so
148
149 %files -n capi-ui-autofill-service
150 %manifest service_lib/capi-ui-autofill-service.manifest
151 %{_libdir}/libcapi-ui-autofill-service.so.*
152 %license LICENSE
153
154 %files -n capi-ui-autofill-service-devel
155 %{_includedir}/autofill_service*.h
156 %{_libdir}/pkgconfig/capi-ui-autofill-service.pc
157 %{_libdir}/libcapi-ui-autofill-service.so
158
159 %files -n capi-ui-autofill-manager
160 %manifest manager/capi-ui-autofill-manager.manifest
161 %{_libdir}/libcapi-ui-autofill-manager.so.*
162 %license LICENSE
163
164 %files -n capi-ui-autofill-manager-devel
165 %{_includedir}/autofill_error.h
166 %{_includedir}/autofill_manager*.h
167 %{_libdir}/pkgconfig/capi-ui-autofill-manager.pc
168 %{_libdir}/libcapi-ui-autofill-manager.so