remove hardcoded path for multiuser support
[platform/core/api/usb-accessory.git] / packaging / capi-system-usb-accessory.spec
1 Name:           capi-system-usb-accessory
2 Version:        0.0.9
3 Release:        1
4 VCS:            platform/core/api/usb-accessory#accepted/tizen/20130520.100842-0-g0fb5aab8f1efb2d0fa391a0c1e2938b80aab2d45-dirty
5 License:        Apache-2.0
6 Summary:        A USB accessory library in TIZEN C API
7 Group:          System/API
8 Source0:        %{name}-%{version}.tar.gz
9 Source1:        capi-system-usb-accessory.manifest
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(capi-base-common)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(libtzplatform-config)
17
18 %description
19 A USB accessory library in TIZEN C API.
20
21 %package devel
22 Summary:        A accessory library in TIZEN C API (Development)
23 Group:          Development/System
24 Requires:       %{name} = %{version}
25
26 %description devel
27 %devel_desc
28
29 %prep
30 %setup -q
31
32
33 %build
34 cp %{SOURCE1} .
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
37
38 make %{?_smp_mflags}
39
40 %install
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47 %files
48 %manifest %{name}.manifest
49 %license LICENSE.Apache_v2
50 %manifest capi-system-usb-accessory.manifest
51 %{_libdir}/libcapi-system-usb-accessory.so.*
52
53 %files devel
54 %manifest %{name}.manifest
55 %{_includedir}/system/usb_accessory.h
56 %{_libdir}/pkgconfig/*.pc
57 %{_libdir}/libcapi-system-usb-accessory.so