3f6cfd92c6db500f695ce57e17d3b5468377b244
[platform/core/api/usb-accessory.git] / packaging / capi-system-usb-accessory.spec
1 Name:           capi-system-usb-accessory
2 Version:        0.0.9
3 Release:        1
4 VCS:            platform/core/api/usb-accessory#accepted/tizen/20130520.100842-0-g0fb5aab8f1efb2d0fa391a0c1e2938b80aab2d45-dirty
5 License:        Apache-2.0
6 Summary:        A USB accessory library in TIZEN C API
7 Group:          System/API
8 Source0:        %{name}-%{version}.tar.gz
9 Source1:        capi-system-usb-accessory.manifest
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(aul)
12 BuildRequires:  pkgconfig(capi-base-common)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(vconf)
16 %description
17 A USB accessory library in TIZEN C API.
18
19 %package devel
20 Summary:        A accessory library in TIZEN C API (Development)
21 Group:          Development/System
22 Requires:       %{name} = %{version}
23
24 %description devel
25 %devel_desc
26
27 %prep
28 %setup -q
29
30
31 %build
32 cp %{SOURCE1} .
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
34 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
35
36 make %{?_smp_mflags}
37
38 %install
39 %make_install
40
41 %post -p /sbin/ldconfig
42
43 %postun -p /sbin/ldconfig
44
45 %files
46 %manifest %{name}.manifest
47 %license LICENSE.Apache_v2
48 %manifest capi-system-usb-accessory.manifest
49 %{_libdir}/libcapi-system-usb-accessory.so.*
50
51 %files devel
52 %manifest %{name}.manifest
53 %{_includedir}/system/usb_accessory.h
54 %{_libdir}/pkgconfig/*.pc
55 %{_libdir}/libcapi-system-usb-accessory.so