capi-system-sensor: version 0.2.2
[platform/core/api/sensor.git] / packaging / capi-system-sensor.spec
1 Name:       capi-system-sensor
2 Summary:    A Sensor library in TIZEN C API
3 Version:    0.2.2
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0 and PD
7 Source0:    %{name}-%{version}.tar.gz
8 Source1:    capi-system-sensor.manifest
9
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(sensor)
13 BuildRequires:  pkgconfig(capi-base-common)
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16
17 %description
18 A Sensor Library in TIZEN C API package.
19
20 %package devel
21 Summary:  A Sensor library in TIZEN C API (Development)
22 Group:    System/Development
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26 A Sensor library in TIZEN C API package (Development).
27 %devel_desc
28
29 %prep
30 %setup -q
31
32 %build
33 cp %{SOURCE1} .
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
36 %__make %{?_smp_mflags}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %manifest capi-system-sensor.manifest
48 %{_libdir}/libcapi-system-sensor.so.*
49 %license LICENSE.APLv2
50
51 %files devel
52 %manifest capi-system-sensor.manifest
53 %license LICENSE.APLv2
54 %{_libdir}/libcapi-system-sensor.so
55 %{_libdir}/pkgconfig/*.pc
56 %{_includedir}/sensor/*.h
57