sensord: delete the duplicated manifest file and clean up spec file
[platform/core/api/sensor.git] / packaging / capi-system-sensor.spec
1 Name:       capi-system-sensor
2 Summary:    A Sensor library in TIZEN C API
3 Version:    0.2.2
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0 and PD
7 Source0:    %{name}-%{version}.tar.gz
8
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(sensor)
12 BuildRequires:  pkgconfig(capi-base-common)
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15
16 %description
17 A Sensor Library in TIZEN C API package.
18
19 %package devel
20 Summary:  A Sensor library in TIZEN C API (Development)
21 Group:    System/Development
22 Requires: %{name} = %{version}-%{release}
23
24 %description devel
25 A Sensor library in TIZEN C API package (Development).
26 %devel_desc
27
28 %prep
29 %setup -q
30
31 %build
32 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
33 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
34 %__make %{?_smp_mflags}
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %post -p /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %files
45 %manifest packaging/capi-system-sensor.manifest
46 %{_libdir}/libcapi-system-sensor.so.*
47 %license LICENSE.APLv2
48
49 %files devel
50 %manifest packaging/capi-system-sensor.manifest
51 %{_libdir}/libcapi-system-sensor.so
52 %{_libdir}/pkgconfig/*.pc
53 %{_includedir}/sensor/*.h
54 %license LICENSE.APLv2