upload tizen1.0 source
[framework/api/runtime-info.git] / packaging / capi-system-runtime-info.spec
1 Name:       capi-system-runtime-info
2 Summary:    A Runtime Information library in Tizen Native API
3 Version:    0.0.1
4 Release:    4
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(vconf)
11 BuildRequires:  pkgconfig(capi-base-common)
12 Requires(post): /sbin/ldconfig  
13 Requires(postun): /sbin/ldconfig
14
15 %description
16
17
18 %package devel
19 Summary:  A Runtime Information library in Tizen Native API (Development)
20 Group:    TO_BE/FILLED_IN
21 Requires: %{name} = %{version}-%{release}
22 Requires:  pkgconfig(capi-base-common)
23
24 %description devel
25
26
27
28 %prep
29 %setup -q
30
31
32 %build
33 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`  
34 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER} 
35
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %{_libdir}/lib*.so.*
50
51 %files devel
52 %{_includedir}/system/*.h
53 %{_libdir}/pkgconfig/*.pc
54 %{_libdir}/lib*.so
55
56