Fix manifests
[platform/core/api/runtime-info.git] / packaging / capi-system-runtime-info.spec
1 Name:       capi-system-runtime-info
2 Summary:    A Runtime Information library in Tizen Native API
3 Version:    0.0.3
4 Release:    0
5 Group:      System/API
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     %{name}.manifest
9 Source1002:     %{name}-devel.manifest
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(capi-base-common)
14
15 %description
16 A Runtime Information library in Tizen Native API.
17
18 %package devel
19 Summary:  A Runtime Information library in Tizen Native API (Development)
20 Group:    Development/System
21 Requires: %{name} = %{version}-%{release}
22 Requires:  pkgconfig(capi-base-common)
23
24 %description devel
25 %devel_desc
26
27
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} %{SOURCE1002} .
32
33
34 %build
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
37
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 %make_install
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48
49 %files
50 %manifest %{name}.manifest
51 %license LICENSE.APLv2
52 %{_libdir}/lib*.so.*
53
54 %files devel
55 %manifest %{name}-devel.manifest
56 %{_includedir}/system/*.h
57 %{_libdir}/pkgconfig/*.pc
58 %{_libdir}/lib*.so
59
60